IRC channel logs

2020-01-05.log

back to list of logs

<jcowan>Fluids interact badly with threads, so I'd avoid them
***daviid is now known as Guest82422
<crab1>Hey, I'm playing with the guile web server, and I can't find all the different options for content-type in the manual anywhere, can anyone help?
<sneek>Welcome back crab1, you have 1 message.
<sneek>crab1, atw says: could you post your operating-system config and talk a bit about how you're installing?
<wingo>jcowan: the whole point of fluids is to interact nicely with threads.
<bandali>wingo, have you seen this? https://drewdevault.com/2020/01/04/Slow.html
<bandali>made me curious what the number of syscalls for a guile hello world looked like
<bandali>so i wrote
<bandali>#!/home/bandali/.guix-profile/bin/guile -s
<bandali>!#
<bandali>(display "hello world")
<bandali>and then
<bandali>strace -o trace ./hello.scm
<bandali>wc -l trace
<bandali>gave me 698
<bandali>which...is quite a few :p that’s with guile 2.2.6
<bandali>anyone know what it looks like with the 2.9.x series?
<terpri>bandali, 947 with guile-next, after running it once for auto-compilation
<bandali>oof
<bandali>terpri, thanks for the data point
<bandali>that’s even more than node and julia, but still less than cpython and ruby, i guess
<spk121>there's a thread over on bug-make about how Make targets C90 but "libguile.h" headers aren't C90 compatible
<spk121>so the Guile extension for make is problematic
<mwette>on 8/3/19 wingo sent to guile-devel this: "** scm_t_uint8, etc deprecated in favor of C99 stdint.h"
<spk121>looks like GNU Make's strategy is going to be to more completely avoid parsing libguile.h when not using the Guile extension
<mwette>and 6/23/18 wingo posted email to guile-devel w/ subject "c99 support"
<mwette>no one caught the make dependence I guess
<ArneBab>Realized today that I’ve already been working with Guile for over 5 years
<mwette>ArneBab: nice work -- I first worked w/ Guile late 90's with mostly 1.6 (maybe 1.4?); then quit for a while and came back when it was 2.0
<ArneBab>I got my basics for dryads-wake ready toady: https://hg.sr.ht/~arnebab/dryads-wake/browse/d5056953e3def507f580acc0feb61ffbb221deaa/dryads-wake.w#L32
<ArneBab>This is now natural script writing with structure
<ArneBab>calling functions inline within dialog via ,(fun), while having full access to all of Guile
<wingo>spk121: why does gnu make target c90 ?
<wingo>anyway they can always include gnulib stdint.h before including libguile afaiu
<wingo>or stay with guile 2.2 in the meantime
<spk121>wingo: i doubt there are any systems that have native compiler that is c89/c90 and that also can compile Guile. Pretty much, Guile is linux, cygwin, and some BSDs only in terms of portability, so the gcc (or clang of OpenBSD) are all c99+. Windows native C compiler is C89
*wingo nod
<jcowan>wingo: Oh, sorry, Guile fluids /= SRFI 15 fluids, which are the bad fluids. But I still agree with the Guile docs: use parameters instead
<jcowan>I ran the strace and wc -l on (display "hello world") with the Chicken interpreter (lines) and a Chicken-compiled version (421 lines).
<jcowan>s/lines/593 lines
<lxsameer>hey folks, I'm new to Guile. Is it a interpreter only language or does it have an actual compiler to compile scheme to native binday image ?
<daviid>lxsameer: https://www.gnu.org/software/guile/
<lxsameer>daviid: yeah i saw the web page