IRC channel logs

2020-01-02.log

back to list of logs

***catonano_ is now known as catonano
***karlosz_ is now known as karlosz
<tsmish>hi #guile. I didn't really study this thoroughly, so sorry if this is documented somewhere, but why does (equal? (vector-ref #('a) 0) 'a) evaluate to #f.
<brettgilio>tsmish: because there is a difference in the object accessing a vector of position 0 being 'a and the object 'a itself. I think instead of equality you want matching.
<tsmish>brettgilio: errm, I still don't understand. Don't symbols eq? each other if their string representation match.
<brettgilio>tsmish: Scheme Procedure: eq?99,99 x y99,99C Function: scm_eq_p99,99 (x, y)99,99
<brettgilio>Return #t if x and y are the same object, except for numbers and characters. For example,
<brettgilio>(define x (vector 1 2 3)) (define y (vector 1 2 3)) (eq? x x) ⇒ #t (eq? x y) ⇒ #f
<brettgilio>The docs seem to say no
<brettgilio>In other words, equality checks for object memory spaces, not representations.
<brettgilio>Which is why I suggest you use pattern matching instead
<tsmish>brettgilio: these are vectors, not symbols. I compare symbol with symbol. Docs say that eq? can be used while comparing symbols, it's said in Equality section for eq?.
<tsmish>please note that i compare result of vector-ref (which should give me a symbol) with 'a.
<tsmish>Also i use equal? which should work for majority of cases, anyway.
<brettgilio>tsmish: what do the pointers of memq return for each object?
<tsmish>brettgilio: ok, i actually need assistance on this one. What do you mean by pointers of memq?
<chrislck>tsmith: the problem is #('a) is not the same as (vector 'a)
<brettgilio>chrislck: agreed
<chrislck>tmisth: #('a) == (vector ''a) == (vector (quote 'a)) == (vector (quote (quote a)))
<chrislck>remember 'a != ''a
<tsmish>oh, i see. #(a) quotes a.
<chrislck># also quotes similar to '
<tsmish>(equal? (vector-ref #('a) 0) ''a) actually evaluates to #t. thanks.
<chrislck>or, (equal? (vector-ref #(a) 0) 'a) ==> #t
<wingo>happy new year's, ppl :)
<daviid>hey hey, happy new year all indeed!
<chrislck>(set! year 2020) (yay)
<daviid>anyone has a haunt powered website somewhere that includes the fsf header and footer?
<wingo>yay, fixed that compile error that people were seeing
<wingo>happily it was neither a jit nor an optimizer bug :P
<wingo>so
<wingo>2.9.8 tomorrow i guess??
<wingo>or today, why not
<wingo> https://www.gnu.org/software/guile/news/gnu-guile-298-beta-released.html
<Wojciech_K>\o/
<wingo>mwette: just made a new release that should fix the ubuntu 18.04 issue
<mwette>wingo: compiling now ...
<mwette>wingo: make and make check succeeds w/ 2.9.8 on Ubunu 18.04 / x86_64
<mwette>there were a number of warnings of the form "using load, use #:delcarative? #f"
<jcowan>It seems to be a common error to think that #(...) is shorthand for a vector constructor, like [...] in Python, rather than a literal.
<jcowan>wingo: testing new release on Cygwin and Ubuntu 16.04, both of which were failing
***ng0_ is now known as ng0
***Server sets mode: +nt
<civodul>oh, new Guile release!
<civodul>yay!
<davexunit>8)
<nerdypepper>nice!
<wingo>moo
<wingo>lloda: can you think of any blockers for 3.0 ?
<wingo>i.e. things that can't be fixed during 3.0 and that can't wait for 3.2
<wingo>or anyone else, obvs
<wingo>civodul: we should come to some resolution on the locale thing. you are arguing for setlocale, but no warning?
<jonsger>tries to fix Guile 2.9.8 on Tumbleweed :)
<wingo>jonsger: is it broken? :)
<jonsger>wingo: no only the tests :P
<wingo>ah :)
<wingo>is it the net-db test?
<wingo>actually i guess i mean to ask: which tests? :)
<wingo>maybe you can send a mail with the info
<wingo>obvs it would be best for guile's tests to pass on suse
<jonsger>version.test (could be caused by something in the RPM packaging) and test-out-of-memory (don't if this worked ever reliable)
<wingo>yeah test-out-of-memory is squirrely, i can understand downstreams disabling it, though i would like to fix the issues it might have
<jonsger>wingo: does increasing the required memory make it more stable?
<wingo>no idea
<wingo>on my systems it does not fail
<jcowan>built Guile 2.9.8 successfully on Ubuntu Xenial
<jcowan>On Cygwin, it blew up on the flag -Oresolve-primitives, so I removed that from the Makefile and now building again.
<wingo>jcowan: bug reports to bug-guile or guile-devel plz
***sneek_ is now known as sneek
<jonsger>scheme@(guile-user)> (version)
<jonsger>$1 = "UNKNOWN"
<jonsger>so I know what is failing, but not yet why :P
<civodul>hi wingo!
<civodul>wingo: yes, i was suggesting setlocale with no warnings
<civodul>BTW, i have other issues since 2.9.7 on Guix (doesn't build, presumably related to the changes to the module system for #:replace & co.)
<civodul>i have yet to debug that