IRC channel logs

2019-12-28.log

back to list of logs

<slyfox>should disassemble-file always be able to disassemble guile's own .go files? Looks like it fails sometimes: http://dpaste.com/3K1N5ZZ.txt
***apteryx_ is now known as apteryx
<spk121>.
<ahungry>.
***ng0_ is now known as ng0
<mwette>.
<rycee>Hey, quick question. Anybody know if there is any dbus library I could use? Couldn't find anything on https://www.gnu.org/software/guile/libraries/
<spk121>mwette: congrats on the 1.0.0!
<mwette>spk121: thanks -- found some config issues, but I am feeling likes it's reasonably robust now
<mwette>rycee: nyacc has dbus in examples
<mwette>wget https://download.savannah.gnu.org/releases/nyacc/nyacc-1.00.tar.gz
<mwette>cd nyacc-1.00.0/examples; . env.sh
<rycee>mwette: I'll have a look. Thanks!
<mwette>guild compile-ffi ffi/dbus.ffi
<mwette>cd nyacc/lang/ffi-help
<mwette>guile dbus-01.scm
<mwette>there are also gdbus examples using glib
<mwette>oops: tarball is nyacc-1.00.0.tar.gz
<daviid>heya guiler
<sneek>daviid, you have 2 messages.
<sneek>daviid, str1ngs says: thanks I had thought of modifying autotools next to account for the re basing. I'll see if this will work for g-golf as well. particularly the use of $GUILE_EFFECTIVE_VERSION is nice.
<sneek>daviid, str1ngs says: it took a while for me to grok why using GUILE_GGOLF_UNINSTALLED was better. I've switched the substitution to work like guile-cv. thanks for pointing this out. I'm not confident substituting configure is better then just re basing the modules by simply moving them. but I've switched to using that as well.
<daviid>str1ngs: wrt the g-golf guix package definitin, I recommend to copy(adapting wrt dependencies of course) 'exactly' what has been done for guile-cv
<daviid>str1ngs, spk121, I just pushed a seris of patches, so g-golf now has working signals - w surely will find 'corner cases' still, bt at least this basic example works fine http://paste.debian.net/1122976/ - so, please pull, run the make dance and test :)
<daviid>rycee: you may also consider using guile-gi or g-golf and the GIO dbus high (and/or) low level api ...
<str1ngs>daviid: great news, will try this out ASAP
<daviid>str1ngs: one thing that won't work for the moment is the delete-event signal, because its seconf argument is a gdk-event, which is a union type, and although g-golf has some low level support for C union types, it still misses bindings to the GIUnionInfo type and method. I'll bid those with priority and wil let you know ..
<str1ngs>daviid: sounds good. I almost all of my signals are created during classing initialization so I should not run into that issue right now. though I can see how it's still needed.
<str1ngs>class*
<pkill9>hello guilers
<str1ngs>hello pkill9
<rycee>daviid: Thanks, guile-gi seems intriguing. Do you know of any example code using it? I'm pretty new with Guile. Just know a bit of elisp :-)
<rycee>g-gold as well. I will dig into these. Many thanks
<lispmacs>hi, I was just wondering if there were any other GUI toolkits for Guile, other than Chickadee, which I think is really a lower level than a tool kit
<lispmacs>*a little lower level
<lispmacs>i suppose I could just make a gtk app and embed guile in it
<spk121>lispmacs: you could make a binding to gtk using gobject introspection. there are a couple of projects that can do that
<spk121>and there's an ncurses binding (lol)
<lispmacs>spk121: hmm, I wonder how much work that is going to be
<spk121>lispmacs: still a bit of work, sadly, but, here's one I did https://github.com/spk121/guile-gi/blob/master/examples/browser.scm
<spk121>since there's a lot of work being invested into the gtk3/4 problem right now with a couple of different strategies, I think by Spring, the Guile GTK3 problem will be solved
<lispmacs>hmm, do you think in the mean time I should try to connect up to some simpler toolkit? I understook TK used to be pretty simple, but not sure if it is now or not
<lispmacs>just trying to add a GUI without making the GUI my main project
<spk121>seems like the GUI functionality that is most complete and ready to go is Guile's internal webserver, so there's that. Looks like the GTK solution is only a couple of months away. There's a couple of SDL libraries out there. Depends on what you want.
<RhodiumToad>guile-gnome sort of works, if you don't need to make much use of idle or timeout events
<RhodiumToad>tk is simple but it's tied to tcl.
<lispmacs>i don't think i need anything super fancy, but didn't want to have to code my own buttons and toolboxes
<spk121>back in the guile v1.4 days there was a tk binding. it has long since bitrotten
<spk121>And last year, I did a combo GTK3 app in C with Guile as an extension language for the Lisp Game Jam. https://github.com/spk121/burro I had a lot of fun with it, but, it was not so easy to merge GTK's main loop and events with Guile. It was that experience that led me to do guile-gi which is a gobject introspection layer for guile
<mwette>nyacc has demos for gtk2; though it's a bit like writing C; code posted at https://paste.debian.net/1122991/
<spk121>That's true. there's always nyacc. If you could find a toolkit where the C headers are a clean API, nyacc would make binding that pretty easy.
<spk121>My first UNIX GUI was Motif or Lesstif, as I recall. I wonder if that still exists?