IRC channel logs

2019-12-26.log

back to list of logs

<str1ngs>daviid: I need to investigate more as to why propagation fix its and what effect this shlibs patch has. I think the reason the non patched version works is due to LD_LIBRARY_PATH searching.
<str1ngs>daviid which brings me to another issues. can you check that (define %libgirepository (dynamic-link "libgirepository-1.0")) is not evaluated at compile time. I think it is. which makes substituting it hard on guix. the other dynamic-link's substitute okay. I can get around this buy using LD_LIBRARY_PATH but that will cause issues on foreign distros.
<str1ngs>daviid: I have some other guix related issues. but I need to add them to tests
<daviid>guix needs the full path, but you should talk about all this on #guix
<str1ngs>I can't for this library because it's evaluated during compile time for some reason
<daviid>as far as i am concern, when make distcheck works fine on debian, upstream is good, anything that wouldn't work is a distro problem
<daviid>only a advanced guix user or maintaner will be able t tell you
<str1ngs>this is a guile issues
<daviid>i don't know, except that guix isn't libtool aware, therefore it needs the full path ...
<daviid>o its not
<str1ngs>(define %libgirepository (dynamic-link "libgirepository-1.0")) needs to not evaluate at compile time to substitute properly.
<str1ngs>maybe I can get around it with guix meantime. also I can use LD_LIBRARY_PATH. but LD_LIBRARY_PATH breaks on foreign distro's as I mentioned
<daviid>str1ngs: please talk to guix, i am telling you, you need to substitute the init.scm file for guix, and you must pas the full pathname ... there are tons of example
<daviid>on other guix packahes
<daviid>pick any other package on guix that does a dynamic-link ... any
<daviid>(dynamic-link "libgirepository-1.0") can not work on guix, it just cant
<daviid>by design
<daviid>please study this with guixers
<str1ngs>I have done that. I will investigate further
<str1ngs> https://github.com/mrosset/giqt/blob/master/guix/giqt/packages/g-golf.scm#L64 see
<str1ngs>actually it's (define %libg-golf (dynamic-link "libg-golf")) that can not be substituted. because the full path does exist at compile time. either way I resolve this on my own. but it would be easier if this did not evaluate at compile time I guess
<daviid>str1ngs: what do other guix 'guile packages' that need to call dynamic-link upon a lib they build do?
<daviid>str1ngs: guile-cv does this to, look at how it's done, in gnu/guile-xyz.scm, line 2594 ... and snarf this and maybe other 'tips and tricks' ...
<daviid>that's funny, guile-cv comes right after your nomad package def in the gnu/guile-xyz.scm file :) - in the version i have here, it probably has changed since i last pull ...
<str1ngs_>daviid: once I get this g-golf nicely done. I'll submit g-golf.scm
***str1ngs_ is now known as str1ngs
<pkill9>what does it mean to put an '@' before an expression? I want to understand this guix package which inherits a package and adds an input https://www.irccloud.com/pastebin/mlsBkBUc/lmms-jack.scm
<zig>pkill9: that ,@expr is unquote-splicing, it will embeded EXPR inside the quoted datum it is part of
<zig> https://www.gnu.org/software/guile/manual/html_node/Expression-Syntax.html#index-unquote_002dsplicing
<zig>it works somewhat like unquote, but it will "splice" the EXPR list inside the outer list.
<pkill9>ah, thanks, i get it
***ayerhart is now known as blahblahhjldfjal
***ayerhart_ is now known as ayerhart
<slyfox>looks like guile-2.2.6 crashes on 32-bit big-endian platforms: https://bugs.gentoo.org/676468#c19
<slyfox>how do prebuilt/32-bit-big-endian get generated for release tarballs?
<slyfox>i wonder if i can generate it natively and check what is different from shipped in tarball
<slyfox>looking at dwarf data prebuilt bytecode was built by guile-2.2.3 to 2.2.6. are they compatible?