IRC channel logs

2019-12-24.log

back to list of logs

<str1ngs>sneek: later tell daviid. guix python GI and GJS binding are working fine same with C. for reference my trivial tests are here https://github.com/mrosset/test-gir. when I down grade gobject-introspection to 1.58.3 test.scm works but not with guix's 1.60.2.
<sneek>Okay.
<dsmith-work>Hey Hi Howdy, Guilers
<zig>heya!
<roelj>So, I have a program that hangs with Guile 2.9.7, but runs fine with Guile 2.2. How do I debug this?
<mwette>try setting env var GUILE_JIT_THRESHOLD=-1
<mwette>if it works then there is a JIT issue
<mwette>another thing you can try is run under gdb then C-C (Control-C) during the hang:
<mwette>gdb path/to/guile
<roelj>Hm, it doesn't seem to be a JIT issue.
<mwette>gdb> run myscript.scm
<mwette>gdb> ^C
<roelj>Are threads in ‘sigsuspend’ idle?
<roelj>One is in ‘GC_mark_from’, and one in ‘read’.
<roelj>Can I somehow map which Guile code it is running?
<mwette>you can go "up" in frames and if you see scm object I think you can print that, though I'm not familiar with the guile-hooks for gdb (libguile-2.X.so.1.4.1-gdb.scm)
<roelj>Thanks mwette!
<roelj>I'm trying the "run ..." method, but I get "Unbound variable: run".
<roelj>Before I'd run the runscript of the program (which uses Guile as shell), and then "attach" with gdb to the running/hanging program.
<mwette>roelj: that sounds fine; could you stop the program when it hangs?
<mwette>roelj: are you loading your code into guile or running guile from your own main() ?
<roelj>mwette: Uhh.. I have a script that starts with #!/gnu/store/.../bin/guile --no-auto-compile, and goes on to run Guile code..
<roelj>And I just ./my-script it
<roelj>I can stop it with ^C, or attach to it while it runs/hangs.
<mwette>hmm ... not much more I can help. for what it's worth, 2.9.7 will not even build on Ubuntu
<mwette>gotta go now ..
<roelj>Okay. Well, thanks a lot for your help!
<mwette>YW
<str1ngs>hello daviid. it seems this patch http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch is causing the issue guix. when I don't apply the patch g-golf works fine. but I can't seem to figure out this relates to g-golf at all. I'm pretty confident g-golf does not use g-ir-scanner and friends. any ideas?
<str1ngs>on second thought maybe a g-golf depend uses g-ir-scanner. and that effects g-golf. but that does not explain how GJS, python ancd C still work
<str1ngs>daviid: either way I'm pretty confident this is not a g-golf issue at this point. I'll post a bug report with guix.