IRC channel logs

2019-12-21.log

back to list of logs

<nly>str1ngs jcowan I think a global stack is just a bad idea, i.e. buffer-stack in (emacsy buffer). But Lists can implement stack very well.
<faLUCE> hello. What's wrong in this syntax? (list (cons "editableClass" editableClass)(cons "editableSubclass" editableClass))
<faLUCE>[01:02] <faLUCE> it's ok for (list (cons "editableClass" editableClass))
<daviid>lloda: guix has a string-replace-substring, here http://git.savannah.gnu.org/cgit/guix.git/tree/guix/utils.scm, but i think it should be called string-replace-all, so i snarfed and renamed it, here http://git.savannah.nongnu.org/cgit/grip.git/tree/grip/string.scm
***catonano_ is now known as catonano
<RhodiumToad>faLUCE: looks ok to me?
<manumanumanu>Ahoy guilers!
<manumanumanu>Do I have to have xcode to have any chance of building anything from source on osx?
<manumanumanu>And why is ./autogen.sh not finding AM_GNU_GETTEXT?
<manumanumanu>Because I hadn't linked it properly!
<manumanumanu>Has anybody successfully built guile outside brew on mac os x? Regardless of my --with-libltdl-prefix it outputs a warning that it can't find libltdl
<manumanumanu>eff this. I'll do all guile development on my rpi.
<manumanumanu>can I use an existing guile2.2.x to bootstrap 3.0?
<peanutbutterandc>Hello there, n00b here, trying to go through this tutorial: https://www.gnu.org/software/guile/docs/guile-tut/tutorial.html but for some reason my code does not work (the backend .c program): https://termbin.com/3iy3
<peanutbutterandc>Any ideas, please?
<peanutbutterandc>By the way, it compiles without any errors. `gcc -Wall ...` is silent.
<str1ngs>peanutbutterandc: what error do you get when you run the program?
<peanutbutterandc>str1ngs, Hey there. I get no errors even while running. And it is exiting with $? 0, too. I just can't see anything. I thought I was supposed to see the turtle
<peanutbutterandc>Also, I did try putting in `sleep (1)` inside the for-loop that draws
<str1ngs>peanutbutterandc: does anything print to stdout?
<peanutbutterandc>str1ngs, Not at all. Does it work on your machine?
<peanutbutterandc>I am using gnuplot off of guix, BTW. On a foreign distro.
<str1ngs>to me everything seems fine. it's just not obvious to me what gnuplot is doing with the piped input
<peanutbutterandc>str1ngs, I lack the knowledge about C and gnuplot to know it
<peanutbutterandc>The first part where I had to deviate (apart from the function prototypes) from the tutorial was execlp() function. Instead of "gnuplot" it's "gnuplot", "gnuplot" (stack overflow-ed it)
<peanutbutterandc>wonder if that makes any difference. Wasn't compiling without the change
<str1ngs>peanutbutterandc: output = fdopen (pipes[1], "w"); it's not obvious to me what pipes[1] is
<peanutbutterandc>str1ngs, If it were not for pipe() it would have been an uninitialized array... so it must have something to do with pipe() ?
<str1ngs>actually to me it just writes to the gnuplut process
<peanutbutterandc>... that seems to be what was intended, too. I wonder why gnuplot window isn't showing up
<str1ngs>peanutbutterandc: I just figured out gnuplot creates a window too
<str1ngs>peanutbutterandc: does echo "clear" | gnuplot create a window. if for a short time?
<peanutbutterandc>No, sir. But I have seen a window blink in while trying to run ./tortoise, occasionally. I then put sleep(1) in the loop but the window didn't show up at all.
<str1ngs>peanutbutterandc: everything looks okay. just seems gnuplot is not displaying
<str1ngs>try running gnuplut and plotting a simple example
<str1ngs>by hand
<peanutbutterandc>str1ngs, plot sin(x) does give me a plot
<peanutbutterandc>in the interactive gnuplot prompt
<str1ngs>peanutbutterandc: maybe there is a problem with the syntax piped to gnuplot
<manumanumanu>wingo: the REPL message still says 2.9.2 for me, which wasted 1SEK of energy on a rebuild because I don't understand OSX :D
<peanutbutterandc>str1ngs, I have just emailed the author of the tutorial. Hopefully he will be able to pin-point the issue?
<manumanumanu>Which is weird, since (micro-version) is 7, but (version) reports 2.9.2~COMMIT
<manumanumanu>Which seems odd, since that should not pass all the tests if I read test-suite/tests/version.test correctly.
<manumanumanu>wingo: Now I have everything in place, including tests and everything. Is there anything extra I need to do? The documentation is in srfi-modules.texi, the modules are in the srfi directory, the tests are in the test directory named srfi-171.test. Do I have to add it anywhere else?
<manumanumanu>and btw, that weird version thing was a left over from me not doing a make clean
<manumanumanu>oh. The makefile.am's
<manumanumanu>building guile again to see if it works now!