IRC channel logs

2019-12-09.log

back to list of logs

<daviid>chrislck: is it you that has a guix g-golf package def?
<sneek>daviid, you have 1 message.
<sneek>daviid, str1ngs says: sound good thanks.
<daviid>*have
<daviid>who ever it is, please make it point to the latest master commit ..., tx!
<daviid>chrislck: wrt your email, i don't think it is feasible to reimplement car and cdr, though in theory it is, you'd still need to parse the data every 'consult' and won't be able to use any scheme list functionality ... unpractical imo
<daviid>chrislck: you should try to use g-golf, which does a prepend reverse as well of course, but it uses both the ffi and GI to get the data (most often gobject subclass instances, in this case you get goops instances) ...
<daviid>the data conversion is incomplete at the moment (it works for gobject subclass instances though), but extrememly easy to complete, something i will do 'on demand' since i wana work on signals ... but i can extend what misses on demand in // with what ever it is i'm working on ...
<chrislck>daviid: very little time here; (7;55am) my approach was to define a C struct Pair which has car & cdr, and car points to data, cdr points to rest.
<daviid>chrislck: see gi-glist->scm and gi-gslist->scm (I see looking at this g-golf still misses their counter part scm->... but that's soething i can provide extremely easily as well ...
<daviid>
<daviid>chrislck: yes, but it won't get you 'nowhere', imo
<chrislck>so, SWIG would expose the opaque struct and we use car/cdr accessors for using the struct. we are hoping for a neater approach.
<chrislck>gtg
<daviid>if only to get th car cdr pointer, from scheme, then i'd recommend to use g-golf
<chrislck>ok thx gtg
<daviid>chrislck: https://www.gnu.org/software/g-golf/manual/html_node/Doubly_002dLinked-Lists.html#Doubly_002dLinked-Lists and the next section
<daviid>chrislck: part of the runtime time is consumed by parse-c-struct, whenever i find sometime, after impemeting signals, i'd like to snarf the magical tool civodul wrote for guix and that allow us to compile C struct accesors ... that is a winner and should find its way to guile core imo
<daviid>chrislck: here is the guix module that does that https://git.savannah.gnu.org/cgit/guix.git/tree/guix/build/syscalls.scm line 184 -> 359, then line 641 for an example of use ...
***catonano_ is now known as catonano
<apteryx>I still need to understand how I can input #'something as a literal in a quoted list in Guile (I couldn't workaround it with a string, after all)
<apteryx>if anyone would know :-)
<RhodiumToad>not sure I understand the question?
<apteryx>RhodiumToad: basically, I'm trying to make the following function call: (emacs-batch-eval (format #f "(mapc #'load ~a)" autoloads))
<apteryx>rather, this: (emacs-batch-eval `(mapc #'load ,autoloads))
<apteryx>and it fails because #'load is expanded to (syntax load) by Guile.
<RhodiumToad>use (function load) instead?
<RhodiumToad>(since that's what #'load expands to in elisp)
<ZombieChicken>This isn't exactly a guile question, but I think it's Close Enough; Is anyone aware of a way to get org-babel to execute code in a REPL via geiser?
<spk121>RhodiumToad: `(mapc #{#'load}# ,autoloads)
<str1ngs>daviid: i have updated to the latest hash. if any one needs a guix package declaration. https://github.com/mrosset/giqt/blob/master/guix/giqt/packages/g-golf.scm
<daviid>str1ngs: ok, thanks. i have to leave now, bbl
<str1ngs>daviid: there are some issues with g-golf and guix. but I can't repclicate it on on the systems like debian/ubuntu so I'm trying to figure it out on my on for now
<str1ngs>on other systems*
<daviid>str1ngs: ok, try to see hose with #guix, unless it is s g-golf proble of course ...
<daviid>need to go, bbl
<str1ngs> it's more a GI GTK issue with g-golf and guix. I will try to narrow down the issue and report it
<str1ngs>but it does not happen on other systems so related to guix only at this time.
<str1ngs>ttl
<zig>nomonofu parsed 110 000 000 triples out of 9 000 000 000 triples, that will be a very long process.
<wingo>moin
<civodul>'lo Guilers!
<zig>o/
<wingo>moo
<RhodiumToad>rlb: that set of fluids tests could probably do with including a test of make-unbound-fluid somewhere
<nerdypepper>hihi
<nerdypepper>I had asked about building with readline support, and it turns out it was an issue with the prefix supplied to the "withlibreadline" option. thanks guilers!
<wingo>nice :)
<lloda>wingo: another bogus warning I think (?) https://paste.debian.net/1120350/
<lloda>this is a1e88ebc124b3f6183d1ff59052d3ba74385716c nvm the tag
<wingo>lloda: not a bug i think. re-export doesn't mark its bindings as being replacements
<wingo>to silence the warning you need #:replace, which is only available as a define-module arg
<lloda>oh thx
<lloda>I think I've never used #:replace
<lloda>doc says I can also do (export!)
<lloda>it feels strange b/c the redef of format is not in the same module, but it's imported
<lloda>I have to be careful with those core bindings...
<wingo>yeah it's weird. in the past one module marking a binding as being a replacement would mean that any re-exporter would also propagate that mark on through
<wingo>but that might not be what you want. like one module might want to re-export raise-exception as raise and mark it as replacement, but another might not
<lloda>I see. This also fixes the bug I had the other day.
<civodul>found a funny bug in Guile that would occasionally crash PID 1 (shepherd): https://issues.guix.gnu.org/issue/37757
<wingo>nice!!
<wingo>crashing pid 1 sounds... not nice
<civodul>yeah, that's when you realize the impact of a misplaced abort/assert :-)
<civodul>but that gave us a proper crash handler as a side effect, which is good
<civodul>i hadn't thought about how to get a core dump from PID 1 until now
<zig>re database work: I read there is several people working in bio info (computer science applied in biology) around, others can help too: I am looking for a dataset to test an "approximate string matching" algorithm, do you know such a dataset that is freely available?
<zig>At a meetup, last week, a person working biology told me that they work on matching dna sequences in giant repositories and that it was very slow... I happens that I have an algorithm to do exactly that, I would like to test it in a real world scenario.
<zig>I tried to search the Internet, but it does not give meaningful results.
***ng0_ is now known as ng0
<rlb>RhodiumToad: ok, happy to add it -- I need to figure out what the conventions are, haven't committed actual code to guile in a while, i.e. are patch revisions on the list preferred, or followups to the bug tracker, or either...
***apteryx_ is now known as apteryx