IRC channel logs

2019-11-30.log

back to list of logs

<SrainUser>Hey there, how does guile find modules within the "module path"? does the filename have to match the module name or Does it scan each *.scm file for (define-modules) commands and builds a mapping from filename to modulename?
<RhodiumToad>the filename is constructed from the module name and then looked up relative to directories in %load-path
<RhodiumToad>see node "Modules and the File System" in the docs
<SrainUser>oh ok thx. WIll have a look
<SrainUser>so I do have 2 source files - a, b - in my folder "tls".
<SrainUser>"a" does have to define the module like this: (define-module (tls a)) doesnt it?
<SrainUser>that would be analog to the (ice-9 popen) example on "
<SrainUser>6.20.4 Modules and the File System"
<RhodiumToad>yes, afaik
<ArneBab>Great article which is also important for Guile: Software developers should avoid traumatic changes → https://drewdevault.com/2019/11/26/Avoid-traumatic-changes.html
*RhodiumToad wonders where the break-even point is for checking for unique symbols using a hash table vs. a simple list and memq
<RhodiumToad>hm. is there a good way to match an sexp that looks like (foo [optional stuff] . bar) ?
<ecraven>wingo: I don't think I ever checked in graph.scm, it is a total mess :-/
<ecraven>for chez, there should be a link in the README.org to my r7rs shims
<chrislck>ooh https://everything2.com/user/jimb
***lispmacs is now known as Guest75914
<q66>hello, do you think it would be possible to tag a 2.0.15 release for the oldstable series? there has been none since early 2017 and it seems the gnulib update commit (which is an ~8KLOC commit so it's impractical to ship it downstream) fixed some strange build errors on powerpc(64): https://gist.github.com/q66/1b5917cb398e2b8837d8676bcf1f142a
<q66>alternatively i'll just switch it to a git snapshot, but i'd prefer not to
<q66>hrm, still getting these errors on latest git when compiling for musl libc... strange :/
<q66>time to dig around more
<zig>Sure thing multithread POSIX threads, fibers and the module system do not play nice together...
<zig>The take away of this afternoon of debug is that, I will avoid bash bang to start a main procedure and instead rely on (scheme process-content)'s program-arguments procedure.
<zig>It seems like when program is also a guile module, there is some stuff happenning that made my program segfault.
<zig>the positive side of things is that it seems that the for-each-par-map I have been working on that can be used in mainthread fiber to execute database queries seems to work.
<zig>that is execute database queries or cpu intensive task without blocking the mainthread that is running a guile-fibers scheduler.
<zig>\o/
<q66>i think i have the same problem as https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941218
<q66>no idea what to do though
<q66>what even
<q66>the issue disappears when i compile it with -Os