IRC channel logs

2019-11-20.log

back to list of logs

<anon987321>hey
<anon987321>about guile's support for other languages
<anon987321>does it mean that i can write scheme and compile it to another language such as emacs lisp or ecmascript?
<ft>No. There are different language frontends that all compile to Guile's VM.
<anon987321>thanks :)
<daviid>str1ngs: I pushed a new version of flatten, to (grip list), based on the one written by manumanumanu you pointed to me, thanks you both ... here http://git.savannah.nongnu.org/cgit/grip.git/commit/?id=537e8cc12fe2f3095f065084ea2b9376d548b6e6
<str1ngs>daviid: IIRC that was somebody else
<str1ngs>daviid: this it was chrislck
<str1ngs>s/this/think
<daviid>oh, ok, well thanks chrislck (and sorry about this)
***catonano_ is now known as catonano
<wingo>moin
<zig>moin
<zig>For some reason, the naive crawler I put together using 'wget' is mirroring the whole gnu mailing archive...
<zig>while IFS= read -r line; do # read from stdin
<zig> echo "$line";
<zig> wget -A "*.html" --random-wait --adjust-extension -q --mirror --no-parent "$line";
<zig>done
<zig>here is stdin: https://git.sr.ht/~amz3/guile-babelia/tree/master/roots.txt
<zig>that probably because of a missing slash at the end of some the line :/
<zig>anyway, I will do crawler that rely on http-get and fibers.
<zig>yeah, that is because it is missing a slash...
<chrislck>daviid: np i have plenty of commit history elsewhere ;)
<pinoaffe>RhodiumToad: come on, don't be such a hardass
<pinoaffe>it doesn't fail, it just breaks an assumption you think it shouldn't break
<RhodiumToad>um?
<RhodiumToad>any nontrivial xml file will have a namespace declaration somewhere
<RhodiumToad>if the input xml contains any namespace declaration that's not matched in #:namespaces, then sxml->xml will just error out on the result
<RhodiumToad>if it contains one that _is_ matched in #:namespaces, then sxml->xml will output invalid xml
<jcowan>Actually plenty of XML files don't use namespaces, because some XML-ites (including me) think they were a Great Big Mistake.
<jcowan>SGML had much better strategies than trying to make every name globally unique.
<RhodiumToad>of the ~100 xml files currently in my working directories, discounting the xml validation set, ~80% have namespaces and ~20% do not
<RhodiumToad>whether you think they are a big mistake is of no relevance to people who have to work with them
<manumanumanu>ArneBab: Well, it keeps about half of the memory if you clear longlonglist and longlonglist2 from memory as well.
<ArneBab>manumanumanu: yes
<manumanumanu>daviid: Why use match? It probably produces the same code in the end. Do you find it clearer? I am usually a match-lover, but for that case it seems to me it doesn't add much...
<daviid>manumanumanu: yes, a lot cleaner, but i guess all relative ...
<manumanumanu>:D
<manumanumanu>match is a thing of wonders. After watching Kent Dybvigs talk about "the macro writer's bill of rights" I love the idea of the implementation taking care of most of the dirty work to let your macros be zero cost :D
<manumanumanu>daviid: Happy someone uses code I wrote for good!
<jcowan>RhodiumToad: Yes, I know they are there and people have to work with them. I only objected to your claim that no non-trivial XML documents lack them (excluding the xml: namespace which is a special case).
<jcowan>About 10 years ago I was working with a company that had about a billion XML documents, all namespace-free.
<RhodiumToad>I'm guessing they produced them themselves
<daviid>a billion, really?
<RhodiumToad>I don't see why not
<jcowan>They formatted them themselves, yes, but did not produce the content.
<jcowan>LexisNexis has all the legislation for the U.S. and all 50 states, all the government regulations, court decisions, detailed information on all lawyers (defined as members of bar associations), legal news stories, ....
<jcowan>A billion was my best estimate at the time. When my team needed samples of documents of a given type to work on, they usually sent us about a hundred, but when we convinced them that we really could drink from the firehose,
<jcowan>the sample size went up to tens of thousands.
<jcowan>We then sent them back detailed transformation instructions to convert their XML into semantically much richer XML according to about 40 schemas (with about another 40 in the pipeline). And yes, our XML had namespaces, though they really weren't necessary at all.
<RhodiumToad>in fact, dealing with missing namespaces brings out even more issues with (sxml simple)
<manumanumanu>chrislck: the old code you replaced does something spectacular I didn't know was possible. it defines the named let lp and passes lp as a proc to fold.
<manumanumanu>is that supposed to work? is the expansion of named lets such that it should work, or is it implementation dependant?
<stis> http://c-lambda.se/units.html
<stis>have fun ...
<jcowan>manumanumanu: Named-let procedures are like any other procedures: they exist and are callable until the GC destroys them
***jao is now known as Guest89846