IRC channel logs

2019-11-14.log

back to list of logs

***jao is now known as Guest40344
<daviid>sneek: later tell spk121 whenever you have a few minutes, you could pull and make (the latest g-golf devel branch - that I have enhanced since my last message) and then try/valgrind this g-idle-add example https://paste.debian.net/1116132/ (that I also updated today ...), it should not leak, it doesn't leak here anymore. If/once this is confirmed, I'd be happy to share some knowledge I gained wrt all this, including what i believe is a
<daviid>bug in g-closure-unref (although it does not 'raise an exception') and how I finally decided t handle this 'mess' in G-Golf (I'm actually quoting one of the gnome developers, who, while I was explaing 'my problem', confirmed that the GSource and GClosure interfaces are 'less then optimal' ...
<sneek>Got it.
<daviid>sneek: later tell spk121 I suggest read the channel log, I think our bot only got one part of the long sentence I wrote ...
<sneek>Will do.
<daviid>str1ngs: if you use g-idle-add, g-time-out-add*, please pull, make and see this updated example - https://paste.debian.net/1116132/ - that shows how to use those procedures, receive their multiple values and free both the source and the closure ...
<daviid>*g-timeout-add*
<daviid>str1ngs: they all (g-idle-add, g-timeout-add*) return the source id, the source pointer and the <closure> istance, in that order, so th example 'serves for all' till I write some doc for the high level api (I updated the doc for the low level api already ...)
<daviid>of course the example shows how to free the source and the closure, which is appropirte i this case, because the idle 'callback' is not kept in the mai loop context (see line 20) ... you don't free anything until the source has been removed from its context ...
<str1ngs>sneek: later tell daviid, thank you will test this out. I'm only using g-idle-add in an example right now. but I do have a use case later on when g-golf signals are further along. thanks for the update.
<sneek>Will do.
<redkahuna>Hey all, i am novice in guile, i found the code `(web server ,impl) what does mean the "," here and the "`"
<d4ryus>redkahuna: its called quasiquote, works like ' (quote) but allows one to unquote part of the expression with , (komma), eg (setq x 3) `(1 2 ,x) would evaluate to (1 2 3)
<d4ryus>s/setq/define
<redkahuna>ah ok thanks, because i tought that the , have some relation with the , of system like ,d ,t
<dsmith-work>Morning Greetings, Guilers
<roelj>Is there a codebase that implements a web server that does SSL (via GNUtls?)?
<roelj>(obviously, written in Guile)
<amz3>hellooo #guile
<wingo>o/
<wingo>ok exception stuff done, will merge tomorrow i think
<amz3> http://git.savannah.gnu.org/cgit/guile.git/log/?h=wip-exceptions
<wingo>civodul: hey :) i am headed to zzz but fyi i plan on merging http://git.savannah.gnu.org/cgit/guile.git/log/?h=wip-exceptions tomorrow, lmk if any objections
<civodul>wingo: cool, thanks for the heads-up!
<civodul>and sorry for not being more reactive
<civodul>i'm swamped and i've lost track of... many things