IRC channel logs

2019-10-15.log

back to list of logs

<daviid>janneke: chrislck, tx, fyi, spk121 said he will produce a new patch and email guile-user sometimes this week, including all the steps one has to do to install dependencies, guile and compile install ...
<daviid>chrislck: you also uses spk121 branch i guess?
***jao- is now known as jao
<chrislck>daviid: ?no
<daviid>chrislck: from the link you posted, i couldn't figure out how you install guile, but don't worry, i was just being curious, and want/will (to) use the msys2 and the method/guile version that spk121 spoke about and will update for us this week ... tx
<MaliRemorker>Morning everyone. I am currently playing around with the pattern matcher in Guile v2.2.6
<MaliRemorker>(match '(1 2 3 4 5) ((a ... b) "match"))
<MaliRemorker>matches
<MaliRemorker>however
<MaliRemorker>(match '(1 2 3 4 5) ((a ... b . c) "match"))
<MaliRemorker>does not, despite this bit of documentation: | (pat_1 ... pat_n . pat_{n+1}) list of n or more
<amz3>the pattern prolly meant (a b c . d) not ellipsis.
<MaliRemorker>the error returned (match-syntax-error "dotted tail not allowed after ellipsis" c)
<MaliRemorker>but, isn't a ... b . c still a valid pattern?
<MaliRemorker>... meaning that the error should not be a syntax error?
<weinholt>that kind of pattern seems to be the same as having multiple ..., which is also not allowed
<MaliRemorker>yeah, i did not think about the possible reduction to an invalid pattern
<MaliRemorker>basically, i did not _think_ :D
<MaliRemorker>however, the documentation can be understood as this being a valid form under all circumstances
<MaliRemorker>(at least to those who only have an intuitive understanding of ::=, | ... notation used to break down the logics of the pattern matching)
<weinholt>the typography is unfortunate
<MaliRemorker>still: (match '(1 2 3 4 . 5) ((a ... 4 . 5) #t))
<MaliRemorker>this can't be reduced to multiple ...
<MaliRemorker>and raises the error that it is forbidden to follow ... by .
<MaliRemorker>which is in contradiction with the docs
<joshuaBPMan>hello, I'm trying to split my guile program into modules...
<joshuaBPMan>what's the best procedure for telling guile how to find these modules?
<joshuaBPMan>(use-module ...) is giving me an error no code for module (decode).
<wingo>joshuaBPMan: pass -L to Guile on the command-line
<wingo>alternately GUILE_LOAD_PATH / GUILE_LOAD_COMPILED_PATH; see the manual for more
<joshuaBPMan>thanks andy. I am seeing (add-to-load-path dir) might be an option too.
<wingo>yep
<joshuaBPMan>wingo: I also found some code to parse POST data:
<joshuaBPMan> https://stackoverflow.com/questions/46656074/how-to-read-post-data-in-the-guile-web-server
<joshuaBPMan>I should probably add that to the guile web module/manual proper.
<joshuaBPMan>because that would be handy to have!
<wingo>that is from amz3 :)
<wingo>i think
<wingo>but yes it might make sense to have in guile
<MaliRemorker>(hours later ...) ooooh, now i understand the docs for (ice-9 match) : The dot-dot-dot in the docs is just the human-readable dots, while ooo represents the dots in the pattern sense
<heisenberg-25>MaliRemorker, I also had this difficulty when I first came across (ice-9 match) :)
<amz3>joshuaBPMan: probably wrong answer
<amz3>joshuaBPMan: if it works for you good, it is been a long time.
<heisenberg-25>how do you pass keyword arguments as a rest argument?
<jcowan>Apply is the general way of passing a list of arguments (keywords or otherwise) to a procedure: (apply arg1 arg2 ... arglist)
<jcowan>However, never recurse on a rest argument ("variadic recursion") as it will kill your performance.
***jao is now known as Guest8858
<joshuaBPMan>hmmm...that's weird. I just got my basic guile web server to serve css files, but my local machine is not accepting it as a css file.
<joshuaBPMan>I've got the response header to be text/css...
<joshuaBPMan>"content-type" header rather.
<joshuaBPMan>essentially I wonder what headers are necessary for my web server to get my browser to accept the css file...
<davexunit>wingo: I don't have any real numbers to back this up but the additional unboxed ops in 2.9.4 seem to have a positive impact! I know you asked me quite some time ago and I didn't have answer then.
<davexunit>I got frustrated hunting for a bug after upgrading to 2.9.4 so I put the project aside for a few weeks.