IRC channel logs

2019-10-01.log

back to list of logs

***ng0_ is now known as ng0
<nly>hi
<nly>(define E '((b 3)))
<nly>(assoc-set! E 'b '(2))
<nly>ERROR: In procedure assoc-set!:
<nly>In procedure set-cdr!: Wrong type argument in position 1 (expecting mutable pair): (b 3)
<nly>
<nly>why? and any workaround?
<lloda>nly: E is a literal
<lloda>do (define E (list (list 'b 3)))
<nly>ahh
<nly>thank you :)
<lloda>yw
<nly>does variable-unset! do what i think it does?
<nly>undefine a var
<chrislck>I found some obscure combo which undefines a var, but this required digging guile's c sources
<lloda>nly: yes
<lloda>(define a 3)
<lloda>(variable-unset! (module-local-variable (resolve-module '(guile-user)) 'a))
<lloda>> a
<lloda>ERROR: Unbound variable: a
<chrislck>ah yes that one, easy to remember
<nly>thank you lloda :)
<lloda>np
<lloda>I've never used that in nearly 20 years of Guile
<wingo>i haven't ever used it either :P
<dsmith-work>Hey Hi Howdy, Guilers
<str1ngs>hello daviid is there some way to squelch the signal info console output when using gi-import?
<str1ngs>daviid: also the closure/signal work looks interesting. is it possible to connect to any gtk signals yet. Seems to me this is just lower level glib right now? That was my impression while checking the git log anyways.
<count3rmeasure>hey all, just doubling back to ask during waking hours: Does anyone know of any guile scripts for the guile->gdb api?
<count3rmeasure>I've searched pretty extensively, asked a couple places (including here, albeit at a bad time of day), emailed the author of the guile api code himself, and I've yet to find more than one project in the wild that uses these bindings