IRC channel logs

2019-09-16.log

back to list of logs

<daviid>hum, i realize g-golg flag names still use _ instead of - ... todo
<daviid>str1ngs, spk121, here is an example, it compiles fine but it segfault here, do you have any idea why? I don't know Gio, nor WebKit2 ... http://paste.debian.net/1100958/
<daviid>it segfault on make <gtk-application-window>
<daviid>even without any argumet
<daviid>mistery
<daviid>here is a slightly updated version that doesn't segfault anymore, but still raises an exception http://paste.debian.net/1100962/
<daviid>it seems it will be impossible to instantiate <gtk-application-window> using the goops style? it seems in the 'working way' - (gtk-application-window-new app) - app is not a property ...
<spk121>daviid: that run is from Gio. I think that Gtk will intercept the command line argument "--name=<Program Name for Window Manager>" so you could try that
<chrislck>daviid: thx I don't indend to replace gnucash's C into guile -- they want to minimise guile.
<chrislck>just wanna hack!
<spk121>daviid: I did pull the master of g-golf to see if I could find your segfault, but, I get a compilation error https://paste.gnome.org/pvrhusisz
<spk121>daviid: also, in your configure.ac the line GUILE_PROGS([2.0.14]) seems suspect, unless that is really what you mean
<daviid>spk121: you need to checkout devel
<daviid>master is months 'late'
<daviid> GUILE_PROGS([2.0.14]) jut checks that you have at least guile >= 2.0.14, but it should find the gule you have, it does here at least
<daviid>anyway, if you could look at the latest paste ... i don't know enough about gio, webkit
<daviid> https://paste.gnome.org/pvrhusisz -> The page you are looking for does not exist.
<daviid>but you need devel, not master
<daviid>chrislck: fine
<daviid>spk121: once you have devel, look at the second paste, here http://paste.debian.net/1100962/
<spk121>daviid: OK. I can reproduce
<spk121>first. I was actually using devel not master when I got a compilation error. here's the error again using debian paste https://paste.debian.net/1100968/
<str1ngs> daviid I think gtk-application-window constructor takes a GtkAppliction
<str1ngs>daviid maybe gtk-application-new would work better
<str1ngs>err gtk-application-window-new
<spk121>daviid: sorry, couldn't figure it out. Gotta jump to another task.
<daviid>spk121: ok tx. i've no idea why g-golf does not compile on your side
<daviid>spk121: are you using 2.2 or 2.9? do you have 'local' def for get-keyword maybe ? that sounds really weird, g-golf uses get-keyword all over the places ...
<daviid>str1ngs: please try and tell me, i just don't know ...
<daviid>str1ngs: this is a trnscription of the guile-gi browser.scm file ... so you may see what works using guile-gi ...
<daviid>spk121: get-keyword is provided by goops
<daviid>spk121: hum!! i think you found a bug, but that might be in guile :) here is what happens - in (g-golf support enum), line 133, the call to get-keyword does _not_ pass its default optional argument, which being optional, should be initialized to #f, but in your case, it raises an exception ... are you on 2.9 ? because here i'm on 2.2.6, and it's fine
<daviid>spk121: i pushed a fix, although i shoudn't have to, but it should compile on your side now ... let me know
<daviid>spk121: on the devel branch
<daviid>spk121: here, "2.2.6.1-a69b5" - get-keyword -> $2 = #<procedure get-keyword (key l #:optional default)>
<daviid>spk121: i bet you have another 'answer' on your system?
<daviid>spk121: it could be that 2.9 expects #<procedure get-keyword (key l #:optional (default #f)>
<daviid>spk121: can you try this (get-keyword #:foo '(#:foo bar)) in your repl
<daviid>then (get-keyword #:foo '(#:foo bar) #f) if it failed ...
<daviid>hum, just compiled/install 2.9 and this works fine to ,use (oop goops)\n (get-keyword #:foo '(#:foo bar)) -> bar
<daviid>using GNU Guile 2.9.4.8-374c1e
<spk121>daviid: I'm guile 2.2.4, and this patch does work for me
<daviid>wierd, 3 of us can compile it on 2.2, jst tried 2.9 as well
<daviid>and here make check make distcheck work fine
<daviid>spk121: so, can u try ,use (oop goops) then (get-keyword #:foo '(#:foo bar))
<daviid>in a fresh repl
<spk121>$1 = bar
<daviid>amazing :)
<spk121>OK. I think I have it. The /usr/bin/guile on my system is guile 2.0.14, which has the old behavior requiring 3 parameters. I think the autoconfigury was picking up the default guile for compilation. I also have guile 2.2 as /usr/bin/guile2.2 so I think it is a parallel install problem
<daviid>right! but then tha patch should have fixed it
<spk121>yes, the patch did fix it
<daviid>ah, ok i just pushed another mini patch, a typo in the name of that gi-enum instance ...
<daviid>back on track then
<daviid>i thought i did read the patch didn't fix it, sorry
<daviid>hence i was pulling my hear :):)
<daviid>*my hair aha
<daviid>this what fails (gtk-application-window-new (make <g-application> #:application-id "org.gtk.example"))
<daviid>if you import as in the eval-when in the pste, then paste the above, it reproduces the problem, which probably is a g-golf bug (a miss feature maybe, don't know yet)
<daviid>here is shorter example, it segfault as well http://paste.debian.net/1100986/
<str1ngs>daviid: I can I test with this paste http://paste.debian.net/1100986/ ? I've been AFK but I have time now
<str1ngs>I'll try with your latest REPL paste maybe
<str1ngs>daviid:
<str1ngs>daviid: I don't think it makes sense to try and get GtkApplication to work without signals
<str1ngs>it relies on the activate signal
<str1ngs>basically you need to call g_application_run passing an application. which is going to then block. and you want to create your windows from within the activation signal callback
<str1ngs>daviid: so withing out being able to connect a callback to the applications activate callback g-golf wont be able to create application windows
<str1ngs>I hope this help you out
<nly>any resource for freely licensed svgs?
<spk121>nly: you can check out the svg icons from Tango. Lemme find a link...
<nly>thanks spk121
<spk121> https://commons.wikimedia.org/wiki/Category:Tango_project
<dsmith-work>Hey Hi Howdy, Guilers
<amz3>o/
<nly>hi rekado
<nly> (call-with-input-file wagon (compose make-pict xml->sxml))
<nly>$7 = ERROR: In procedure scm-error:
<nly>Invalid QName: more than one colon http://www.w3.org/2000/svg:svg
<nly>
<nly>where wagon is this file: https://commons.wikimedia.org/wiki/File:Horse_Wagon2.svg
<nly>any ideas?
<str1ngs>nly: does make-pict handle the URL parsing?
<nly>nope
<nly>i am downloading it first
<nly>hey :)
<str1ngs>and hello :)
<str1ngs>based on the error svg:svg is causing issues
<str1ngs>I suspect it's something that is not parsing the URI properly
<str1ngs>or maybe the URI needs encoding
<str1ngs>: is a reserved URI character
<str1ngs>nly: also have you tris file https://upload.wikimedia.org/wikipedia/commons/1/19/Horse_Wagon2.svg
<str1ngs>the pages you linked is html not xml
<str1ngs>tried this*
<nly>str1ngs: ah i see
<nly>sorry for the late reply
<nly>(xml->sxml <svg xmlns="http://www.w3.org/2000/svg" ... ) -> (*TOP* (http://www.w3.org/2000/svg:svg ...) ...)
<nly>so all tags are getting replaced in this pattern: <foo> -> http://www.w3.org/2000/svg:foo
<nly>i think i'll have to provide a namespace argument
<retropikzel>I have a hashtable with key "test", I'm trying to access it with (define t "test") (hashq-ref ht t) but it only returns #f. If I replace variable t with "test" it works.
<rekado>sneek: later tell nly There’s an old discussion re XML namespace handling that might be of interest to you: https://issues.guix.gnu.org/issue/20339
<sneek>Okay.
<rekado>sneek: botsnack
<sneek>:)
<dsmith-work>sneek: sneek ?
<dsmith-work>sneek: sneek is a good bot
<sneek>So noted.
*sneek wags
<daviid>str1ngs: i don't think you need any signal callback, from a user, to make and run an application, at least it runs fine using clutter, and i bet it does using gtk 'only' (without gio) - the activate signal has been emited when guile-gi receives it, and spk121 decided to implement there the win min size and ... but that can be done at gtk-win creation ... and i don't think the app will 'lock'
<daviid>str1ngs: and that code segfault, probably a g-golg bug/missing feature, so let's investigate better ... it should never segfault, if passing good code of course, and that is where i needed help - is what is written correct?
<daviid>is there a 'granma' step-by-step guile to install guile on a w64 machine?
<daviid>* ... guide ... somewhere?