IRC channel logs

2019-09-08.log

back to list of logs

<lispmacs>does guile have something like type-based procedure dispatch?
<lispmacs>wait, that is goops functionality, I think I remember now
<lispmacs>been a while
<daviid>str1ngs: will look into the (make <gtk-text-iter>) you reproted asap, tx
<str1ngs>daviid: thank you
<nly>hi roptat
<nly>i've been learning a lot from guile-torrent
<nly>can i write the 'pieces' bytevector in a meaningful format?
<nly>such as a base16 string
<ft>nly: There is the (rnrs bytevectors) module, that contains all sorts of deserialisation functions like bytevector-u16-ref and utf16->string.
<ft>See API Reference → Data Types → Bytevectors in the manual.
<nly>thanks
<apteryx>hello; is there a set of libraries for parsing sexp already? I'm interested in writing some indentation code.
<apteryx>I need to know the level of parens, the scope of the encapsulating sexp, stuff like this.
<apteryx>(that question is a bit naive -- there has to be a sexp parser available, given that I can run scheme code, but I'm not sure if it's made available to the users through some neat interface)
<weinholt>apteryx, i'm sure there are other options, but here's mine: https://github.com/weinholt/laesare/
<weinholt>it lacks much of guile's supported syntax though
<apteryx>weinholt: hey, thanks; it might be a good inspiration to define the very restricted set of things I need for my very limited use case.
<roptat>nly thanks, the project is a bit on hold for now though ^^
<heisenberg-25>rain1: is #akku active? I asked there and didn't see any response
<weinholt>heisenberg-25, you just didn't hang around long enough :)
<chrislck>trying to create function which caches results. eg. (fib n) I wish to create (define fib (make-cached-function (lambda (n) ...))) whereby make-cached-function takes care of bookkeeping the hash-table. anyone done one before?
<nly>in guix there's a (guix memoization) module
<nly>228 lines
<nly>i don't know much else about it, but i've used it before
<chrislck>Ok this works. http://paste.debian.net/1099511/ watch CPU spike when running (fib 30000)
<spk121>hello guilers. What is the best way to draw a plot in Guile. For my GUI project, I'm going to make a plot of memory usage as a function of time.
<mwette>GUI project w/ what package?
<spk121>We've been working on a GTK wrapper called guile-gi. And with that, I'm trying to write a graphical debugger for Guile called yvdebug.
<mwette>I googled and got gtkmm-plplot, but that is apparently far from gtk3 friendly
<mwette>cool -- been waiting for guile debugging support
<str1ngs>spk121: I would use cairo, should work with guile-gi
<spk121>i know someone make an SVG library at some point. It wouldn't be too hard to make my own plots in SVG, I guess.
<str1ngs>should work*
<str1ngs>spk121: I think you want something like gnome-system-monitors resource tab?
<str1ngs>in terms of plotting
<mwette>I have done graphics using SVG => Cairo in guile
<mwette>but I think you want a real-time plot that scrolls, yes?
<spk121>str1ngs: that's the general idea. There is a guile procedure called `gc-stats` that I want to poll
<str1ngs>I think cairo would be good for a trivial start
<str1ngs>I would think cairo has typelibs you can use with guile-gi
<spk121>cool. I'll start with cairo. I've done some work with it, so it should be ok.
<str1ngs>I'm curious what gnome-system-monitor uses if it's a custom control. or something that can be reused
<spk121>str1ngs: that's an interesting idea
<spk121>wingo: I want to make a gui widget for (gc-stats). Is guile-charting still workable? Do you know of anything better?
<janneke>spk121: trying to upgrade to guile-gi v0.2.0, how do i change (set-policy window POLICY_AUTOMATIC POLICY_AUTOMATIC)?
<janneke>i'm looking for symbol->...policy...; previously G_MESSAGES_DEBUG=all <program> would show every symbol, but i cannot seem to find it
<spk121>janneke: lemme check
<janneke>hmm, and STATE_NORMAL .. iwbn if i could find the new names myself... :)
<janneke>(override-background-color ebox STATE_NORMAL bgc)
<spk121>janneke: i know. It was one of our discussions arguments about 0.2.0. Trying to solve the problem of enum groups, but, the cure may be worse than the disease
<janneke>spk121: i like the change in general, could be a documentation thing
<janneke>it's very schemy this way
<spk121>janneke: the problem is that we've made assumptions about typelibs being right, and they are often wrong
<janneke>ah, that's less than great
<spk121>janneke: (set-policy win (symbol->policy-type 'automatic) (symbol->policy-type 'automatic))
<janneke>spk121: tnx!
<civodul>spk121: re plotting, there's guile-charting by wingo
<spk121>janneke: and the other is (symbol->state-type 'normal)
<janneke>spk121: thanks!
<spk121>civodul: cool, I'll check that out
<mwette>fyi guile-charting is now located at https://gitlab.com/wingo/guile-charting
***rubdos_ is now known as rubdos