IRC channel logs

2019-08-27.log

back to list of logs

<str1ngs>sneek: later tell nly. the new mru seems to fix the buffer kill race condition. but now sometimes buffer-enter-hook is not called, after killing a buffer and it switch's to another buffer.
<sneek>Okay.
<daviid>str1ngs: i just pushed a patch that fixes the GI typelib bug: incorrect *-new returned value class names, so for example (webkit-web-view-new) -| #<<webkit-web-view> 5648cf58ec20> (and not a <gtk-widget> instance prior to the patch
<daviid>and just pushed another patch that enhance the above, in that return-value->scm will now verify a function type-spec only once
<str1ngs>daviid: a that's a good fix will test this out.
<lispmacs>hi, what is procedure for starting a new process and connecting to its stdio/stdout?
<lispmacs>i think I found what I was looking for in Pipes section of the manual
***ng0_ is now known as ng0
<g_bor>Hello gentle people!
<g_bor>Just to answer my question regarding repost handling in guile web server:
<g_bor>I found out that this is a firefox bug, not a guile bug :)
<g_bor>It is fixed in firefox62.
<civodul>g_bor: interesting that it turned out to be a Firefox bug!
<civodul>usually, you're debugging your own stuff, and you blame everything from gcc to the kernel...
<civodul>... just to find out that the bug is obviously in your own code :-)
<g_bor>civodul: yes, it is.
<g_bor>When resending post data firefox calculated the wrong content-lenght value.
<g_bor>I believe that creating this minimal reproducer helped a lot, as it became nearly impossible that the error is in my own code :)
<g_bor>I just wasn't sure if it is in guile, or in the browser.
<civodul>heh
<civodul>were you the first one to report that bug?
<g_bor>Finally I did a tcpdump to see what's going on, and noticed the wrong content-length.
<g_bor>No, it was already fixed. It's just both icecat and debian firefox is still too old.
<g_bor>Here is a link for the report: https://bugzilla.mozilla.org/show_bug.cgi?id=1434553
<g_bor>it's been reported two years ago.
<nly>is there anything in scheme like 'partial' and 'rpartial' from emacs dash library?
<jlicht>nly: I was wondering the same thing recently, but I just used `Curried Definitions' from (ice-9 curried-definitions) to solve my issue. It might not help you though, sorry!
<nly>partial is this one, here: https://github.com/magnars/dash.el/blob/master/README.md#-partial-fn-rest-args
<nly>thanks jlicht
<nly>it'd be nice if these worked for anonymous functions too
<g_bor>nly: srfi-26 can also be of iterest...
<nly>ah, i keep disconnecting
<nly>g_bor: i use srfi 26 all the time :)
<nly>jlicht: this partial seems to suffice for now http://nly.info.tm:9001/guile/partial.scm
<wingo>o/
<jlicht>nly: nice! It even works for for nullary functions
<nly>jlicht: i just updated it, with rpartial :)
<nly>0/
<civodul>heya wingo!
<wingo>hi :)
<jlicht>Using guile-fibers, is there a safe way to do start other processes, while still having some control using e.g. chdir, setgid, setuid?
<wingo>jlicht: i think maybe? make a dedicated fiber that processes process spawn requests over a channel. then all spawns are serialized through it
<wingo>so it can set the global state as appropriate before spawning processes
<wingo>does that work?
<jlicht>wingo: it does! Combined with some `with-<whatever' macrology it does the trick. Thanks!
<wingo>cool :)
<jlicht>Am I digging a nice me-shaped hole by using `dynamic-unwind' i.c.w. fibers though?
<wingo>jlicht: i think yes :)
<jlicht>wingo: morituri te salutamus
<jlicht>thanks anyway. Walking the DAG and adding parallelized startup in shepherd using fibers is much harder than I thought it would be :/
*wingo found a very nice bug in cse that's probably there in 2.2 also
<civodul>how nice is that? :-)
<wingo>what can i say, i am like a computing entomologist :)
<civodul>heh
<civodul>does it have a simple reproducer?
<str1ngs>sneek: later tell daviid. the more accurate return values looks good. though this creates an issue when matching with arguments. here is my test case http://paste.debian.net/1097610. which fails with g-golf/hl-api/function.scm:548:13: In procedure prepare-gi-args-in: Throw to key `match-error' with args `("match" "no matching pattern" (enum webkit-network-proxy-mode #<<gi-enum> 5614f49614e0> 94648005204544 #t))'.
<sneek>Got it.
<str1ngs>sneek: later tell daviid. this happens with other functions as well not just enum. I used this the above example since I hope it covers once like object as well
<sneek>Will do.
<daviid>hi guilers!
<sneek>Welcome back daviid, you have 2 messages.
<sneek>daviid, str1ngs says: the more accurate return values looks good. though this creates an issue when matching with arguments. here is my test case http://paste.debian.net/1097610. which fails with g-golf/hl-api/function.scm:548:13: In procedure prepare-gi-args-in: Throw to key `match-error' with args `("match" "no matching pattern" (enum webkit-network-proxy-mode #<<gi-enum> 5614f49614e0> 94648005204544 #t))'.
<sneek>daviid, str1ngs says: this happens with other functions as well not just enum. I used this the above example since I hope it covers once like object as well
<daviid>rekado: tx for the logs again! don't you think it would be better to present the front log page with dates sorted in a lifo mode?
<daviid>str1ngs: sorry about this, i'll fix this right now, give me a sec
<daviid>*a few mins :)
<str1ngs>daviid: no rush. it's just a FYI
<daviid>str1ngs: i pushed a fix
<androclus>hey, all.. silly question.. what channel would you recommend less for the guile devs and more for those programming in (and learning to) guile? or does #scheme sort of serve that purpose?
<androclus>(just getting started here..)
<bandali>hey androclus, not silly at all :) fwiw, this channel is often kind of quiet
<bandali>regardless, a number of guile devs/experts hang around here
<bandali>perhaps like you said you could try other lisp/scheme related channels for general lisp/scheme questions
<bandali>too
<bandali>also, you could try asking your questions on the guile-user@ or guile-devel@ lists
<androclus>okay, thx :-)
<bandali>no problem :)