IRC channel logs

2019-08-23.log

back to list of logs

<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>GoodBot
<daviid>str1ngs: I just pushed a 'Code review and new interfaces - The g-inst(ance) cache' patch to g-golf
<daviid>str1ngs: so, untill i find a solution to 'g-golf %g-inst-cache to be(come) gc friendly, you may g-inst-cache-remove! entries 'yourself' if/when you know that a specific <gtype-instance> instance is not referenced anymore anywhere in your scheme code - this said, it might not even be necessary you do anythng 'for now' unless you plan to have a few millions insances ...
<civodul>Hello Guilers!
*civodul wonders whether/how guile-simple-zmq could be used with Fibers
<lloda>civodul: thx for the explanation
<lloda>tbh I wish I understood my tools better
<lloda>my gdb skills are pathetic
<civodul>lloda: heh, np :-)
<rekado>Hey Guilers, historic #guile logs are now available here as well: http://logs.guix.gnu.org/guile
<rekado>unfortunately, about one year of logs is missing.
<rekado>they were not included in the SQL dump I received.
<lloda>I will post a followup to https://lists.gnu.org/archive/html/guile-devel/2019-08/msg00007.html over the weekend
<lloda>on guile-user
<lloda>as I'm done with the basic stuff
<lloda>and it's already a lot better than what comes with Guile, so I'd like to be able to use it myself
<lloda>only need some help with optimization
<lloda>also I think a couple of functions are needed in Guile
<lloda>rank-1 copy and fill for all vector types
<lloda>e.g. bytevector-copy! doesn't take a stride, and there's no equivalent vector-copy!
<lloda>and I don't think an external lib should be needed for this
<lloda>I tried to follow some of the vm assembly and I really don't understand it :-/
<lloda>maybe the rank-1 ops can be taken from gfortran, there must be something like that in there
<lloda>I mean just a plain C loop would be a lot faster than what Guile does atm
<manumanumanu>daviid: Sorry about the late reply. What I'm trying to do is to have a list of valid forms (in-list, in-range etc) that you can add to if you add another supported form. The problem is I that I only want the added forms to be visible to the ones that has imported the module. Since this is a macro (albeit a 600 LOC one) I figured I can just use syntax objects and let macro hygiene handle the rest. #'in-stream
<manumanumanu>is not the correct #'in-stream unless you have imported (loops seq streams).
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>sneek: botsnack
<sneek>:)
<manumanumanu>dsmith-work: Ahoy hoy!
<OrangeShark>Happy Friday!
<nly>i was reading 2013 logs(thanks rekado), what's the problem with ice-9 qs?
<civodul>nly: you'll have to be more specific because not everyone is done reading the 2013 logs yet ;-)
<nly>there was not much, but this
<nly>15,99<mark_weaver>99,99ijp: regarding queues: yes, please, let's have a sane queue module.
<nly> http://logs.guix.gnu.org/guile/2013-03-29.log
<nly>it's fun to see how guile was built in those days, but i know that guile has even older/richer history :)
<nly>at least the little that can be gleamed from logs
<civodul>heh
<civodul>i suppose this was about (ice-9 q) being imperative and overall not great
<nly>we caught a bug in emacsy mru-stack which uses q
<nly>maybe not related tho
<dsmith-work>sneek: seen mark_weaver
<sneek>I last saw mark_weaver on Jan 13 at 04:29 am UTC, saying: :).
<wingo>wb civodul :)
<wingo>you might be interested by http://git.savannah.gnu.org/cgit/guile.git/commit/?id=356ea0971996c81997481f7e1f9cf27cdd594a34
<wingo>feedback welcome
<civodul>hi wingo!
<civodul>wingo: i like it! at last cross-procedure inlining! \o/
<civodul>a couple of ideas:
<civodul>1. perhaps "guild compile" should have a flag to change the default?
<str1ngs>daviid: will check it out thanks.
<civodul>2. should the default be #f, to reduce unwanted breakage?
<str1ngs>nly: did that bug every get fixed? or are you thinking of another solution?
<nly>str1ngs hi
<nly>i haven't done anything about the mru issue, but i'll probably make an attempt tommorrow
***sneek_ is now known as sneek
<manumanumanu>nly: I just published some old r6rs code that has both a mutable heap and a functional pairing-heap (which is probably better for most use cases than leftist heaps): https://hg.sr.ht/~bjoli/misc/browse
<manumanumanu>under both mutable heap and pairing-heap
<manumanumanu>which can be used as priority queues
<nly>manumanumanu cool, thanks
<manumanumanu>nly: I just had an idea for a functional fifo. If that is what you are looking for, i can ping you in a couple of days when I put it online.
<manumanumanu>O(1) enqueue and amortized O(1) for dequeue.
<nly>sure
<manumanumanu>will do. Good night everyone!
<nly>mru -> most recently used, first in last out
<daviid>manumanumanu: fwiw, methods are only visible to those module that imported the module(s) that define and export them ...
<manumanumanu>exactly. I wanted to know how this is done. Since I am only working with syntax objects, I found an easy solution :D
<manumanumanu>nly: for that you should just use a list. Perfect use case :D
<manumanumanu>oh. my idea was actually nothing new. Googled it. Nice to know that it works though :D :D
<nly>just a little bit more is needed tho, setting something as first after it's been used
<daviid>manumanumanu: 'how this is done' is a guile module 'thing', no a goops 'thing' - this is explained i the emal i wrote to help those who want to understand 'what's going on' and how to mimic clos, if that is what they want of course ...
<manumanumanu>daviid: I will RTFM! Thanks for taking the time to reply to me!
<daviid>wc!
<nly>g'night and thanks