IRC channel logs

2019-08-18.log

back to list of logs

<daviid>str1ngs: when you paste an example, please dont use srfi-64, just paste an example - I can't use it and wish I can jus copy/paste - then I don't use srfi-64 as a test suite anyway ... thanks!
<daviid>str1ngs: then, for your own code and tests, you may selectively import gtk-init, gtk-init-check .. like this
<daviid> https://paste.debian.net/1096313/
<str1ngs>daviid: the selective import is nice thanks
<daviid>wc!
<daviid>str1ngs: back to your earlier claim, where it's true that these *-get-* *-set-* methods do not work yet, I will work on it of course, note that you should (lways) be able to get those values using their property accessor, and somehow, it becomes actually secondary to have those C like getters/setter, again, I will work on those of course, but utlimately, you might even choose not to use them, for example
<daviid> https://paste.debian.net/1096345/
<daviid>the same reasoning applies for constructors that takes no arguments: in this case, we may even always prefer to use the scheme way (make <webkit-web-view>), instead of calling (webkit-web-context-new) - which currently is not (yet) working I'll work on those as well of course
<daviid>this said, I definetely need to work on this and provide those for opaque boxed type, like webkit-web-context, precisely provided to get/set opaque boxed type instances ...
<str1ngs>daviid: I had given that some thought myself, and I meant to ask which was the preferred way. I agree that goop constructors and slots are probably better approach. I will try to remember that going forward, I'm glad you brought this up. I don't think it helps I am more familiar with C and the corresponding functions.
<daviid>str1ngs: right now, I'll work to solve the problem related to methods that get- set- opaque boxed type, since there is no other option ayway, then on those that get- set- gobject subclass instances, which gnrally already work sing accessors ...
<daviid>str1ngs: do you know if ther is any diff between webkit-web-context-get-default and webkit-web-context-new?
<str1ngs>(webkit-web-context-set-network-proxy-settings (!web-context view) 'custom settings) still won't work because the web-context is a #<pointer> and not a <webkit-web-context> so it has no !g-inst. but I'll put a complete working example for this together that you can copy and paste.
<str1ngs>daviid: I believe they are different webkit-web-context-get-default returns a the global context. and webkit-web-context-new creates a new one that can be used with webkit-web-view-new-with-context
<str1ngs>daviid: i'll read the docs and verify that for sure though
<daviid>don't worry
<daviid>i'll make both work
<daviid>(!web-context view) returns a pointer to an opaque boxed type, webkit-web-context-set-network-proxy-settings should accept it, but i didn't try here
<str1ngs>daviid I'll retest the set-network-proxy-settings an if I still have a problem post a complete copy and paste example for you .
<daviid>ok
<str1ngs>daviid: also webkit_web_context_get_default () is more useful for me. since I plan on providing global proxy settings. find grain per view proxy adds extra complexity I'd rather avoid.
<daviid>ok, i should have that working well by tomorrow
<str1ngs>daviid webkit_web_context_get_default () essentially is the context used by default for all new web views unless context is specified with webkit_web_view_new_with_context
<daviid>str1ngs: ok, my question was more - does it return a new pointer every call, or not?
<daviid>i guess it does
<str1ngs>_new should yes, default should not
<daviid>correction, i guess it doesn't
<str1ngs>I can't check in scheme, but I'll try with C
<daviid>don't bother, i'll be able to check in scheme in a short time
<str1ngs>daviid: http://paste.debian.net/1096350
<daviid>str1ngs: ok tx, that confirms what i thought
<daviid>str1ngs: I pushed a fix which solves the problem of functions and methods that return a GI object type, but it's a wip
<daviid>str1ngs: you may read the commit for a better understanding of what I refer to, then here is an exmaple for you to reproduce and understand what I am talking about ... https://paste.debian.net/1096372/
<daviid>str1ngs: it works and what is being said won't block you to use it, but I need to find a better solution to what is (I hope clearly) explained in the commit message
<daviid>spk121: I wonder what you do in guile-gi, I'd be happy if you could read the commit http://git.savannah.gnu.org/cgit/g-golf.git/commit/?h=devel c1e32d2e7e4cc7d35fee53d8a0598d2c96774542 and let me know what you think about all this ...
<apteryx>how do I return the nth list in guile? 'nth' doesn't seem to be available
<apteryx>nth element of the list*
<apteryx>list-ref
<apteryx>I'll remember to search for 'kth' instead of 'nth' in the Guile Reference for the next time... ;-)
<str1ngs> daviid great , will test this out today.
<str1ngs>daviid: I can see problem b being a tough issue to solve. I guess the important thing is it returns a matching g-inst pointers. but I can see how this could cause a problem. namely in with say garbage collection.
<pkill9>does Guile have a function for moving a file? there is copy-file, but no move-file
<cehteh>hint: search for 'rename'
<pkill9>thanks
*wingo found interesting codegen + coverage issue
<wingo>just pushed a pretty neat top-level binding optimization pass; enables inlining / contification of top-level definitions within a compilation unit
<wingo>see comment in https://git.savannah.gnu.org/cgit/guile.git/commit/?id=d7bbf6d5db2f0eb2ee44557c5d3f65977f432ed3 for mechanism
<wingo>and documentation in https://git.savannah.gnu.org/cgit/guile.git/commit/?id=356ea0971996c81997481f7e1f9cf27cdd594a34 for what it means on a semantic level
<wingo>lol ntakl goes from 18s to 8s :)
<janneke>wingo: \o/