IRC channel logs

2019-08-13.log

back to list of logs

<daviid>I don't like that convention that rename packages guile-*, please don't do that for g-golf, thanks
<str1ngs>daviid: I updated my definition in nomad. I just have not push the changes yet
***scs is now known as Guest89253
<str1ngs>daviid: here's a simple char** example using glib. http://paste.debian.net/1095535
<str1ngs>but maybe const gchar * const *strv is not handled yet? or an edge case?
<str1ngs>actually proxy settings new takes const gchar * const *ignore_hosts so this should be a good test case I think.
<str1ngs>but proxy setting seems to have annotation for types etc
<daviid>str1ngs: we'll be with you int 10mi
<daviid>*in 10min
***scs is now known as Guest37443
<daviid>str1ngs: the thing is that I should block the import of Glib, GObject, because, for bootstrap reasons, what is needed is binded 'manually', and automatic bindig of those conflict,obviously ...
<daviid>só, I would need to manually bind g-strv-contains, which I won't , now
<daviid>but tx
<daviid>it is fine to test using s selective imports from clutter, gtk, webkit ... at least for the time being
<daviid>wrt to webkit-network-proxy-settings-new, I'd like to know if you ever made use of it from C? did it work?
<dsmith>sneek_: botsnack
<dsmith>sneek: botsnack
<sneek>:)
<dsmith>sneek: seen str1ngs
<sneek>str1ngs was here Aug 13 at 01:09 am UTC, saying: but proxy setting seems to have annotation for types etc.
***dsmith is now known as gorf`
<gorf`>Hey
***gorf` is now known as dsmith
<dsmith>sneek: seen gorf`
<sneek>gorf` was here Aug 13 at 02:40 am UTC, saying: Hey.
<str1ngs>daviid: I'll try to find a better example for ghar** I though I might be pushing my luck wit GLib :)
<str1ngs>err gchar**
<daviid>str1ngs: don't worryfor now
<str1ngs>I'll locally test proxy setting. but it's probably going to be an online test. which wont be good for a g-golf test. Maybe I'll find something in clutter that uses char**
<daviid>str1ngs: I need to check g-golf against namespace, wether oeone like it or not. people/distro may skip checks anyway, individually, or 'per distro', but I can't not check g-golf against 'ral' namespace
<daviid>wrt webkit-network-proxy-settings-new, I thought you 'severely' did need it, did use in in C .. but no problem either, just wanted to make sure how can possibly anyone make use of the result of that function, if it is, by definition, always an empty ist ....
<daviid>#instrospection did not answer either ...
<str1ngs>yes, we need it. right now it's in pure C. but I need to port it over.
<daviid>an web is not my domain, but i want nomad to be happy
<daviid>ok, if you need it, tell me what the C code returns
<daviid>my guess is it is an empty C struct, but ...
<daviid>a pointer to, to be more precise, but what is its content is the question of course ...
<str1ngs>should return WebKitNetworkProxySettings * webkit_network_proxy_settings_new ()
<daviid>yes
<daviid>which is an empty structure
<str1ngs>which is a struct yes
<daviid>an empty struct, in C,
<daviid>str1ngs: here is how g-golf sees it https://paste.debian.net/1095497/
<daviid>hence always an empty list when you call webkit-network-proxy-settings-new, no matter what ...
<str1ngs>mainly it gets passed to webkit_web_context_set_network_proxy_settings which sets the proxy setting given the context you pass
<str1ngs>normally you just find the global context and pass that. but you can also get the context from a current webview
<daviid>str1ngs: i don't now how to say it in a different way: the GIStructInfo that I receive from the "WebKit2" namespace is empty
<str1ngs>I was looking at structs abit, but I wasnt 100% sure how you would create a new one in g-golf
<daviid>it is empty, no definition, no fields ...
<daviid>besides, I can't see any definotion in their manual either
<str1ngs>the struct could have private fields though. but it' just a struct not GObject class which is add
<str1ngs>odd*
<str1ngs>let me see if I can find it in a header file
<str1ngs>my guess if it has fields its of char* proxy_host char** ignore_hosts. would make sense
<dsmith>sneek: botsnack
<sneek>:)
<nly>nomad now runs from 'guix build guix-loca.scm'
<sneek>nly, you have 2 messages.
<sneek>nly, str1ngs says: substitution looks good. Ironically I had a commit almost identical to yours.
<sneek>nly, str1ngs says: substitution looks good. Ironically I had a commit almost identical to yours.
<nly>hello
<str1ngs>nly: oh you picked up on my changes. there are some cough hacks to get it working lol
<str1ngs>I had to propagate and use some uneeded imports to get it working. but I think it can be refined
<str1ngs>err inputs I meant
<nly>v can clean it up as we go
<daviid>str1ngs: my battery is low, if I leave abruptly, bbl or tomorrow
<str1ngs>nly: for native-search-paths can you access inputs from there. might be better then wrapping if not we'll have to wrap GI_TYPELIB_PATH
<str1ngs>daviid: no worries
<str1ngs>nly: nvm you beat me to it lol
<str1ngs>nly: nice work, thanks for these additions
<str1ngs>nly: expect some breakage though. I'm still porting somethings
<nly>ok
***scs is now known as Guest80137
***scs is now known as Guest61143
<zhlyg>Could guile's boehm-gc usage somehow interfere with the clients boehm-gc?
<wingo>moo
<wingo>zhlyg: if guile and a client attempt to initialize boehm-gc in different incompatible ways, maybe
<wingo>it can work tho
<zhlyg>I get a sigsegv in GC_malloc_kind, not sure why, looking at it in gdb now. Next attempting to use GC-8.0.4 in client, but guile would still be at 7.6.4.
<wingo>does anyone here use arch linux, and if so, can you request an update of https://aur.archlinux.org/packages/guile-git/ plz
<wingo>to package guile 2.9.3
<wingo>that way i can poke ecraven to run some benchmarks :)
<ecraven>;) I keep running into problems with specific Schemes, I really have to turn everything into containers :-=
*wingo has a fixing-letrec-reloaded pass, woo
<zhlyg>ecraven: guile+rumpkernel ? :)
***scs is now known as Guest83406
***scs is now known as Guest94852
<wingo>manumanumanu: just landed "fixing letrec, reloaded" which improves codegen for local "define"
<wingo>and is a step on the path towards better top-level complication too
<jonsger>wingo: In theory I could now start with the ppc64le stuff, as my machine is up and running. But I need to fix some more important packages before (mesa, firefox, nextcloud, libreoffice...)
<lloda>is 'FAIL: version.test: version reporting works' something obvious? it happens all the time and I just ignore it
<wingo>lloda: i think it means you need to autoreconf -vif
<wingo>lloda: it's not important
<lloda>ok thx
<lloda>I think I've asked it before & forgotten it :-|
<wingo>np :
<wingo>)
<wingo>jonsger: lmk when you want a video call regarding lightening
<wingo>probably when you have a couple weeks of good hacking time free ahead of you
***scs is now known as Guest71829
<dsmith-work>Tuesday Greetings, Guilers
<wingo>heya dsmith
<dsmith-work>wingo: Very exciting all the happenings with the compiler.
<dsmith-work>wingo: And a tarball release build took only 6 minutes!
<wingo>:)
***ecraven- is now known as ecraven
<str1ngs>daviid he's a basic proxy setting test case. I used serfi-64 http://paste.debian.net/1095618
<str1ngs>srfi*
***scs is now known as Guest35710
<sp1ff0>Hi: having trouble with guile & readline on MacOS: (use-modules (ice-9 readline)) => In procedure dynamic-link: file: "guile-readline", message: "file not found"
<sp1ff0>Has anyone seen this before?
<str1ngs>sp1ff0: how did you install guile with homebrew?
<rekado>this means that the binary library “guile-readline” wasn’t found. Try to locate it and add the location to LD_LIBRARY_PATH, for example.
<sp1ff0>str1ngs: yes, homebrew
<sp1ff0>rekado: trying that
<dsmith-work>sp1ff0: Not sure if it's still true, but MaxOS comes with a readline-like library that doesn't quite exactly match the gnu readline api. ./configure thinks it's available, but when guile actually tries to use it, it fails.
<sp1ff0>Ok. I'll horse around with dtruss to see if I can tell which .so it's trying to load. Thx all
<sp1ff0>DYLD_PRINT_LIBRARIES=YES did the trick
***scs is now known as Guest57296
***scs is now known as Guest10223
<daviid>str1ngs: well thanks, but that does not help, I know what g-golf see/does wrt webkit-network-proxy-settings-new, and no matter what, it will always return an empty list, as explained here yersterday. this is a WebKit2 problem, not a g-golf problem
<daviid>str1ngs: afaict, no GI language binding to WebKit2, on earth, will be abble to use that function
<str1ngs> daviid okay, is (webkit-web-context-get-default) returning unspecified expected behavior as well?
***scs is now known as Guest86328
<daviid>str1ngs: let's be very precise - the result of calling webkit-network-proxy-settings-new from g-golf, or any other GI language binding is not undefined, it si very well defined, it is the empty list, always
<daviid>now, webkit-web-context-get-default is supposed to return an instance of the <web-kit-web-context> sublass, I see although the signature is good in g-golf, it does not return an instance, that could be a 'still missing' feature in g-golf, let me check
<daviid>*<web-kit-web-context> GObject sublass
<daviid>str1ngs: do you happen to know if there is a webkit2 irc channel, if yes, on what server?
<dsmith>sneek: botsnack
<sneek>:)
<daviid>str1ngs: #webkitgtk on freenode