IRC channel logs

2019-08-08.log

back to list of logs

<str1ngs>dsmith-work: tell is useful when the source information is the bot, but you need to direct the response to someone in the channel
<apteryx>how can I set backtraces width to a bigger value, everywhere? I tried: (debug-set! width 180) in my ~/.guile but that doesn't do it.
<nly>hi janneke
<nly>in nomad if i use (message ..) imported from (emacsy emacsy) inside the browser it works. but if i call it from a repl connected to the browser it returns an error "abort to unknown prompt".
<nly>is this related? https://git.savannah.nongnu.org/cgit/emacsy.git/tree/emacsy/c-tokenize.lex?h=wip-doc#n187
<nly>maybe the command 'abort' cannot find the default prompt when called from a repl context? idk. Maybe someone else knows better
<nly>it'd be great if all procedures/values inside nomad behave just the same even if called remotely.
<manumanumanu>Ahoy hoy!
<manumanumanu>What would be a good name for a binding construct? I am writing a (def ...) macro that behaves like define, but with support for definitions in expression context, and apart from subsequent (def ...) I also want a binding construct that gets converted to let* for some extra speed. (bind name expr) would be nice, but bind is already a guile procedure
<manumanumanu>(let! name expr)?
<manumanumanu>(def ...) gets converted to letrec, same as (define ...).
<lloda>wow logs!!! much props rekado_ / rekado
<wingo>manumanumanu: define is the right name!
<wingo>we should change to be like racket and support mixed definitions and expressions
<manumanumanu>Well, I could do that, but I want a binding construct that expands to let*
<manumanumanu>or let
<manumanumanu>that doesn't "nest"
<manumanumanu>so I can do (let! a 5) (let! b 6) rest ... and it converts it to (let ((a 5) (b 6)) rest ...)
<manumanumanu>right now I have (def ...) let! and let*!
<manumanumanu>And I suspect that guile proper wants a real implementation instead of a macro one.
<manumanumanu>that is bolted on as a module
<manumanumanu>anyway, I agree with you
<manumanumanu>it is not a hard transformation to do (even I can do it, apparently)
<manumanumanu>but doing it on the macro level means I might not play nice with other macros.
<manumanumanu>but looking at the code for working with tree-il I... might... be able to do something
<manumanumanu>but it terrifies me
<wingo>:)
<eiro>hello people
<brutelumpen>eiro, hi
***Server sets mode: +nt
<rekado_>logs are now at logs.guix.gnu.org/guile
<pkill9>does `guix deploy` handle running `guix pull` on the remote machine?
<ng0>you might want to filter out the IPs for #guile and #bootstrappable, ie the join/part/leave/quit events
<ng0>it's not as if irc would be the best protocol to do this, but for stored logs it would be nice.. at least that was a request grothoff had for all channels at some point before the really long discussion became too tiring for me
<ng0>of course what you do is up to you, i just see that it's done this way already in #guix
<ZombieChicken>hmm
***jao is now known as Guest77149
<pkill9>oops, wrong channel
<OrangeShark>yay logs :)
<rekado_>ng0: yeah, not sure why it doesn’t do it for #guile and #bootstrappable; it’s the same application. Will fix this later.
<rekado_>ah, it’s an old shell script…
<ng0>ok :)
<rekado_>it’s now handled by the log viewer
<rekado_>thanks for reporting it
<OrangeShark>rekado_: it works, great :)
<rekado_>(the link back to all the logs leads back to the *guix* logs; I’ll do something about this later)
***jao- is now known as jao
<dsmith-work>str1ngs: Exactly!
<dsmith-work>Thursday Greetings, Guilers
<str1ngs>greetings dsmith-work :)
<apteryx>my color often gets lost at the Geiser REPL. any way to get it back without restarting the REPL?
<str1ngs>apteryx: can you define what you mean by color?
<apteryx>the different colors of the prompt, comments, REPL messages, etc.
<apteryx>sometime some output seems to confuse Geiser and everything turn into the same color
<str1ngs>apteryx: sounds like either an issue with gieser, or maybe the output?
<OrangeShark>the output gets truncated
<OrangeShark>for example in output that is really long, you might get a start " for a string, but no closing "
<ZombieChicken>Any of the nomad devs here atm?
<str1ngs>ZombieChicken: yep, whats up?
<str1ngs>also there is #nomad-browser
<ZombieChicken>Ah. I'll just go there then and ask my question
<daviid>sneek: logs?
<sneek>I could be wrong, but logs is http://bayfront.guixsd.org:3334/
<daviid>sneek: forget logs
<sneek>Okay.
<daviid>logs is http://logs.guix.gnu.org/guile/
<daviid>sneek: logs is http://logs.guix.gnu.org/guile/
<sneek>Understood.
<daviid>sneek: logs?
<sneek>Someone once said logs is http://logs.guix.gnu.org/guile/
<daviid>happy logged friday guilers!
<daviid>who has admin right here may change the subject line to inform of this new log adddress
<karlosz>is anyone here familiar with the guile intermediate ir, or can direct me to someone who is?
<karlosz>or IRs, i should say
<mwette>guile ir: https://www.gnu.org/software/guile/docs/docs-2.0/guile-ref/A-Virtual-Machine-for-Guile.html#A-Virtual-Machine-for-Guile
<mwette>and: https://www.gnu.org/software/guile/docs/docs-2.0/guile-ref/Compiling-to-the-Virtual-Machine.html#Compiling-to-the-Virtual-Machine
<karlosz>yes, i saw those
<karlosz>as well as a lot of andy wingo 's posts
<karlosz>im more wondering how cps soup has worked out
<karlosz>i'm a common lisp implementer and the question of ssa or not has really knawed at me and other implementors
<davexunit>not to speak for andy, but my impression from reading his blog posts is that cps soup has been good overall.
<karlosz>one thing i never understood from reading the blog posts was - why cps soup and not ssa? it's not because of continuation support in guile, right?
<karlosz>one big problem we have is the representation of phi nodes - they seem yucky because they are special in the flow graph and require coupling between predecessors and arguments, as well as some invariants related with keeping them all in a cluster as the first instructions of a BB
<karlosz>so it's mostly notational stuff, but from what i gathered, cps soup really just is a different notation for ssa
<davexunit>that's a question andy could answer when he's around.
<davexunit>which he is often enough. or you could mail the list.
<dsmith-work>daviid: wingo, civodul, and mweaver (and maybe rlb)
<mwette>I believe the guile cps design is inspired by https://www.microsoft.com/en-us/research/publication/compiling-with-continuations-continued/
<mwette>The first chapter of the book compiling with continuations by appel explains pros/cons of SSA vs CPS
<karlosz>i've read it
<mwette>CPS and SSA have been shown to be equivalent. I don't have the reference
<karlosz>but CPS soup is different
<karlosz>because there are no scope trees, as wingo writes about
<karlosz>the appel texts all predate MLTon's CPS -> SSA switch, and they're a little more biased to CPS, being older
<karlosz>Appel actually shows equivalence in his textbooks, but it comes down to the notation actually mattering when it comes to ease of transformation and keeping the notation valid
<mwette>it's been a while since I dug in. here is another that you may have alredy read: http://wingolog.org/archives/2011/07/12/static-single-assignment-for-functional-programmers
<karlosz>yep. another interesting thing is that in guile and cl we *don't* have whole program optimization
<karlosz>so its really not clear when ssa should be introduced
<karlosz>there's sort of a phase ordering problem there too, because using ssa would make certain closure optimizations easier, but without whole program optimization, its harder to closure convert/maybe impossible after ssa transformation, especially when you have mutable closure variables
<mwette>you are way ahead of me -- I think you need to address the comments to wingo; I'm guessing he would be interested in a discussion
***karlosz_ is now known as karlosz
<dsmith-work>Off Topic: Anyone ever use Hy? I do lots of Python in $DAYJOB (hey, at least it's not Java or C# !), and a lispy face to the code sounds really attractive.
<mwette>dsmith-work: thanks for the Hy comment -- I'll be checking it out
<dsmith-work>mwette: What would be cool, is a py2hy to convert some existing code..
***karlosz_ is now known as karlosz