IRC channel logs

2018-09-06.log

back to list of logs

***Server sets mode: +nt
***rekado_ is now known as rekado
<Combinatorialist>What's the difference between string-concatenate/shared and string-append/shared ?
<chrislck>I believe string-concatenate is much more efficient than string-append
<chrislck>ha found from the archives https://gnunet.org/bot/log/guile/2014-03-25
<chrislck>I might be wrong tho
<Combinatorialist>Is there a version of set! that returns the new value instead of #<unspecified> ?
<Combinatorialist>and is there a way to test if #<unspecified> is an element of a list?
***heroux_ is now known as heroux
<lloda>sneek: later tell daviid please give a link to the working patches you have for guile-cairo and I'll try to merge them
<sneek>Okay.
<lloda>after many many years of using Unix terminals, I've finally started to use screen. Never too late...
<hugo>Combinatorialist: For the set question you could just write a macro:
<hugo>(define-syntax-rule (set*! var val)
<hugo> (begin (set! var val)
<hugo> val)) ; => #<unspecified>
<hugo>And for the secound one (using srfi-1):
<hugo>(find unspecified? lst)
<hugo>Where lst is your list
<janneke>iirc, guile-1.8 had (debug-enable 'debug) to drop into the repl/debugger upon error; how does that work with guile-2.2?