IRC channel logs

2018-08-06.log

back to list of logs

<mwette> /quit
***Elwell_ is now known as Guest50430
<wingo>i am an idiot. wrote a custom allocator, didn't test edge cases -> bugs
<weinholt>happens to everyone
<weinholt>i'm debugging after-gc-hook and have a pretty good test setup where i can reproduce the test failure
<weinholt>the failure correlates pretty well with the test scm_is_false (SCM_CDR (after_gc_async_cell)) being false in queue_after_gc_hook()
<weinholt>(strange sentence)
<weinholt>wingo, is there a debug printer that's usable if scm_display() is not working?
<wingo>weinholt: there are things you can do from gdb that directly try to interpret the memory
<wingo>civodul is the expert tho...
<wingo>(system base types) is the module, i think there is some support from gdb-guile to use it
<weinholt>well, it turned out to be null anyway
<wingo>heh
<wingo>weinholt: just for reference -- does your guile have threads
<wingo>?
<weinholt>yes, half a dozen
<wingo>k
<wingo>i guess you have verified that the libgc test suite is passing fine for you
<weinholt>will do so now
<wingo>i don't see a test failure there but that doesn't mean there isn't a guile bug!
<weinholt>libgc's "make check" passes
<amz32>weinholt: what are you doing?
<weinholt>amz32, trying to pin down where this is coming from "FAIL: gc.test: gc: after-gc-hook gets called": https://tests.reproducible-builds.org/debian/rbuild/unstable/amd64/guile-2.2_2.2.4+1-1.rbuild.log.gz
<roelj>When I have a function like this: (define* (test param #:optional '(a #f) #:key (b #t))), and I'd like to define a macro: (define-syntax-rule (t param) ...) Can I pass the #:b somehow via the macro?
<amz32>roelj: I think you don't need ' in '(a #f) check the manual to be sure; idk the core of the question tho
<chrislck>a kinda-noob question - when we do "(use-modules (srfi srfi-1))", why exactly is the expression (srfi srfi-1) acceptable as the parameter to use-modules? it looks like we're calling the function called (srfi) with argument srfi-1, and passing its result to (use-modules)... shouldn't it be (use-modules '(srfi srfi-1)) ??
<weinholt>use-modules is special syntax, like a macro
<roelj>chrislck: There's a file srfi/srfi-1.scm in the GUILE_LOAD_PATH, which gets read/loaded.
<roelj>chrislck: (srfi srfi-1) simply refers to that file.
<chrislck>ok. bit weird though. un-lispy!
<weinholt>sure, but (srfi srfi-1) when evaluated would normally try to look up srfi and srfi-1 in the environment. since use-modules is syntax, it doesn't evaluate its arguments
<chrislck>what other special syntaxes exist?
<weinholt>there's quite a bit. search the manual for "syntax:"
<chrislck>this part of scheme is something I'd rather leave as the 'internal magic' :)
<OrangeShark>You can look at some common ones that you might use like lambda, define, if, case, let, and many more
<chrislck>ok - lambda/define/if/let don't use any syntax-words, but (case x (...) (else ...)) does use the 'else' syntax-word... got it
<roelj>Uhh, how would you transform '(((hello)) ((scheme)) ((world))))) into '(hello scheme world)?
<chrislck>find a flatten function?
<spk121>roelj: (map caar '(((hello)) ((scheme)) ((world))))
<roelj>Woah, caar is cool :) Maybe we should consider calling it limousine
<roelj>See if that makes the code more understandable
<spk121>;-)
<roelj>Thanks!
<chrislck>my surprise to learn that .scm can accept emoji code in strings, and outside strings :-o
<roelj>Unfortunately my IRC client doesn't ;)
***rjungemann_ is now known as rjungemann
<rain1>you coudl recursively flatten any tree into a list if you like
<daviid> http://www.nongnu.org/grip/manual/grip.html#index-flatten
<dsmith>Hey Hi Howdy, Guilers
<daviid>hi dsmith! (not at work :))
<dsmith>Oi!
***dsmith is now known as dsmith-work
<dsmith-work>Whew. That'
<dsmith-work>s better
<daviid>oh! I thought you were on vacation :( sorry I to remind that's not thatcase :)
<daviid>dsmith-work: you're the only one I know who changes his nick depending on location (or activity) :)
<dsmith-work>daviid: Years ago, I would stay logged in from home and also from work.
<dsmith-work>The home machine is now a laptop and goes away with the lid closed, and I'm not on much there anyway.
<daviid>amz31: (for info, you have two active nicks, which makes completion fail ...) wrt to your quiz, yesterday about mapping values from one range to another ... these are very common and sometimes even mandatory procedures in image processing ... guile-cv has im-normalize and im-clip, and I should provide im-scale (not to confuse with im-resize, which guile-cv has, scale in img processing is precisely what you described, a map from a range
<daviid>of values to another ...)
<daviid>amz31: voilĂ , not sure I answer your quiz though ...
<xen1>
<amz31>daviid: tx, I know about autocompletion failure, I will fix later this week.
<amz31>daviid: thank you so much for the feedback on and explanation about my issue
<daviid>np! wrt irc, you can logout from one and regain the nick of your choice, if you resgistered
<daviid>the last cmmit for guile-pg is from 2015, that worries me bit, any active guile-pg user out there?
<daviid>postgres has eveloved so much, that big tech companies claimed that they will abandonn nosql to use it instead ... (I did read about htis recently but i lost the link)
<daviid>*evolved
<amz31>well, they are alternatives that are easier to setup than posgresql, less fluff more productivity
<daviid>I think a proper (and modern) binding to postres is something we can't offer not to have, so to speak, so I wish I had 3 lives ..., but I don't: I hope one of us will pick up guile-squee and turn it the best guile-bindings of all times :)
<amz31>daviid: nosql is not a thing anymore... i mean it was just a marketing buzz crack anyway...
<amz31>I looking for building foundationdb bindings, not sure when
<daviid>amz31: not to be pretentious, but Ive always quitely thought so, and neve investd in any ... but I'm glad postgres did full fill gaps, so 'they' can use it ...
<amz31>it's... wait forit... Apple's software.. . Apple bougth foundation db a few years back and made it free
<amz31>I agree postgresql bindings will be greqt
<amz31>I agree postgresql bindings will be great
<daviid>amz31: ok, if you are looking for jobs, and wish to offer to script and develop using guile instead of the snake :), then you'll see that the vast majority of the companies and research labs use postgres ...
<amz31>I fully agree, I dream of not being stubborn and less creative, I would have created guile bindings for postgres and would prolly be coding day and night in guile
<amz31>instead I code ads for the snake
<daviid>amz31: it's not we can't have other bindings, but not having a postgres top notch bindings, super tested, super documented, super maintained ... makes it difficult to offer to use guile ...
<daviid>what is ads?
<amz31>advertisments
<daviid>oh
<amz31>you don't want to know how bad it is..
<daviid>amz31: good binding wll challenge your creativity as well
<amz31>yes sure
<amz31>In september, I will try, I promise.
<amz31>in the mean time i must show my collegue once again that I am not a dummy coder and that I am tired of that monkey tasks
<amz31>s/that/their/
<amz31>I mean, is profesionnal coding always boring?!
<daviid>we need, imo at least, good postgres and gnome introspection (g-golf, I plan to start to work on it again - I wish I could find some external funding to work on this)
<weinholt>amz31, no, doesn't have to be boring
<amz31>weinholt: you are in over of the top company, that has decades of experience in CS... that should be much different, i guess
<daviid>what company, if not indescrete (top companies are not the most interesting imo)
<weinholt>me? ericsson currently, but i've resigned and have literally days left
<daviid>ah ok
<amz31>erirsson is like one of the biggest if not the biggest CS contributor
<amz31>in europe
<amz31>I don't know any other company like that, maybe Spotify looks alike but much smaller
<daviid>I thought it was seemens
<daviid>seimens, in europe
<amz31>ericsson has erlang afaik
<amz31>seimens might be big, but they did not free their language... i mean free computer science / engineering. Of course they other big computer companies in europe
<amz31>s/they other/they are other/
<amz31>actual skills that inherited by future generations, not magic.
<amz31>s/inherited/shared with/
<daviid>I'd like to transfrom my free s/w micro consultancy into an ngo, or close it and opening a new one, don't know yet, then invite all of you to help, participate, as shareholders, coders ... and (1) raise funding to write and maintain proper bindings to 'essential libs' and (2) start to offer consultancy using guile ... and I'm dead serious
<daviid>enough snakes in this stupid world
<daviid>:)
<daviid>I'll make a coffe, brb
<daviid>we could follow the igalia model
<amz31>what do you mean by igalia model? a team of remote dev dedicated to guile software?
<amz31>daviid: that's what guix foundation europe is for I guess
<amz31>for guix
<amz31>the thing is that we need a software to sell, IIRC igalia was selling GNOME consultancy
<amz31>I mean sotware or library to seel consultancy
<amz31>s/seel/sell/
<dsmith-work>amz31: I've almost always really enjoyed the work I was doing. But I mostly to embedded stuff.
<dsmith-work>s/to/do/
<dsmith-work>Not much chance of Scheme though.
<amz31>It's been 5 years of sadness then
<amz31>that I am lucky that at least i do the snake and some proprietary stuff
<amz31>that I am lucky that at least i do the snake and _not_ some proprietary stuff
<amz31>I mean i work with free software that makes me happy
<weinholt>nice
<amz31>maybe it's just that I always want more of something, in french we say "the garden of the neighboor is always greener"
<dsmith-work>There are many things worse than Python.
<amz31>yes
<OrangeShark>now I have plenty of time to work on free software projects :)
<daviid>OrangeShark: really? let's talk!
<OrangeShark>sure
<daviid>amz31: i was refering to their social model, the way the employes and consultant are part of the board ... and retributed on benefice ...
<amz31>daviid: big dream
<amz31>OrangeShark: plans?
<amz31>OrangeShark: daviid is trying to find some who will work on postgres sql bindings
<OrangeShark>amz31: I plan on trying to go back to school for a PhD. That will take awhile though
<dsmith-work>amz31: Yeah. I've heard it as "The grass is always greener on the other side." (US English)
<daviid>I don't think that sentence stands for someone looking for a better job though
<dsmith-work>Nope
<daviid>OrangeShark: what will be the subject of your thesis? or at leat the main domain, do you know ? or not yet
<dsmith-work>It's about how other peoples stuff or situation always seems to look better than yours.
<weinholt>that's quite the thesis
<daviid>amz31: I worked with lisp and guile for my entire carer, so is not only a dream, it is dead possible :)
<amz31>dsmith-work: exactly
<daviid>and igalia is very well alive, the social model is prety cool
<amz31>like are you a recruiter for igalia or something?
<OrangeShark>that is where wingo works at, isn't it?
<daviid>OrangeShark: yes
<daviid>amz31: haha, no
<amz31>well, anyway my ventures are too much 'weird' for companies
<amz31>I have to type latex to explain what i do, I am like going back to college
<amz31>or something not sure what the term is in english for master/phd stuff
<daviid>have to go, bbl
<amz31>ciao
<daviid>before I leave, i want to add that thanks to purism, and the librem5 phone, we have a unique opportunity to develop app for mobiles sing guile, but we need bindings to postgres and gnome introspection (and make sure guile compiles on their arquitecture, actually Id like to know if it is already possible, anyone know?)
<dsmith-work>daviid: The guile app will run on the phone?
<amz31>that's apparantly the plan
<amz31>OrangeShark: so, what is the subject of your phd?
<OrangeShark>computer science
<amz31>:]
<amz31>what field in computer science?
<dsmith-work>I wonder if postgres will also be on the phone..
<OrangeShark>I am thinking of researching compilers and programming languages
<amz31>dsmith-work: I read people use sqlite on mobile
<amz31>even foundationdb use sqlite
<dsmith-work>Yes, Seems more appropriate
<amz31>OrangeShark: :D
<amz31>OrangeShark: well, I have a future feature request to do then, please rewrite the garbage collector in scheme ;]
<OrangeShark>well the app might communicate to a server (which should be written in guile) that has to access postgres
<OrangeShark>amz31: hehe
<amz31>yes, but afaik daviid is not willing to use a server
<dsmith-work>The local channel bot uses sqlite
<amz31>this is too https://www.sqlite.org/src/timeline
<amz31>I talk about foundationdb, it's out of the scope of my guile project to create bindings of foundationdb
<amz31>I will continue to work on wiredtiger because the scale of what i build it's good enough
<amz31>I mean scale, I mean for the number of people using my software
***logicmoo is now known as dmiles