IRC channel logs

2018-07-14.log

back to list of logs

<thomassgn>in a guile script, I would like to react to a grep'ed part of several lines of output from a program. Currently I'm using system* and readline to loop over the pipe. Is this an allright way forward? I also find it a bit weird that if I run my procedure twice it continues grep'ing through the output of the previous call, not a new 'system*' invocation... Do I need to flush the pipe in addition to close it?
<thomassgn>(or maybe the new system* output is appended to the pipe?)
<markx>Hello!
<markx>Is there a telnet client for guile?
<brendyn>Don't really understand it but it looks interesting. guile on WebAssembly one day? http://words.steveklabnik.com/webassembly-is-more-than-just-the-web
***sarna_ is now known as sarna
<chrislck>Hi may I ask simple question? Perused manual but still unsure if my task is doable.
<chrislck>I am successfully using (define* (func a b c #:key (d 'd) (e 'e)) ...)
<chrislck>afterwards I can do (func 1 2 3) or (func 2 3 4 #:d 5 #:e 6) to call (func), and specify customized d and e arguments
<chrislck>but I wonder if there is a way to do it one level higher
<chrislck>i.e. after (define* func) as above, I wish to do (define* (func2-with-d-5 a b c) (func a b c #:d 5)), i.e. func2 calls func with d=5
<chrislck>sorry I wish to do something like (define* (func3 a #:rest) (func a 'b 'c #:rest))
<chrislck>i.e. func3 is similar to func, but will set b='b and c='c, but func3's #:rest is also passed on to func #:rest
<chrislck>a better snippet is https://pastebin.com/b5tyVj8y - basically I wish to define (add-to-table) which will expand to (add-multicolumn-acct-table) with some default arguments, but can also pass its keyword arguments through to add-multicolumn-acct-table
<thomassgn>chrislck: I'd try, I'm quite a guile beginner, but this looks like it should work as you've written it...
<thomassgn>(I'm just assuming you have not tried from the wording in the question)
<chrislck>well no it doesn't work
<janneke>bah, getopt-long does not handle (one-per-line (single-char #\\1))
<manumanumanu>brendyn: I would really like to convert wasm to one of guile's intermediate languages.
<manumanumanu>how hard can it be?
<manumanumanu>:D
<brendyn>manumanumanu: Does guile's C parts need to be rewritten in guile to accomodate that?
<manumanumanu>well, no... WASM is pretty simple, but it might be hard to make it run fast
<brendyn>Does that mean having guile in the browser somehow?
<manumanumanu>no, but it means we can have things compiled for wasm running in guile
<janneke>ACTION sent bug report with patch
<daviid>I wonder why we don't have keyword? and keyword->string in core guile?
<manumanumanu>daviid: I have keyword?
<janneke>there is keyword->symbol
<manumanumanu>(define keyword->string (compose symbol->string keyword->symbol))
<daviid>manumanumanu: ah, thought keyword was in srfi-88 'only', and the latter should be in guile, I mean why not, that was the question :)
<daviid>*keyword?
***sarna_ is now known as sarna
<stis_>evening folks!
<manumanumanu>evening stis_
<stis_>I manage to implement python's re module recently. That's good because a lot of python code depends on that specific module
<manumanumanu>alright!
<manumanumanu>what kind of problems did you encounter?
<mwette>where is your python-in-guile homed?
<stis_>manumanumanu: the re module is not translatable to scheme regexp mainly
<manumanumanu>oh :(
<stis_>mwette: https://gitlab.com/python-on-guile/python-on-guile
<stis_>to be able to pickle and unpickle you need to have guile-log installed as well
<stis_>manumanumanu: later I will check for scheme compatability of the regexp and use that in cases where those apply
<mwette>stis_: Thanks.
<mwette>.