IRC channel logs

2018-07-13.log

back to list of logs

<thesage>hi
<thesage>if given proper guidance, on how to contribute to guile, i would try to be an valuable resource and asset
<thesage>can someone explain the basics of guile internal architecture
<thesage>my email is rkchilaka378@gmail.com
<thesage>i want to be a volunteer at gnu
<thesage>is someone online?
<amz31>yes
<thesage>hi amz31
<amz31>thesage: read the source and manual, send a mail to guile-devel mailling list about what you want to help with
<thesage>ok
<amz31>thesage: read the bugtracker, you will find the url in the manual
<thesage>is everything written in the manual updated and correct?
<amz31>thesage: for instance, I have a 'html' module that I would like to include in guile proper but never come around writing tests for it
<thesage>oh
<amz31>thesage: best effort :)
<thesage>thanks amz31
<thesage>i would like to write tests for the html module you have
<thesage>where can i get that html module? :)
<amz31>thesage: https://github.com/a-guile-mind/guile-web/blob/master/src/web/html.scm
<thesage>thanks amz31
<amz31>thesage: send a message on the mailling list saying what you plan to do
<amz31>thesage: not all guile core dev are on IRC
<amz31>I am not a core dev
<thesage>ok amz31
<thesage>but first i will try to write tests for the module you wrote
<thesage>when they are done, we can submit that module together :)
<thesage>or you can add me as a minor contributer
<amz31>thesage: use srfi 64 unit tests module
<amz31>thesage: have a look at this repository to learn how to setup test coverage https://github.com/a-guile-mind/coverage
<amz31>if you plan to code the tests out of the guile git repository
<thesage>ok amz31
<thesage>how do i contact you amz31?
<thesage>do you have whatsapp or telegram?
<thesage>i have whatsapp and telegram
<thesage>my number is +919113512050
<thesage>if you are interesting in guiding me through the project, it would be lot of help.
<amz31>thesage: please use the mailling list it's better for everybody
<amz31>also I don't have whatsapp and telegram
<thesage>ok
<thesage>ok amz31
<thesage>i have signed up for the mailing list
<thesage>i will try to propose that i am writing tests for your module there.
<thesage>thanks for helping me out.
<thesage>i hope you have my number, if you want to contact me using whatsapp or telegram
<thesage>email: rkchilaka378@gmail.com
<thesage>number: +919113512050
<thesage> https://github.com/thesageinpilani
<thesage>is my github page, i am just starting ;)
<amz31>you have one more follower :)
<thesage>ha, ha thanks
<thesage>you also have one more ;)
***sarna_ is now known as sarna
<dsmith-work>Happy Friday, Guilers!!
<OrangeShark>happy Friday!
<amz31>!
<civodul>yay, happy Friday all!
<daviid>yeah, happy Friday!
<manumanumanu>Wahoo! I finally get to use fibers!
<manumanumanu>happy happy friday!
<brendyn>manumanumanu: one of these days I'll get to use them too!
<manumanumanu>stis, my fellow countryman, how's it hanging?
<manumanumanu>what have you been up to?
<manumanumanu>I have been using your syntax-parse to great success
<stis_>manumanumanu: great I think that is a cool lib, but it is a port and I'm just a translator
<stis_>I just went into the fog today and reproduced python regular expression lib
<manumanumanu>stis_: it is pretty damn great though.
<manumanumanu>it is so much simpler to use than syntax-case
<stis_>the go files are huge though, I would really like to trim the sizes of the go files but don't know how
<stis_>for a fun application of syntax parse consider look at my implementation of CL's loop macro
<manumanumanu>stis_: wtf, you impemented the loop macro? that's what I'm using it for :(
<stis_> https://gitlab.com/guile-cl/guile-cl
<manumanumanu>stis_: show me the source :D
<manumanumanu>stis_: what kind of code does it generate? is it efficient?
<manumanumanu>seems like there is a lot of mutation going on
<manumanumanu>(like the regular loop macro)
<stis_>yes it's mutating
<manumanumanu>isn't it possible to implement most of the loop macro as a folding construct? That would remove a bit of the mutation
<stis_>could be but I think that I decided for code simplicity do the mutation. You can explore if there is a better way and get better speed and continuation properties
<stis_>the loop macro is disliked, so I did not want to put too much effort in it. there is iterate that is better and you have foof loop as I think it is named that is prefered amongst guilers I think
<manumanumanu>CLers will never stop complaining about how nothing compares to loop, so I want to try implementing it in a way that adds little overhead so that they can be happy
<manumanumanu>I never really understood what it has over rackets for-loops apart from early exits
<stis_>well it's quite used in the cl community and I suspect that they want to use something they know rather than something that is technically better
<stis_>the loop macro is in the standard
<stis_>also mutation is cheaper and better optimized ontop of e.g. SBCL than guile
<stis_>technically this is because CL does not do re installable continuations I think.
<manumanumanu>hmmm. racket does not support the by clause
<manumanumanu>or something like (loop repeat 5 for x = 0 then y y = 1 then (+ x y) collect y))
<manumanumanu>but that can be added easily.