IRC channel logs

2018-07-12.log

back to list of logs

<chrislck>running n-tuple combinatorial tests on gnucash reports :-o https://lists.gnucash.org/pipermail/gnucash-devel/2018-July/042330.html - output at https://gist.github.com/christopherlam/c04d43398ecac486d662c4e74eb293ca see daily-reports.scm being torture-tested...
<lloda>how do I get emacs to indent #:export like, #:export (a b\\n***align below a not below b***)
<civodul>good question, i don't have a good answer to that
<civodul>it's one of these warts you get used to ;-)
<amz31>o/
<lloda>thx anyway civodul :-)
<siraben>Hi #guile, I wrote a fibonacci function "fib" and I want to see how long it takes for an input n, how do I do something like (map (lambda (x) (<how-long-it-takes> (fib x))) '(30 31 32))?
<siraben>I want to collect data on the time taken for fib to run on an input N
<siraben>I want that map to return a list of timings in seconds, e.g. (1.2 1.3 1.4)
<dsmith-work>Hey Hi Howdy, Guilers
<lloda>siraben: you can use the functions get-internal-run-time get-internal-real-time and the variable internal-time-units-per-second
<lloda> https://www.gnu.org/software/guile/manual/html_node/Time.html
<amz31>heya dsmith
<OrangeShark>Happy day before Friday!
<dsmith-work>Wheee!
<ArneBab>sneek: later tell siraben: here’s an example of timing functions: https://bitbucket.org/ArneBab/wisp/src/7501dc0db3f8cebf49b48634719ab82b4a509a79/examples/benchmark.scm?#benchmark.scm-48
<sneek>Got it.
<ArneBab>sneek: botsnack
<sneek>:)