IRC channel logs

2018-07-08.log

back to list of logs

<amirouche>since I removed the debug print statment from my program that does a dump of hn it's running
<amirouche>for 2 days already
<amirouche>I mean that it did not crash, but I don't what's it is doing
<amirouche>let's wait 1 week and see what happens
<amirouche>^^'
<daviid>manumanumanu: did you know about guile-lib (os process)? I did no look at your code carefuly, neither do I know (os proces) 'in details', but always nice to avoid 'rewriting the wheel' ...
<brettgilio>Hi, all.
<chrislckaway>manumanumanu and taylan - thx for pointers, these look complicated
<daviid>chrislckaway: may be you wna to also have a look at guile-lib (os process)?
<daviid>chrislckaway: here: http://www.nongnu.org/guile-lib/doc/ref/os.process/
***chrislckaway is now known as chrislck
<chrislck>thx daviid i was hoping for something inhouse; i'll check
<chrislck>my use-case is to (system "jenny 2 2 2 3") from http://burtleburtle.net/bob/math/jenny.html to generate unit-test cases and run comprehensive n-tuple tests
<daviid>chrislck: guile-lib is the 'ante quarto' of guile, it is 'almost' in house :)
<daviid>chrislck: I higly recommend you to use the guile-lib test-suite instead
<daviid>which integrates well/esily with the autotool chain, should that metter to you
<daviid> http://www.nongnu.org/guile-lib/doc/ref/unit-test/
<chrislck>ah i'm using srfi-64 successfully
<chrislck>here's my sweat and tears: https://github.com/Gnucash/gnucash/blob/maint/gnucash/report/standard-reports/test/test-transaction.scm
<daviid>chrislck: ah, this (system "jenny 2 2 2 3") scared me
<daviid>:)
<chrislck>nah jenny is public-domain and completely harmless; it creates useful short combinatorial permutations of options
<daviid>cool
<chrislck>Ok I think taylan's method with popen and textual-ports is the simplest
<daviid>chrislck: i think guile-lib (run "cmd" "parameters") is easier, and maintained ... but of course as you wish
<chrislck>the issue is I can install guile-lib locally but don't wish to force a scheme dependency onto travis-CI or other users. thx for pointing me towards this useful library
<chrislck>i guess it'd be (run-with-pipe "r" "jenny" "2 3 4")
<daviid>chrislck: i respect, though I don't understand why you can't have (force isn't the right word in this case imo) a dependency toward guile-lib for gnucash
<daviid>or any other guile lib(s) for that matter
<chrislck>there hasn't been a gnucash scheme maintainer for years... they're aiming to reduce nloc in scheme
<chrislck>it's too difficult for most hackers
<chrislck>the scheme code was written 15-20 years ago before srfi-1, slib and r6rs
<chrislck>imagine ...
<daviid>chrislck: sure, but you are now working it, and you should be able do the right thing, which is to use guile and well developed supported guile-libs, imo
<daviid>*working on it
<chrislck>:-o will see !
<daviid>chrislck: so now you can use all these, and guile-lib, it will be better for all, not just for you, imo, anyone asking you to rewrite a wel written, well supported code 'is wrong', not helping you to clean the code and making it far easer to maintain, precisely what those complains about i the first place, ... to me, this is none sense
<daviid>but hey, do as you wish, again, and thanks for working on this as well by the way!
<chrislck>np
<manumanumanu>daviid: (or process) seems a bit lower level, but generally does the same. It is just convenience things built on open-process and port->list or port-fold.
<manumanumanu>(os process)*
<manumanumanu>I really think guile should deprecate most of (ice-9 popen) and just make open-process available as an import.
<manumanumanu>and provide some nice port operations instead, like port-fold or port->list
<daviid>manumanumanu: it seems to me that (os process) from guile-lib does what your paste does, and more ... if that is correct, theh I'd rather encourage users to use and rely upon guile-lib, which is (very) well written, documented, has a complete test-suite ... if that is not correct, we should enhance guile-lib ...
<manumanumanu>daviid: you are correct
<manumanumanu>I didn't say anyone shoud use my library, that was ArneBab's idea :D I just pasted it to show how I interface with open-process
<manumanumanu>which I think should be exposed by guile by default, since it covers most uses for executing external programs
<Thra11>Does the guile repl have any sort of config file so I can for example load readline support automatically every time I launch the repl?
<mwette>you can put something in your ~/.guile file [e.g., (use-modules (ice-9 readline)) (acivate-readline)]
<sneek>mwette, you have 3 messages.
<sneek>mwette, ArneBab says: for me wisp is a usecase for additional languages in Guile. It allows me to have the features of Scheme with better readability for newcomers. Essentially a thin shell over Scheme, were the basic syntax of Scheme cannot accomodate to something.
<sneek>mwette, ArneBab says: another use case for additional languages in Guile is to be able to reuse domain specific work people did in other languages. For example being able to parse org-mode documents with real org-mode and get them as data into Guile programs.
<sneek>mwette, ArneBab says: I’m using org-mode as example, because it is essentially specified by its source — and so complex that you can’t just go and re-implement it. At the same time it is already being used as data-interchange format in Emacs.
<Thra11>mwette: Thanks!