IRC channel logs

2018-07-01.log

back to list of logs

<brettgilio>Hey all, I started Guile and Scheme about three weeks ago. I am wanting to rewrite an application of mine which is in C++/Qt5 to Guile, but want to keep the application front-end in Qt5. I know that Guile is rather portable and can be embedded in C/C++, and I am planning on keeping the logic quite separated, like an MVC. Do you have any advice for this process? Thanks!
<brettgilio>Also, for some reason the Guile mailing list isn't letting me register.
<daviid>brettgilio: excellent news and welcome! we don't have (at least that I'm aware of) qt5 bindings. As usual, the best is to keep proper separation between the app core functionality and the UI, no mistery here. now, we generally recommend the opposite: write the app in scheme, and import what ever lib you need either using an existing binding, or write your own when not available ... this said Iunderstand t probably represent too much
<daviid>work in your case (qt5 bindings ...)
<daviid>wrt mailing list, I don't knw, did you try to subscribe using the ML web page dedicated to this?
<brettgilio>daviid: Thanks for your help, and I pretty much figured it will simply have to be a clean separation between the logic and the gui. I simply find the scheme implementation and the hackability of it to be such a beautiful feature, especially given that I am not by profession a programmer nor even closely related.
<brettgilio>daviid: As far as the mailing list goes, I used the gnu mailing list page at https://lists.gnu.org/mailman/listinfo/guile-user
<brettgilio>Otherwise, I am happy to be here. I moved to having emacs as my window manager about two weeks ago, and the integration of irc is such a beautiful thing.
<daviid>brettgilio: that is the right ML page yes, so you subscribe, then you should receive a subscription confirmation email, that you need to respond to to effectively activate your membership, did you do that?
<daviid>brettgilio: most of us use eamcs, are you aware of geiser? that is our 'ide' so to speak
<brettgilio>daviid: I have attempted to register a few times, but it is not relaying to my email address. I will try a different address and see if it works, but I have a preferred address I'd like to use.
<brettgilio>daviid: Yes, Geiser is integrated directly into my emacs workflow, it is a terrific tool and runs perfectly with so many scheme implementations.
<daviid>i think it ight be your email provider or something
<brettgilio>daviid: You're correct, it is.
<brettgilio>daviid: What do non-emacs users use? DrRacket?
<daviid>brettgilio: I don't know :)
<daviid>brettgilio: what is your app about, any link (just curious here)
<daviid>is it free s/w?
<brettgilio>daviid: Always free s/w, gpl.. It's mostly a self-starter project that I've been using to learn the reddit api and apply my Qt5 and C++ skills. But when I got close to a working prototype was when I discovered scheme and the embeddability of guile in C/C++. It's not in a public repo atm, but I can make it so in a few days after I look into this Guile and C++ combination scenario.
<brettgilio>daviid: I run parabola gnu/linux-libre. /Always/ free software.
<daviid>brettgilio: ok, I was just curius, good luck! kepp us informed ...
<daviid>*curious
<atw>ArneBab: I had another beginner question: where does match-lambda come from? I found out it comes from ice-9. What functionality is provided by ice-9 versus SRFIs versus SLIB versus something else?
<brettgilio>atw: What resource did you use to figure out ice-9?
<daviid`>brettgilio: the manual '7 Guile Modules'
<daviid`>atw: (ice-9 match)
<atw>That's a good manual section :) I used Geiser
<brettgilio>atw: you mean the geiser helm info section?
<brettgilio>atw: I've been reading SICP and The Scheme Programming Language and using the helm info section off and on
<atw>brettgilio: I started Geiser, eval'ed the buffer, and put the point on match-lambda
<brettgilio>atw: Did it take you to the buffer with 7.7 Pattern Matching?
<atw>brettgilio: when I just put the point on match-lambda, a message in the echo area indicates that it is from (ice-9 match), which gives me enough information to search further :) I see that Geiser has C-c C-d TAB for manual lookup. That seems to work for e.g. define but not match-lambda. i suspect that's a Geiser misconfiguration on my part
<daviid`>atw: no, it's because match-lambda comes from an include, and geiser can't know that
<daviid`>atw: if you visit (ice-9 match) you'll understand ...
<brettgilio>atw: M-x helm-info-guile (ice-9 match)
<brettgilio>That is how I found it.
<brettgilio>Section 7.7 if youre on the GNU page.
<atw>thanks! reading now...
<amz3>I will submit a proposal for my guile database to scheme2018
<amz3>maybe
<amz3>also I will move to the newest microkanren
<amz3>what's up ijp-znc ?
<wingo>moo
<mwette>programming in COW now? https://esolangs.org/wiki/COW
<amz3>^^
<amz3>that's the next big thing
<civodul>guile-hall looks like a step in the right direction
<weinholt>civodul, https://akkuscm.org/ here's my step in some similar direction (minus the guix parts)
<civodul>hey weinholt
<weinholt>hello there
<civodul>weinholt: to me Akku is a different beast: more at the package manager level, whereas Hall is more at the level of 'make'
<civodul>well, in between maybe, but definitely lower level
<weinholt>okay
<civodul>Akku does look very nice though
<civodul>prolly nicer than previous attempts in this space (Snow, guildhall, etc.) :-)
<weinholt>:)
<weinholt>the latest release gained support for running from guile, although it doesn't recognize guile's modules yet
<weinholt>unlike guildhall/dorodango it parses the code to understand where everything should be installed, makes things a lot easier for the user
<ArneBab>sneek later tell atw: ice-9 are core tools provided by Guile "as a crystal seed" for programs.
<sneek>Got it.
<ArneBab>sneek: later tell atw: SRFIs cross-implementation features. They are collected at https://srfi.schemers.org/ and are likely to work on multiple scheme implementations, not only in Guile.
<sneek>Okay.
<ArneBab>sneek: botsnack
<sneek>:)