IRC channel logs

2018-06-19.log

back to list of logs

<ArneBab>I built a simple file upload server with multifile support and no design at all: https://bitbucket.org/ArneBab/wisp/src/7501dc0db3f8cebf49b48634719ab82b4a509a79/examples/upload-server.w
<ArneBab>I built a simple upload server with multifile support and no design at all: https://bitbucket.org/ArneBab/wisp/src/7501dc0db3f8cebf49b48634719ab82b4a509a79/examples/upload-server.w
<ArneBab>I built a simple upload server with multifile support and no design at all: https://bitbucket.org/ArneBab/wisp/src/7501dc0db3f8cebf49b48634719ab82b4a509a79/examples/upload-server.w
<hugo>ArneBab: Cool to see someone actually use Wisp!
<hugo>Code looks rather good also
<hugo>But I would recommend using an XML library (such as sxml-simple) since sexp's and xml matches so nicely to each other
***lavaflow_ is now known as lavaflow
<civodul>scm_to_stringn goes through iconv to convert latin1 strings to utf8 :-/
<civodul>that's the most common case (latin1/ascii file names and utf8 locale)
<wingo>probably it should bottom out to scm_to_utf8_stringn if in a utf-8 locale
<wingo>probably just needs a change to scm_to_locale_string i would guess
<wingo>civodul: i think scm_to_port_stringn does the right thing
<wingo>all other callers of scm_to_stringn look good to me fwiw
<civodul>indeed, i didn't know that one
<wingo>civodul: probably most callers of scm_to_locale_stringn should use scm_to_port_stringn anyway
<civodul>yes but often there's no 'port'
<wingo>maybe you're right :)
<civodul>here's what i see: https://paste.debian.net/1029878/
<wingo>yuck :)
<civodul>it's not easy actually because you can never know whether a narrow string is also valid UTF-8
<civodul>well, no easily
<civodul>*not
<wingo>well, we have dedicated latin1->utf8 converters
<civodul>yes so we should special-case this in scm_to_stringn i guess
<wingo>yep
***guile-guest5 is now known as nieper
<nieper>What is the current state of Guile's R7RS support? Is full conformance actively worked on?
<rain1>nieper: no one is workingon it
<nieper>rain1: Do you know whether the missing parts (to R7RS compatibility) are documented somewhere?
<rain1>i don't think there is any documentation about it
<lloda>nieper: search guile-devel. mark_weaver has been working on that on and off
<civodul>wingo: this should be an improvement already: https://paste.debian.net/1029892/
<nieper>lloda: Thanks for pointing out the guile-devel mailing list. There are a number of helpful R7RS references.
<wingo>civodul: indeed, though i think we should avoid duplicating that code and instead call through scm_to_utf8_stringn; given that latin_to_u8 has only one caller it will get nicely inlined
<wingo>but that is just a nit! :)
<civodul>wingo: scm_to_utf8_stringn does a little bit more than we need, but i guess that's fine?
<wingo>well it handles the wide case too
<wingo>which is probably fine :)
<civodul>it's true that we can make it 2 lines: https://paste.debian.net/1029895/
<civodul>see how rusty i am? :-)
<galex-713>wow
<galex-713>I juste compiled chickadee for the first time
<galex-713>always failed with sly
<galex-713>it features sound, SDF for fonts, and opengl shaders (yet I don’t know what is a shader exactely)
<galex-713>(but I know curv and libfive use them to display SDF)
<galex-713>“buffers”, “hook”, recalls me so much of emacs…
<galex-713>if only there were a standard accross scheme and normal lisp (like el and cl) about these, so interface would be more stable
<civodul>galex-713: Emacs Lisp and Common Lisp are very different though :-)
<galex-713>civodul: not as much as them and scheme
<galex-713>and they have some common points
<galex-713>but their incompatbilities are narrowing
<galex-713>right?
<galex-713>I think I recall cl has grown over time
<civodul>so, i'm at loss with these crashes
<civodul>like https://paste.debian.net/1029911/ suggests a missing SYNC_SP or something along these lines
<civodul>wingo: do you have tricks to display VM frames in gdb?
<civodul>it seems that the support we have no longer works
<civodul>can 'struct-set!' be considered atomic?
<rekado>davexunit: I see you’ve made some commits to chickadee in the past months; will there be a new release soon?
<rekado>I want to write a little game as a gift for a friend, so I’m looking at my options.
<OrangeShark>hello everyone
<galex-713>I wonder if there’s a mail header for saying if a message is really important or not
<galex-713>ah yeah, Importance
***lavaflow_ is now known as lavaflow