IRC channel logs

2018-06-17.log

back to list of logs

<wingo>i think i can remove support for ia64 / itanium in guile
<wingo>red hat has stopped supporting it entirely i think
<wingo>also fedora
<wingo>debian still has a port, though it seems a bit tenuous
<wingo>hum, there was an ia64 patch last year :P
<wingo>maybe i can just remove all the ifdefs and rely on bdw-gc to do things right
<chris_>I never thought there was a difference between '(1 2) and (list 1 2)......... the latter creates *mutable* list... argh
<wingo>yeah indeed
<chris_>I never thought there was a difference between '(1 2) and (list 1 2)......... the latter creates *mutable* list... argh
<chris_>,leave
***Raimondii is now known as Raimondi
<chris_>Would be grateful for a review of https://gist.github.com/christopherlam/eccab30d3d6a5ebfab3899d6afbc5d5e
<chris_>1) it seems to work when run, however is not acceptable to REPL
<chris_>2) when run, it seems to mishandle (list-set-safe! #f 1 9) --> expected output = (list #f 9), obtained output = #f
<mwette> /quit
<janneke>chris_: from the manual: ‘append’ doesn’t modify the given lists, but the return may share
<janneke> structure with the final OBJ. ‘append!’ is permitted, but not
<janneke> required, to modify the given lists to form its return.
<chris_>janneke: thx i found that i needed to (set! l newlist) or something
<chris_>so much fun... to me scheme is assembly language, not bound by pointer arithmetic nor malloc troubles
<chris_>msg for wingo - sorry won't be here to reply it's late here - just wondering about your old code in daily-reports.scm - https://github.com/Gnucash/gnucash/blob/maint/gnucash/report/standard-reports/daily-reports.scm#L187
<chris_>I guess the (gnc:make-stats-collector) was used to process numbers only once, and interrogate later on for max/min/average...
<chris_>Today with modern guile are these accumulators still needed?
<chris_>I'll be aiming to eradicate use of similar collectors because they're confusing and add values as required
<chris_>(apply + (map split->value splitlist)) so much better than (for-each (lambda (v) (collector 'add (split->value v)) splitlist)
<chris_>anyway i'm a bit confusing
***chris_ is now known as chris-afk
<wingo>chris-afk: that was literally the first scheme code i ever wrote; we should probably assume it doesn't make sense :)
<wingo>that said, i think that was just copypasta. if accumulators aren't needed for someother reason then sure, you can take the functional tack
<wingo>jesus
<wingo>a real thing that's in libguile:
<wingo>SCM_DEFINE (scm_noop, "noop", 0, 0, 1,
<wingo>#define FUNC_NAME s_scm_noop
<wingo>{
<wingo> SCM_VALIDATE_REST_ARGUMENT (args);
<wingo> return (SCM_NULL_OR_NIL_P (args) ? SCM_BOOL_F : SCM_CAR (args));
<wingo>}
<wingo>#undef FUNC_NAME
<wingo>wat
<janneke>haha