IRC channel logs

2018-06-07.log

back to list of logs

***Raimondii is now known as Raimondi
<dadinn>hi all
<dadinn>I would like to ask question regarding pipes, how do I convert the following shell command into guile code using I/O pipes: pv -Ss $(blockdev --getsize64 $DEV) < /dev/zero > $DEV
<dadinn>i have a let* with (in (open-input-pipe (string-append "pv -Ss " dev-size))) ... and (out (open-output-file dev #:binary))
<dadinn>i would somehow need to pipe `in` to the `out` i suppose, not sure what command to use :/
<lloda>dadinn: you can try looking here if you find what you need
<lloda> http://git.savannah.gnu.org/gitweb/?p=guile.git;a=blob;f=test-suite/tests/popen.test;h=2c08774846a1d8c088f68b7ed333eefeaca27856;hb=HEAD
<lloda>paste.lisp.org is gone :-( :-(
<lloda>dadinn: I use this myself, with example
<lloda> http://paste.debian.net/1028323/
<lloda>however it waits for the input to end, if it doesn't it will hang
<lloda>this question comes up often in the mailing list, you can try to search there
<lloda>I think we should have a few examples in the manual
<dsmith-work>{appropriate time} Greetings, Guilers
<OrangeShark>hello everyone
<OrangeShark>happy day before friday!
<dsmith-work>heh
<dadinn>lloda: exactly, in the pipes page in the manual is definitely lacking in using pipes. Unfortunately it means I am stuck with bash for scripting, because Guile manual is inadaquate for scripting everyday tasks.
<daviid>heelo guilers!