IRC channel logs

2018-06-05.log

back to list of logs

<lloda>I miss being able to pass a value to a kwarg or optional that means 'use the default'. I usually do (define* (f #:key a) (let ((a (or a a-default))) ...)) which looks kind of ugly :-/
<wingo>you don't like (define (f #:key (a default)) ...) ?
<wingo>i guess you can't pass a value there to say 'use the default'
<lloda>yes, that's it
<lloda>most often when it's a nested call
<rain1>that seems like a limited approach because of #f
<lloda>well yes, it wasn't a proposal. Please read (let ((a (match a (I-want-default-object a-default) (a a)))) ...) or so
<rain1>hmm i see, whats the question/problem ?
<lloda>have (define* (f0 #:key (a a-default)) ...) somewhere
<lloda>then (define* (f1 #:key (a a-default)) (f0 #:a a)) somewhere else
<lloda>I guess having to put a-default twice?
<lloda>nvm really
<dsmith-work>{appropriate time} Greetings, Guilers
***ota_ is now known as ota