IRC channel logs

2018-06-03.log

back to list of logs

<axd-v>hey, which module or library do I have to load in gulie in order to get access to the functions `first, butfirst, bf, etc` in guile?
<axd-v>I'm trying to follow berkeley's SICP lectures from 2010 but they're using STK scheme so idk if those functions are specific to that.
<axd-v>but it seems like those should be packaged in the standard library or something
<mwette>axd-v: try (srfi srfi-1); I know that has `first'
<axd-v>mwette: yeah that has first, but not other ones. How can I find out where to look to find these "standard library" functions?
<axd-v>like, I wouldn't have known to import srfi-1 to get the `first` function. Where do I find this info?
<daviid>axd-v: by looking in the procedure index of the manual, you can check if it exists, and you also can see if it is in guile core or if you ned to import a specific module ... thee indexes, procedures, variables, concept ... are your friends
<daviid>axd-v: also check this https://github.com/zv/SICP-guile
<axd-v>daviid: are you referring to the guile manual?
<daviid>axd-v: yes
<axd-v>daviid: well the lectures also use functions like butfirst, butlast to split apart different collections. In the procedure index on the guile manual those functions are absent. Are they just part of STK scheme libraries or what's up about that?
<daviid>yes, try to see if the link I just pasted helps ... it says it has all the exercises solved ...
<axd-v>daviid: thanks I'll check it out. Just trying to understand the standard library organization for now. Those indexes are pretty nice.
<daviid>axd-v: check this as well https://mitpress.mit.edu/sites/default/files/sicp/code/index.html
<daviid>you may build your own guile modules using all this ... then try solve the exercise on your own ...
<axd-v>daviid: thank you very much, gonna try to incorporate it all together. A lot of supplemental material. I'm trying to get emacs to work with an textinfo version of the book.
<daviid>welcome
<daviid>good luck
***Raimondii is now known as Raimondi
***gour_ is now known as gour