IRC channel logs

2018-05-31.log

back to list of logs

***Raimondii is now known as Raimondi
***logicmoo is now known as dmiles
<NingaLeaf>how do you run a '.go' file?
<daviid>NingaLeaf: we don't "run go files", we write script(s) that import and use modules ... look for 4.3 Guile Scripting in the manual ...
<NingaLeaf>oh i thought i read that .go files was a complied version of a script and could be executed on the guile vm
<NingaLeaf>similar to java bytecode execution
<NingaLeaf>what is the .go file used for if you can't run it?
<NingaLeaf>is it used as a type of intermediate representation for the guile vm?
<NingaLeaf>I inherited a guile project and now i'm working my way thought the language and ecosystem
<daviid>NingaLeaf: what project?
<NingaLeaf>oh a work project
<NingaLeaf>the project is like a microservice implementing a directed acyclic graph for a ML application and the original author chose guile
<rekado>NingaLeaf: the .go file contains byte code. If it exists it is preferred over the readable Scheme code, which would otherwise have to be interpreted.
<NingaLeaf>rekado: thanks! this what i assumed, but wasn't sure.
<dsmith-work>Greetings, Guilers
<daviid>NingaLeaf: to complete rekado's explanation, if the go file does not exists, unless you would have set GUILE_AUTO_COMPILE to 0 (zero), guile will create one ... but we don't "run these go files', we import their corresponding module (see use-modules in the manual) and use their exported procedures, syntax, methods ..
<daviid>NingaLeaf: I don't know ML, and so I don't know how one does call guile from ML, get access to the results ... is the existing code you 'inherited' pure scheme code or C code using libguile?