IRC channel logs

2018-05-11.log

back to list of logs

<gour>morning
<gour>i'm trying to make some custom gnucash reports working in 3.0. i've been able to adjust my config-user.scm by using add-to-load-path and now i'm not getting " ERROR: no code for module (gnucash gnctimeperiod-utilities)" error in console any longer, but now the problem is that "gnucash --debug --log gnc.scm=debug" does not produce any error, while report is still not available, so wonder how to troubleshoot it further?
<amz3`>o/
***Raimondii is now known as Raimondi
<str1ngs>o/
<str1ngs>gour: did you get the resolved?
<str1ngs>that*
<gour>str1ngs: nope. i was even considering to downgrade to 2.6.x, but it's time consuming since fc28 does provide only 3.0 atm, so i'm forced to fix reports
<gour>(somehow)
<str1ngs>fc28 as in fedora 28?
<gour>yep
<str1ngs>normally I fun fedora but I switched to unbuntu for some work related stuff.
<str1ngs>I should upgrade 27 to 28
<str1ngs>does your reports work for 2.6?
<gour>fedora is, for me, the best distro i've ever encountered and i'm on linux since '99
<gour>yes, those reports do work with 2.6
<str1ngs>run guile then do (use-modules (gnucash gnctimeperiod-utilities))
<gour>but, gnucash does change things a bit...
<gour>ERROR: no code for module (gnucash gnctimeperiod-utilities)
<str1ngs>I started with linux around redhat colgate
<str1ngs>how about (use-modules (gnucash))
<gour>same. othwerwise, my report is current-vs-average and requires gnctimeperiod-utilities
<gour>ERROR: no code for module (gnucash)
<str1ngs>%load-path has the modules for gnucash?
<gour>i put: (add-to-load-path "~/.local/share/gnucash/gnctimeperiod-utilities.scm") in my ~/.config/gnucash/config-user.scm
<str1ngs>ahh
<gour>so, gnucash does load the report, but does not install and it and debug does not produce any error now
<str1ngs>should be (add-to-load-path "/full/home/path/.local/share")
<gour>ahh, let me try it
<str1ngs>or (add-to-load-path (string-append (getenv "HOME") "/.local/share"))
<str1ngs>guile does not expand ~
<str1ngs>and your adding the file path no the directory path
<gour>i changed into 1st option: (add-to-load-path "/home/gour/.local/share")
<gour>but still don't get anything from gnucash debug's output, shall i try again by invoking guile?
<str1ngs>and (use-modules (gnucash gnctimeperiod-utilities) in guile
<str1ngs>err dont forget closing )
<gour>ERROR: no code for module (gnucash gnctimeperiod-utilities)
<str1ngs>find ~/.local/share/gnucash
<str1ngs>don't paste output
<str1ngs>how many files are they just the one?
<gour>no, many files, few folders
<gour> https://pastebin.com/pzcsWpwL
<str1ngs>k one sec let me build gnucash 3.0 right?
<gour>str1ngs: thanks a lot!
<gour>ACTION would like to learn some scheme/guile in order to be able to customize gC reports
<str1ngs>what pkg-config is missing with this error CMake Error at /usr/share/cmake-3.10/Modules/FindPkgConfig.cmake:415 (message):
<str1ngs> A required package was not found
<str1ngs>nvm libxsssslt
<str1ngs>sorry keyboard lag
<str1ngs>wow I just get libdb-sqlite3 provided a libdi backend haha
<str1ngs>guessed*
<gour>you can --disable dbi
<str1ngs>this is using cmake for some reason. which I though was odd
<str1ngs>are you using guile-2.2.3?
<gour>no, 2.0.14
<str1ngs>oh on fedora. dont use that
<str1ngs>use 2.23
<str1ngs>err 2.2.3 . what does 28 ship with ?
<str1ngs>guile 2.0.14 is just there in /bin for some shebangs
<gour>it has 2.2, but deps for gnucash is 2.0...let me check the exact version
<str1ngs>leave it for now
<gour>ok, otherwise there is 2.2.2
<str1ngs>2.2.2 is not bad
<str1ngs>gour: I dont have gnctimeperiod-utilitie
<gour>str1ngs: that's part of custom report...let me paste it
<gour>main report:https://pastebin.com/p8QWy3LB
<str1ngs>where is gnucashed installed rpm?
<gour>utilities: https://pastebin.com/LC93bZjc
<str1ngs>err gnucash
<str1ngs>also is .gcm intentional or is that guile 2.0 related
<gour>libs are under /usr/lib64/gnucash
<str1ngs>I'm trying to understand this paste that has .gcm exntention is that byte compiled?
<gour>where is .gcm?
<str1ngs> https://pastebin.com/pzcsWpwL
<gour>ahhm those are ust book-related settings, you can ignore them related to report
<gour>*just
<str1ngs>ahh this makes more sense now.. one sec
<gour>will have to go to lunch soon, but bbs
<str1ngs>gour: before you go try this
<gour>?
<str1ngs>in guile (load "/home/gour/.local/share/gnucash/gnctimeperiod-utilities.scm")
<str1ngs>it might complain no code gnucash gettext
<gour>right
<str1ngs>this just looks like an module path issue so far
<gour>pk
<gour>ok
<gour>bbs
<str1ngs>gour: add $PREFIX/share/gnucash/scm to %load-path move gnctimeperiod-utilities.scm to $PREFIX/share/gnucash/scm/gnucash
<str1ngs>then (use-modules (gnucash gnctimeperiod-utilities)) should work
<str1ngs>$PREFIX is not a real variable
<str1ngs>gour: you don't have to move gnctimeperiod-utilities.scm but it makes trouble shooting easier. alternatively you need to add gnctimeperiod-utilities.scm parent directory to %load-path as well
<gour>pwd
<str1ngs>pwd: command not found
<gour>:-)
<gour>str1ngs: i've added: (add-to-load-path "/usr/share/gnucash/scm") and put scm file into: /usr/share/gnucash/scm/gnucash, but still get the same error
<str1ngs>is gnucash installed into $HOME/local ?
<str1ngs>err .local
<str1ngs>ironically I use $HOME/local not .local
<gour>no gnucacsh is installed under /usr
<str1ngs>check /usr/share/gnucash/scm
<str1ngs>if it exists and is populated. add that to %load-path
<gour>ok
<gour>i mean, that's the folder i've added to the load-path
<str1ngs>oh wait I read that wrong. that looks good
<str1ngs>one sec
<str1ngs>(use-modules (gnucash gnctimeperiod-utilities)) gives no code?
<gour>no, it gives: ERROR: no code for module (gnucash gnctimeperiod-utilities)
<str1ngs>yes that's the error I meant
<str1ngs>output of %load-path
<gour>$1 = ("/usr/share/guile/2.0" "/usr/share/guile/site/2.0" "/usr/share/guile/site" "/usr/share/guile")
<gour>ahh, i was adding to load-path within gnucash and not guile itself :-(
<str1ngs>yes. alternatively you can add it in ~/.guile IIRC
<gour>some progress: https://pastebin.com/yvWsZd2E
<str1ngs>ok that's another issue
<gour>now i put it into ~/.guile to make it more convenient
<str1ngs>seems the module paths are right now
<str1ngs>so that a dynamic linker thing. it might have trouble find so files
<str1ngs>dynamic-link is like C's dlopen
<gour>str1ngs: btw, i watched some video where wingo mentioned that 3.0 is supposed to have native code-generation. is there any rough estimate when it might happen?
<str1ngs>guile 3.0?
<gour>yes
<str1ngs>ah I think you mean compiling scm to elf instead of bytcode?
<gour>correct
<wingo>this year
<str1ngs>speak of the devil :P
<wingo>:)
<str1ngs>I think that what we are talking about compiling to elf ?
<gour>i was considering to fiddle with the racket, but probably due to lack of time will focus just on guile since i have real need for it for gnucash...
<str1ngs>personally I only every use guile
<str1ngs>and then I get confused when I need to use elisp again haha
<str1ngs>gour: I'm stilling checking why dynamic-link can not find so files
<gour>str1ngs: i'm told by some gnucash hacker that: " well you are trying to load gncitmeperiod-utilities into a blank guile environment. this module relies on a lot of gnucash modules which rely on C and SWIG and etc. ergo you will never be able to load a gnucash guile module directly into guile."
<str1ngs>I don't think that's how repl works :P
<str1ngs>but gnucash may have C bits
<str1ngs>I suspect that is what he means
<str1ngs>gour: can you make sure gnucash has the right %load-path and try then
<str1ngs>either way this problem is dynamic-link which is run time loading so not related to gnucash C bit
<str1ngs>gour: either way I think it's resolved once you get gnucash's %load-path fix. atleast this issue
<gour>str1ngs: progress - https://pastebin.com/k1v50U71
<gour>str1ngs: btw, is it possible to hack guile using vim?
<str1ngs>yes, but not worth it
<str1ngs>geiser with emacs is amazing
<str1ngs>emacs with evil and geiser is a good setup
<chrislck>emacs+magit is da bomb
<chrislck>can anyone with guile-2.2 help me - is the /usr/bin/guild script still (c) 2014 or is there a newer one?
<str1ngs>gour: how do I use timeperiod module from gnucash
<gour>thanks...now have to do something else, will resume later
<str1ngs>gour: ya I think we are past your orginal issue now
<str1ngs>the rest is gnucash related
<gour>str1ngs: i'm told that " you now need to modify gnctimepair stuff to gnctime64" - see e.g. https://github.com/Gnucash/gnucash/pull/256
<gour>ACTION nods
<str1ngs>gour: I'm currently hacking a web browser in scheme and C
<str1ngs>I'm calling it nomad!
<gour>it sounds similar to monad :D
<chrislck>thank you gour for putting my pull request - it incorporates an update onto daily-reports.scm which was created be the one and only wingo :)
<wingo>hah! that was the first scheme i ever wrote :)
<gour>chrislck: what about your fix for ytd-budget reports? is it going to be applied?
<chrislck>gour: it's still available and fixed at https://github.com/christopherlam/gnucash/commits/master-ytd - up to the devs when they can be ready to accept additions rather than fixes
<gour>chrislck: ok, i do mind as long as it does its job...but in order to prepare budget, i need current-vs-average as well
<chrislck>gour perhaps try compare quality of code between current-vs-average.scm and https://raw.githubusercontent.com/christopherlam/gnucash/scheme-progress/gnucash/report/standard-reports/transaction.scm -- the former is so much hack
<chrislck>wingo not sure if you were involved at the same time as rgmerk but I met him in Melbourne in January :-P
<chrislck>just wanted to wave o/
<str1ngs>gour: actually there is not relation with monad
<wingo>o/
<str1ngs>gour: I wanted something that explored on safari and killed foxs. I came up with a nomad haha
<str1ngs>gour: screenshot https://imgur.com/hhKGfb1
<amz3`>look familiar
<dsmith-work>Happy Friday, Guilers!!
<amz3`>!
<mwette>howdy!
<OrangeShark>happy friday
<mwette>Any of you use git on git.sv.gnu.org? I'm having problems connecting today.
<mwette>this: `ssh: connect to host git.gv.gnu.org port 22: Connection timed out'
<janneke>Hapyy Friday
<janneke>mwette: just a silly question: what do the `d' and `i' stand for in i-sel, d-sel?
<janneke>after many months of working on Mes' scheme implementation, i'm again working on the MesCC C compiler
<mwette>IIRC i-sel is indirect selection "a->b"; and d-del is direct selection "a.b"
<janneke>mwette: ah, thanks
<mwette>git on git.sv.gnu.org is working now; it was overloaded this morning
<mwette>(or several hours ago)
***gour_ is now known as gour
<rain1>hello wingo are you there?