IRC channel logs

2018-05-02.log

back to list of logs

<reepca>Hm, I'm sure I've asked this before, but forgot the answer... but I've tried using (debug-set! width 100) to get a better look at a long string argument, but it's not appearing any wider. None of the lines ever gets longer than 72 characters. Could geiser be interfering there?
***fibratio` is now known as fibration
<roelj>When using #:use-module, can I set a prefix per imported symbol?
<civodul>hey!
<civodul>you can do: #:use-module ((ice-9 q) #:prefix foo:)
<civodul>is that what you meant?
<civodul>if you need more flexibility, you can use #:renamer instead of #:prefix
<roelj>Hm, so #:prefix sets a prefix for all imported symbols. How does #:renamer work?
<roelj>It takes a function that can conditionally rename functions?
<roelj>(I found that in Guix's (test-packages) module)
<lloda>roelj: you can also repeat #:use-module with the same module and give a different #:prefix for different #:select lists
<roelj>Right. Thanks for the options!
<roelj>I like #:renamer.
<rain1>how do I define functions for use with macros?
<rain1>in racket its got 'define-for-syntax' is there an equivalent?
<rain1> https://www.gnu.org/software/guile/manual/html_node/Eval-When.html#Eval-When maybe this
<rain1>if i use eval when it seems that the next form after it gives a syntax error
<amz3>use-modules is so much easier to work with
<amz3>like: (use-modules ((guix packages licenses) #:prefix license))
<amz3>otherwise, did any work with serverless architectures? so called aws lambda
<amz3>they are other implementation but it's the most popular
<amz3>I am wondering if it's possible to represent a sexp in NEON
<amz3>what i mean is save scheme code in the database on a per atom basis
<amz3>actually, that's what it does, but it doesn't execute the code, it must interpret it
<amz3>it's optimized for discovering data by orgnizing in (graph namespace key value tx) where tx builds a direct acyclic graph since the beginning
<amz3>we could further optimize the querying by adding the constraint atom are uint64 or similar fixed size numbers
<amz3>damn, I wrote that code at the very beginning of guile-wiredtiger
<amz3>I will need to dig into archeology
<amz3>to find it :/
<amz3>linas: tell me about about the database you need
<amz3>sneek: later tell linas what database do you need?
<sneek>Will do.
<amz3>my TODO.org-mode http://termbin.com/48u5
<amz3>ark, I got an idea but i am too lazy to write it down right now #LiveCoding