IRC channel logs

2018-03-28.log

back to list of logs

<spk121>ok
***dmiles[m] is now known as dmiles_m
***turlando_ is now known as turlando
<lloda>spk121: (rnrs) has exact & inexact which are better names imo
<manumanumanu>ArneBab: I'm updating the transducers a bit now. I managed to get take-while working
<manumanumanu>and drop while
<manumanumanu>but those are probably slow as darn hey ho, since they are stateful
<manumanumanu>(ie: they use set!
<manumanumanu>)
<manumanumanu>uploading them soon
<manumanumanu>I'm too stupid to make partition work though. I don't want to look at the source of clojure, but if I don't manage to get that transducer to work, I might as well.
<manumanumanu>clojure is EPL, so no... No source look.
<chrislck>I never thought that set! in code makes things slow
<manumanumanu>chrislck: it does. using recursion makes the compiler be able to infer things about your code. set! makes that harder
<manumanumanu>that's why a while-loop using mutation is often slower than the corresponding tail-recursive named let
<chrislck>good to know... i'm not writing lowlevel code but will use it as a last resort from now on
<manumanumanu>ArneBab: but I am sorry to say that the transducers are not faster than actually building intermediate collections for most things. It uses a lot less GC time, but the overhead from all the procedure passing makes them roughly comparable (unless you start combining really long transducers). a (compose (tmap 1+) (filter odd?) (tmap 1-)) transducer over 10 million elements is only about 10% faster)
<amz3>manumanumanu: I like the way you drive things :)
<manumanumanu>amz3: thank you :)
<civodul>hey hey
<civodul>rekado: did you publish pict.scm somewhere?
<rekado>civodul: only on guile-devel.
<rekado>oh, wait: https://elephly.net/downies/pict.scm
<rekado>that’s the only place.
<civodul>rekado: ok, thanks!
<lfam>Recently, this stopped working for me in Guile 2.2.3: (use-modules (ice-9 readline))
<lfam>Now I get "no code for module (ice-9 readline)"
<civodul>lfam: did you "guix package -i guile-readline"?
<civodul>in the previous core-updates, (ice-9 readline) was moved to that separate package
<lfam>Aha
<lfam>I'm sure that will do it :)
<civodul>heh
<civodul>it's confused a number of people already
<lfam>Thanks, now it works :)
<rekado>for properly sized text in the picture language I need Guile bindings for both freetype and harfbuzz.
<rekado>alternatively I could use pango, which already has Guile bindings.
<rekado>but it’s a bit heavier.
<civodul>but it's ready to use
<rekado>yeah.
<rekado>can I use it without having to depend on guile-gnome? Are there separate pango bindings?
<civodul>oh maybe not, i had forgotten it was part of guile-gnome
<civodul>yeah it's heavier :-)
<rekado>I suppose I could also use SDL2_ttf for which there are also Guile bindings, but that also seems to be rather heavy-weight.
<spk121>rekado: the actual number of Pango functions you will need in any project is quite small. An FFI for them would not be huge. (Although, I haven't tried it.)