IRC channel logs

2018-03-22.log

back to list of logs

<rekado>dustyweb: thanks for the link to the snowman tutorial.
<dustyweb>:)
<dustyweb>rekado: np!
<dustyweb>it's a bit silly but hopefully fun.
<rekado>dustyweb: I think doing this with SVG might really work.
<rekado>when I find some more time I’ll give it a try to write some procedures for that.
<rekado>needs lotsa match-sxml for things like “colorize”, but it shouldn’t be too hard.
<rekado>what’s nice is that the Racket REPL can display the images right there.
<rekado>I guess we could teach geiser in Emacs to render SVG strings as images.
<dustyweb>rekado: cool :)
<dustyweb>I hope it works out
<dijong>what's the best (or any) way to do web scraping with guile? working with horribly formed HTML, so i was looking for something like python's beautifulsoup library maybe? but i'd settle for anything one step above "regex on socket html output"
<janneke>dijong: the guile-lib package has a pragmatic html parser - https://www.nongnu.org/guile-lib/doc/ref/htmlprag/
<rekado>I have a simple picture language based on SVG and it shows up correctly in Geiser.
<rekado>It’s still very early, but I’m pretty sure this will work out.
<ArneBab>rekado: nice!
***Shozan is now known as SHODAN
<spk121>is there a MIME type for scheme code?
<civodul>spk121: text/x-scheme, though i don't know if it's standard
<amz3>tx
<spk121>civodul: thanks
<amz3>dijong: use the pragmatic parser works well, then you can snarff the html using (ice-9 sxpath)
<amz3>spk121: I was wondering the same question, I was too afraid to ask ^^'
<catonano>amz3: so
<catonano>what am I supposed to do with the #<git-repository 7fe0e0212540> object I got ? I was expecting the "cloned" folder to be populated, but it's empty
<catonano>amz3: and I try again I get informed that thhe directory already exixsts and it's not empty
<amz3>It's a long time I did not look at guile-git
<amz3>IIRC there is a clone procedure to clone a repository
<amz3>how did you get the <git-repository ...> thing in the first place?
<miqlas>So guys i just got guile working on Haiku: http://chunk.io/miqlas/764d949a26e3498caabf01e327d76623 (screenshot)
<amz3>miqlas: awesome
<catonano>amz3: I got it with this: (clone "https://gitlab.com/humanitiesNerd/tributi.git" "~/cloned" $5)
<amz3>catonano: ok then, what are you trying to achieve?
<catonano>amz3: I'm trying to clone a repository on my disk, in the "cloned" folder
<amz3>idk
<amz3>sorry, I am busy, I can't look into that right now
<amz3>maybe someone else know
<catonano>amz3: no prob. Maybe someone else :-)
<catonano>amz3: Ok, I got it
<catonano>I thought that with "~/cloned" it would have used the "cloned" folder in my home folder
<catonano>instead
<catonano>it created a folder named "~" in my "~/blah/blah/" and within it, it created the repo folder
<rekado>The hardest part of the naive picture language for Guile is, surprisingly, text.
<rekado>There’s no easy way to determine the width of some text snippet, but I need that in order to allow composition.
<rekado>not without using an SVG rendering library, that is.
<catonano>pictre language ?
<daviid>rekado: yeah, it would probably be easier if you would choose to work with cairo (guile-cairo that is), maybe
<rekado>catonano: wget https://elephly.net/downies/pict.scm
<rekado>then start geiser and do (circle 10)
<rekado>I’m willing to ignore text for now. It’s called picture language after all.
<rekado>next up is support for “transform”
<catonano> rekado: georgous !