IRC channel logs

2018-03-18.log

back to list of logs

<amz3>much wikipedia readings nowdays
<amz3>also I discovered there is a thing called "fiber logic" in math
<amz3>which afaicu aims at making two logic model work together
<mwette>amz3: hmmm ... not finding references to fiber logic in mathematics; I have heard about that in nonlinear geometry, and see it references wrt set theory
<amz3>Ok, I was misreading the word from the beginning, it's fibring logic, not fiber logic
<amz3> https://global.oup.com/academic/product/fibring-logics-9780198503811?cc=fr&lang=en&#
<amz3>:/
<mwette>amz3: thanks --- also found http://sqig.math.ist.utl.pt/pub/SernadasC/05-CSS-fiblog27.pdf
<amz3>I read that article
<amz3>I mostly interested in the subject from the point of view of the knowledge representation as explained in the introduction
<amz3>the article is after the introduction rather light on the applications of the fibring logic, i think
<mwette> /quit
<clavero>Hello
<clavero>Why commands like `filter` have documentation when typing `,d filter` but `lambda`, for example, just returns `#f`?
<chrislck>perhaps because no one really uses ,d as documentation; we usually refer to the pdf
<clavero>Oh, ok
<clavero>Thanks
<mwette>clavero: lambdas can have documentation.
<mwette>clavero: ,d (lambda () "hello" 1)
<clavero>No, my question was why the lambda keyword doesn't have documentation
<clavero>Or cons, car, cdr, first ...
<mwette>Ah, OK.
<mwette>I'm not sure syntax can have doc strings.
<chrislck>I learned from SICP HTDP TLS and never saw ,d until just now :-P
<clavero>I guess I'm used to it from other languages
<chrislck>there's lots to unlearn from other languages :-)
<clavero>I don't know, I find useful to just ,d everything when I'm in doubt instead of juggling with pdf's
<clavero>Also, that's not a Scheme thing per se, is more of an implementation thing
<chrislck>personally i found more useful to install racket, and use the bookmarked local html racket documentation
<clavero>That's a good one, I'll definitely try
<mwette>I usually keep a PDF version of the guile ref manual open.
<chrislck>installing racket will install a local copy of https://docs.racket-lang.org/ - it's really good
<ArneBab>sneek: later tell clavero: I think that’s an implementation artifact, which would be nice to have different
<sneek>Okay.
<ArneBab>sneek: later tell clavero: I typically have the guile ref info manual open, and that actually works
<sneek>Will do.
<dadinn>hi all
<dadinn>looking through the guile manual, trying to replace some bash scripts with guile, but I can't find manuals how to use posix pipes
<dadinn>answers like this are insufficient https://stackoverflow.com/questions/18436981/how-do-i-create-a-pipe-between-two-processes-in-guile
<dustyweb>hm
<dadinn>is there a macro where I can write lines of shell commands in sequence, and they will be piped to each other like if I put | inbetween them?
<dustyweb>I guess there isn't an sxml tool that in writing sxml can "compact" uris to compact namespaced uris
<dadinn>I would expect system* to do that, but it seems it does something else
<dadinn>or is this something which is not recommended?
<spk121>dadinn: it should be easy enough. Lemme think.....
<spk121>it is probably open-input-pipe you need
<spk121>but I don't have a proper example
<dadinn>spk121: looked into the ice-9 popen module but couldn't figure out how to translate the pipe commands to POSIX pipes... a pipe should be a channel to which you can both put and take, so this input/output-pipe analogy feels weird to me, a pipe should be both
<dadinn>one man's output is another's input :P
<dadinn>someone's piss is another's drink...
<dadinn>human centipede but for processes, might be a sequel for Tron
<dadinn>sorry, drank too much coffee...
<spk121>Yeah, I don't know to much about this, but, here's a thing.
<spk121> https://paste.gnome.org/prby4jsg2
<dadinn>spk121: hmm, interesting
<ArneBab>sneek: botsnack
<sneek>:)
<ArneBab>spk121: it looks like you could use reduce to "map" this onto a list of program calls to have them piped together
<ArneBab>s/reduce/fold/
<ArneBab>s/reduce/fold/
<ArneBab>I have a funny issue with folding over piped processes: Sometimes this stops early. https://paste.pound-python.org/show/K3Tvasz2iAH4wJu76rUL/
<ArneBab>it should always be equivalent to echo 1 | echo 2 | echo 3 | echo 4
<ArneBab>but sometimes it only does echo 1 | echo 2
<ArneBab>without change to the code
<rekado>“assoc-set!” doesn’t seem to work for me. It says that it is expecting a mutable pair.
<rekado>Are alists not mutable by default?
<rekado>The address-list example in “6.6.20.2 Adding or Setting Alist Entries” results in the same error.
<ArneBab>dadinn, spk121: my paste is a take on making a pipe command: https://paste.pound-python.org/show/K3Tvasz2iAH4wJu76rUL/
<mwette>rekado: make sure your alist is mutable: (assoc-set! '(("a" . 1) ("b" . 2)) "a" -1) will not work; the example in 6.6.20.2 is broken I think
<mwette>rekado: replace '( with (list and maybe it works
<mwette>(define capitals (list (cons "New York" "Albany") ...))
<mwette>probably need to use cons also or wrap a copy-tree around the whole thing
<mwette>(define capitals (copy-tree '(("New York" . "Albany") ...)))
<rekado>mwette: thanks. I’ll just use acons instead.
<mwette>ArneBab: I think you may want to use redirect-port. Checking ...
<ArneBab>mwette: did you already find a reason? (the port is always only used once for input and once for output)