IRC channel logs

2018-03-12.log

back to list of logs

<FrankyCyborg>has someone experience with gnutls+guile and can identify, what goes wrong at the end of the compilation? is a script somewhere just missing the ".la" file suffix? log and info: https://hastebin.com/eraxizasez.bash i'm using the MacPorts package manager on Mac OSX 10.6.8 and try to build against guile 2.2.2 - the shell commands macports uses to build the software start with a "Executing:"
<mwette>FrankyCyborg: I have used macports w/ gnutls and guile. I think there is a bug in gnutls. Try this: install gnutls w/o +guile. Then reinstall w/ +guile. The issue, if I remember correctly, is that the gnutls build does not look in one of the build directories to link.
<mwette>"to link" means "for shared objects"
<FrankyCyborg>ah ok, I could try that, as the maintainer in the macports channel said, he usually doesn't build it with gnutls support, so I am doing that right now.. I can try your hint right after that!
<FrankyCyborg>mwette: ok, second pass is through and indeed, it's building and installing without any error. now it's time to check, why this is happening... but thanks a lot for this hint! don't know if I would have tried that.
<mwette>I belive, where guile support is built in gnutls/guile, the build does not look in gnutls/lib or something like that. I don't have the source handy
<mwette>gotta go -- good luck
<galex-713_>amz3: oh in fact yes
<chrislck>amz3 thank you, as it turns out, i think it's out of scope; vector cannot be converted to json in guile-json
<galex-713_>chrislck: yet… guile already implements javascript right? with all these datatypes implemented? so isn’t there a way to share these datatypes among languages?
***siel_ is now known as siel
<lloda>sneek: later tell daviid I got g-wrap to install by defining GUILE_CFLAGS and _LIBS by hand. When I tried your patch without those exports, g-wrap autogen.sh still failed to find Guile
<lloda>hmm
<lloda>anyway if someone has a solution for guile-gnome, please let me know
<lloda>guile-snarf -DHAVE_CONFIG_H -I. -I. -Wall -pthread -I/home/user/sys/guile4/include/guile/2.2 -std=gnu99 @GUILE_CFLAGS@ -I/opt/g-wrap/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include gc.c > gc.x \\
<lloda>|| { rm gc.x; false; }
<lloda>gcc: error: GUILE_CFLAGS@: No such file or directory
<lloda>Makefile:955: recipe for target 'gc.x' failed
<lloda>so
<lloda>I think it's ridiculous that you have to tell seven different tools where you've installed something
<lloda>it should be enough to just define PKG_CONFIG_PATH