IRC channel logs

2018-02-15.log

back to list of logs

<CherryMan>what's the point of slots for foreign objects?
<ijp>CherryMan: slots are the fields in foreign objects
<Javyre`>ijp: are the names attributed to the slots ever used?
<codefree>hi, I was wanting to calculate framerate in a game. I see (tms:clock (times)), but am confused about the units it returns. Is that like nanoseconds...? and is that going to be the same base across platforms?
<rlb>wingo: ok, thanks - I'll at least do that, i.e. mark it as unresolved, and upload to unstable, might get us closer to propagating back to testing, and if I get a chance, I might poke at the test myself.
<codefree>does anybody know what is "current real time" as returned by (tms:clock (times))?
<codefree>it seems to be trillionths of a second count, but I was wondering if it was the same across platforms...?
<amz3>maybe check the source?
<civodul>codefree: in general i find the SRFI-19 API to be more convenient and clearer
<civodul>i'd recommend taking a look at that one
<civodul>uh, looks like Debian has 2.0.13, not .14: https://packages.debian.org/search?keywords=guile-2.0
<civodul>hey rlb, any idea why? ↑
<Sleep_Walker>hi!
<Sleep_Walker>I'm a bit fighting with guile module packaging and I was wondering, if dynamic-link could be somehow forced to use /usr/lib64/libgit2.so.0.26.0 instead of /usr/lib64/libgit2.so symlink pointing to that file
<Sleep_Walker> /usr/lib64/libgit2.so file is usually part of -devel subpackage containing files required for build, but not runtime
<Sleep_Walker>so it is unhandy to require build time dependencies for runtime of a package
<Sleep_Walker>TIA for answer
<amz3>Sleep_Walker: did you try LD_PRELOAD?
<Sleep_Walker>amz3: could you please say more what you mean?
<amz3>Sleep_Walker: it's trick to force the loading of a library without going through shared library name resolution
<amz3>see https://stackoverflow.com/questions/426230/what-is-the-ld-preload-trick#426260
<amz3>in your exemple, you can do LD_PRELOAD=/usr/lib64/libgit2.so.0.26.0 guile foo.scm
<amz3>but I think it's doesn't anwer your question
<amz3>you are asking about how to make autotools choose the correct .so
<amz3>?
<Sleep_Walker>amz3: and that does influence dynamic-link? https://www.gnu.org/software/guile/docs/docs-1.8/guile-ref/Low-level-dynamic-linking.html
<amz3>yes, dynamic link will see the library is already loaded and won't load it again
<Sleep_Walker>amz3: you can express my question as that as well, right - how to tell autotools to use some other file
<amz3>that's different, I don't know how to do that
<amz3>autotools, get it's information from pkg-config if that helps
<Sleep_Walker>I was more concerned with the interface of the function
<Sleep_Walker>that it doesn't accept file (because it adds `.so' by itself
<Sleep_Walker>I could patch the code to use file I want
<Sleep_Walker>but not with this interface
<Sleep_Walker>using LD_PRELOAD is probably not the right way how to use guile modules everywhere in the system
<Sleep_Walker>I'm asking from package manager perspective...
<Sleep_Walker>s/manager/maintainer/
<ehiggs>are there benchmark results for the language shootout for guile?
<dustyweb>so an interesting workaround to the "gah emacs is destroyed by this long line I printed at the REPL" problem
<dustyweb>Racket just pretty-prints their structures by default
<dustyweb>problem solved!
<dustyweb>~solved ;)
<dustyweb>it might not be a bad idea to make that an option in Guile
<cmaloney>Also a nice debugger would be cool in Guile.
<cmaloney>and a tasty sandwich while we're at it
<daviid>dustyweb: yep, i sent two requests for improvement, see bug#29669 and bug#29684
<dustyweb>davidl: ah thanks for the pointer to those bugs :)