IRC channel logs

2018-02-04.log

back to list of logs

<jeko>Hello guys !!
<rain1>hey :)
<janneke>hi rain1
<rain1>hiya! how goes :)
<amz3>héllo all
<rain1>yo amz!
<amz3>yo rain1, are you still fiddling with minikanren?
<rain1>not at the moment, i will like to do more with it but at the moment im making a PEG parser
<amz3>oh
<amz3>I was at guix event at fosdem
<rain1>awesome!
<amz3>yeah
<rain1>I am looking forward to seeing the fosdem talks online
<amz3>too short tho
<rain1>how did it go?
<amz3>very well
<jeko>haha I missed the guix event
<jeko>I came one day too late lol
<jeko>I was at work anyway
<jeko>too sad :(
<jeko>I left FOSDEM in saturday afternoon, went to the ICAB and then realized it was the wrong day
<jeko><-- dummy
<Javyre>CherryMan: test plz ignore
<manumanumanu>Good evening
<amz3>and=> is very awesome
<manumanumanu>who's macros?
<manumanumanu>I wrote an and~> a long time ago with cut-like syntax extensions
<manumanumanu>so (and~> 5 (- 3) (< 1 <>)) would be #t
<manumanumanu>implicit insertion to the left, but it also supported <>-substitution, and even <...>
<amz3>interesting
<amz3>manumanumanu: what do you mean by "who's macros?"
<manumanumanu>Who wrote the macro?
<manumanumanu>I originally wrote mine for chez: https://bitbucket.org/bjoli/nietzsche/src/1769998a800955d5831aa7c0c8b3c31ba00f7050/syntax/threading.scm?at=default&fileviewer=file-view-default
<amz3>manumanumanu: it's a guile macro
<manumanumanu>the extended receive mentioned in the comments are just an extra clause for receive that expands (receive _values-producer_) into (call-with-values (lambda () _values-producer_) list)
<manumanumanu>built in??
<amz3>manumanumanu: builtin
<manumanumanu>oh, I thought it was a threading macro :D :D
<manumanumanu>sorry
<amz3>manumanumanu: you have _some_ experience writting macros :D
<manumanumanu>I am getting quite proficient actually :)
<amz3>I can see that :)
<amz3>I never wrote a macro that use another macro on purpose
<manumanumanu>the thing is, if you want to serious work with syntax-rules, that is what you have to do
<manumanumanu>and for some things, it is the easiest thing to do wint syntax-case as well
<manumanumanu>amz3: btw, have you ever used srfi-2=
<manumanumanu>?
<manumanumanu>and-let*
<amz3>no
<manumanumanu>my god, you are in for a treat
<amz3>it seems like the generalized and=> that was proposed in guile
<manumanumanu>it works like let*, but if any of the subsequent forms return #f, it stops evaluation and returns #f
<amz3>nice
<amz3> https://srfi.schemers.org/srfi-2/
<amz3>I am just getting used to and/or/and=> to handle errors
<manumanumanu>for short scripts I use it with false-if-exception
<amz3>I don't like let* very much for some reason
<amz3>it reminds me of python code ^^
<manumanumanu>let* is my best friend.
<amz3>why is that?
<manumanumanu>because subsequent bindings are common, and using nested lets suck.
<manumanumanu>and it is more concise than using define
<manumanumanu>and-let* however is my bestest of friends.
<amz3>:)
<amz3>I will study and-let*
<manumanumanu>the implementation in srfi-2 is hard to understand. look at the one in the guile source tree if you want to see the soource
<amz3>I don't read much code :/
<amz3>I will think about it
<mwette> /quit
<amz3>ACTION fought procrastiation, fear of failure & rejection to implement complete sign up & sign in workflow
<amz3>at last
<amz3> https://framagit.org/a-guile-mind/culturia.next/commit/a2599b0170826736eafb6a1cde35b2243bc7531f
<cmaloney>amz3: Congrats!
<amz3>tx!
<amz3>btw security, is not an after-thought... I did not implement csrf protection yet, after reading django code and csrf wikipedia article I understand better why people recommend no-script