IRC channel logs

2018-01-16.log

back to list of logs

<manumanumanu>jesus christ in a chicken basket. I love macros.
<manumanumanu>A friend of mine created bindings for libsodium for perl, and the amount of boilerplate is astounding
<daviid>hello guilers!
<manumanumanu>good evening
<OrangeShark>Happy Tuesday!
<dsmith-work>Tuesday Greetings, Guilers
<roelj>Is there a convenient function in Guile to find a file matching a regexp? Like (find-file "/home/user/some-dir/*/*-tag.txt")
<davexunit>no
<davexunit>you could use the file tree walking procedure plus a regexp to write it, though
<davexunit>see the docs for 'ftw' in the manual
<roelj>Alright, thanks :)
<daviid>roelj: I wrote one, not as beautifull as i wish, but it might help ...
<daviid> http://git.savannah.nongnu.org/cgit/grip.git/tree/grip/fs-ops.scm?h=devel
<daviid>see get-filenames (it's based on Aubrey Jaffer's SLIB, see the commentary in (grip support slib) ...
<daviid>roelj: I believe guix has a 'find file' in its utils too, maybe ask in #guix
<roelj>daviid: Oh, that is very useful, thanks!
<daviid>roelj: yw
<Wojciech_K>Hello! How to make Guile `eval` in local scope? Example: (let ((x 3)) (eval '(+ x 1) ??)
<Wojciech_K>)
<bavier>does anyone know how to suppress output from ldconfig like: "/sbin/ldconfig: /usr/local/lib/libguile-2.0.so.22.8.1-gdb.scm is not an ELF file - it has the wrong magic bytes at the start."?
<dsmith-work>Wojciech_K: Hows this: https://www.gnu.org/software/guile/manual/html_node/Local-Evaluation.html
<bavier>I think the gdb debugging support for libguile is great, but I've heard too many complaints about that output from ldconfig
<Wojciech_K>Thanks, dsmith-work. (local-eval sexpr (the-environment)) does the trick
<dustyweb>davexunit: https://www.npmjs.com/package/commander look at this stringly typed madness
<ArneBab_>dustyweb: where is that stringly typed? is the typing not rather in the type-parsing functions?
<dustyweb>.option('-p, --peppers', 'Add peppers')
<dustyweb>ArneBab_: so right there
<dustyweb>it's extracting the options based on what's in that string
<dustyweb>rather than taking them as some sort of proper arguments
<dustyweb>but it gets a bit goofier
<dustyweb> .command('install [name]', 'install one or more packages')
<dustyweb>you can also do that stuff
<dustyweb>I dunno, parsing the structure out of strings passed in seems really gross to me
<dustyweb>davexunit introduced me to the term "stringly typed", I may be misusing it though ;)
<ArneBab_>isn’t --peppers just giving the variable name?
<dustyweb>yes, the option name is parsed out of that string
<dustyweb>but why parse it from a string? better to have the structure actually passed in via... structure
<dustyweb>I'm doing more javascript for work so I'm just complaining ;)
<ArneBab_>Given that these come from the command line, they actually come as strings, I think
<ArneBab_>you may be in a better position to judge whether the parsing functions actually provide any type security in Javascript, though
<ArneBab_>You could still add an integer argument to a string argument and get it appended to the string
<OrangeShark>I believe stringly typed is more like where you pass strings to represent types to change the behavior of something
<ArneBab_>so that just checks the structure of the arguments (that they can be interpreted as the given type) but does not give you runtime guarantees.
<ArneBab_>Technopedia claims that stringly typing means to store things in strings: https://www.techopedia.com/definition/31876/stringly-typed
<OrangeShark>okay, the example they give is storing the date as a string
<ArneBab_>I don’t know whether they are right in their description, though
<davexunit>dustyweb: Ruby's OptionParser class is similarly stringly typed and terrible
<davexunit>I use it pretty frequently at work to make cli utilities
<dustyweb>ArneBab_: sounds like stringly typed to me :)
<ArneBab_>dustyweb: ok - thanks :)
<cmaloney>dustyweb: javaScript is just a frustrated Scheme. ;)