IRC channel logs

2018-01-07.log

back to list of logs

***bairui_ is now known as bairui
<francorcr>help
<francorcr_>list
<francorcr_>list/
<francorcr_>?;
<francorcr>#help
<amz3>I hit a bug because of struct with unions
<wingo>moin
<wingo>4 minutes to spare ;)
<amz3>hey
<ft>212343211234321234321432134321234
<ft>whoops
***webshinra_ is now known as webshinra
<amz3>this struct with union is painful and settings up gnunet from git is painful too
<amz3>nevertheless I will try to describe how to reproduce the issue maybe someone will have the answer on the mailling list
<mwette>ACTION was repairing a bookshelf today and ran across a printed copy of the Guile Reference Manual for version 1.2a. I guess it's time to throw that out.
<amz3>mwette!
<amz3>stop disconnecting I have a question for you, does FFI helpers works with multiple shared libraries? basically programs that have several shared library and share header files between them
<amz3>btw I tried to compile FH and it failed
<amz3>I know I am jumping from one project to another but I make progress nonetheless
<manumanumanu>Could someone check something for me? If you have libGL installed (which you probably have, check it using "ldconfig -p |grep libGL"), try running (dynamic-link "libGL") and see what happens
<daviid>manumanumanu: works fine here
<daviid>scheme@(guile-user)> (dynamic-link "libGL")
<daviid>$1 = #<dynamic-object "libGL">
<manumanumanu>WTF is wrong at my end then?
<mwette>works for me on Centos 7.4
<manumanumanu>it searches some guix locations, but not .guix-profile/lib
<manumanumanu>oh. it searches the wrong dir on ubuntu...
<amz3>it doesn't work on my side, ubuntu too
<manumanumanu>amz3: guix guile?
<amz3>yes
<manumanumanu>amz3: does it work for libraries in your guix profile?
<manumanumanu>say, libsodium if you have it installed
<manumanumanu>all my libs are in /usr/lib/x86_64-linux-gnu
<manumanumanu>which guile (on guix) doesn't search
<amz3>I have the same pb with gnunet
<amz3>I use the full path to the shared lib, to load the correct lib
<amz3>scheme@(guile-user)> (dynamic-link "libsodium")
<amz3>ERROR: In procedure dynamic-link:
<amz3>I just installed it using guix package -i
<amz3>scheme@(guile-user)> (dynamic-link "/gnu/store/f6g3ypvsd4dmzgprqfmka9kiz5lp54nc-libsodium-1.0.16/lib/libsodium.so")
<amz3>$1 = #<dynamic-object "/gnu/store/f6g3ypvsd4dmzgprqfmka9kiz5lp54nc-libsodium-1.0.16/lib/libsodium.so">
<manumanumanu>amz3: you could just sed ld_library_path
<manumanumanu>but it is a friggin pain anyway
<amz3>maybe... but autotools for guile bindings do the necessary in a guile module, to load the sharelib using the full path
<manumanumanu>I'll just add guix-profile/lib to LD_LIBRARY_PATH and ignore any risks
<amz3>I just made a small autools for gnunet-guile with documentation
<amz3> https://gnunet.org/git/gnunet-guile2.git/
<amz3>I just copy pasted stuff
<amz3>but it works :D
<amz3>except there is not html output yet
<amz3>a lot of people using matrix.org...
<amz3>all the [m] people are matrix.org people
<amz3>not much people use it here, but on #guix, it's a lot of them
<amz3>guix is mainstream anyway
<amz3>;)
<manumanumanu>amz3: if you ever find a workaround that does not include setting $LD_LIBRARY_PATH or anything special at all to make guile behave well, please tell me
<manumanumanu>how does guile decide which dirs to search for libGL.so?
<amz3>manumanumanu: yes, the solution, is to use the full path to the .so file see above example for libsodium
<amz3>it's not guile that does the lookup, it's dlopen or something else
<manumanumanu>amz3: that stinks :( Then setting ld library path is better
<daviid>manumanumanu: /etc/ld.so.conf and /etc/ld.so.conf.d
<manumanumanu>but then why doesn't it find the standard ubuntu directories?
<daviid>w
<manumanumanu>daviid: thx!
<daviid>manumanumanu: it's not guix, it's all systems
<amz3>I used to LD_PRELOAD the so file
<amz3>to work around that behavior
<amz3>Now I live happy with hardcoded paths
<amz3>(set by autotools)
<manumanumanu>daviid: the thing is, the correct directories are in etc/ld.so.conf... guile (guix version) doesn't seem to honour them
<daviid>not sure guix configure guile to use the distro /etc/ld.so.conf ... yo should ask on #guix, I don't use guix :) (or shoud I say :(
<daviid>I mean not sure guix uses /etc/ld.so.conf, (it does not depends on guile for this)
<daviid>guile will see what the system shows ...
<manumanumanu>which makes this a weird bug, because ldconfig shows all the libraries I want it to (except the ones I installed in guix), but guile cannot load any shared library
<manumanumanu>not even sure it is a bug. I probably effed up my install, or ubuntu doesn't play well with guix