IRC channel logs

2017-12-28.log

back to list of logs

<w1gz> #erlang
<w1gz>oups
<rlb>Is this a known issue? (Trying to fix 2.2 on Debian, and currently 2.2.3 on amd64):
<rlb>GC Warning: Failed to expand heap by 65536 bytes
<rlb>GC Warning: Out of Memory! Heap size: 1 MiB. Returning NULL!
<rlb>Warning: Unwind-only `out-of-memory' exception; skipping pre-unwind handler.
<rlb>FAIL: test-out-of-memory
<rlb>
<rlb>(In current debian unstable.)
<daviid>rlb: on amd64? here, debian buster, amd64 as well, manually installed 2.2.3 compiled fine, make check as well...
<rlb>daviid: thanks -- this is within an sbuild chroot, so sometimes that has relevant differences, and there may be some cflags differences, etc.
<rlb>Suppose it could also be buster vs sid. In any case I'll try a "normal" build and make check from a checkout of the v2.2.3 tag in both the chroot, and outside.
<rlb>(if it matters, we build from the source tag, not the tar archive)
<rlb>...and 2.2.2's not happy on all the architectures either. I was hoping 2.2.3 might fare better: https://buildd.debian.org/status/package.php?p=guile-2.2&suite=sid
<daviid>rlb: I can't really help, just wanted to let you know that here (I compile from the source as well), it's all fine, debian buster and amd64 ... so, indeed something is getting in theway, either because of chroot and/or sid
<amz3>o/
<manumanumanu>Morning
<amz3>let's code in guile again :)
<amz3>I plan to rework my blog application to not rely on biwascheme hence not rely on javascript
<amz3>too bad kristofer is away, I think I havea fix for his pastebin app
<amz3>wat! the performance of the pastebin are very poor :(
<amz3>even with fibers and my fix
<amz3>10 RPS
<amz3>I feel guilty
<amz3>let's try some other webapp
<amz3>with two fixes I went from 10 RPS to 210 RPS #win
<amz3>which is according to boom program "pretty good"
<amz3>the issue is that the highlighter is slow
<amz3>or used at the wrong place depending on how you think about it
<amz3>fwiw firefox.fr does 390RPS
<amz3>it's an empty just nginx default page over the internet
<rlb>Looks like page needs updating for 2.2.*: https://www.gnu.org/software/guile/download/
<amz3>there is a git for the website, I am just too lazy to look it up
<rlb>OK, I can reproduce the debian test crash using the 2.2.3 release archive and building via normal "configure && make && make check". I don't know whether or not gcc 7 is relevant, but it does look like the current debian build flags *are*, i.e. it's fine without them: https://paste.debian.net/1002741/
<rlb>(Ignore the bup dir, that's just where I ran the buildflags command for the paste.)
<rlb>I'll try without the -O0 override next (which we need(ed?) on amd64 -- http://bugs.debian.org/809608 )
<rlb>OK, so the test oom doesn't appear to be related to -O0; next up, hardening flags...
<amz3>at last i wrote some guiel :)
<amz3>wingo: tx for the reply on the mailing list
<amz3>wingo: so now, my understanding is that fluids follow fibers when they move around threads, is that correct?
<amz3>based on this, I made a fix in guile-pastebin and it seems to work.
<rlb>Looks like the test-out-of-memory oom failure may be caused by -f-stack-protector-strong