IRC channel logs

2017-12-23.log

back to list of logs

<mwette>daviid: you live well!
<manumanumanu>wingo: that case thing you were talking about, did you think about implementing it as a macro or in the compiler? I have a soon-to-be double-dispatch case (memv and binary search with extra support for strings). I don't know about addig hash tables yet though. Can they be pre-computed by peval?
<amz3>Off topic but a real question: how do keep your work at $WORK?
<ft>Don't configure your work email account on your phone. :)
<amz3>I just filled an issue on github about some bug I found at work
<amz3>things start badly
<amz3>I don't need email on my phone, I sync tabs in firefox already :(
<ft>With tabs you open at work?!
<amz3>yes
<ft>Okay, you're in deep then.
<wingo>manumanumanu: i would like to implement it in the compiler. recognizing chains of if statements there.
<wingo>and compiling to "case" as appropriate
<wingo>as the paper suggests
<ArneBab_>amz3: well, stop synching tabs. If you need to transmit info from work to home, have an analog (paper-) notebook
<ArneBab_>daviid: I think something similar hit me … #+attr_latex: :align r|L{\\dimexpr 0.32\\linewidth-1.5\\tabcolsep}L{\\dimexpr 0.32\\linewidth-1.5\\tabcolsep}L{\\dimexpr 0.32\\linewidth-1.5\\tabcolsep} -- using this definition for L: https://bitbucket.org/ArneBab/1w6/src/26274437f361ccde5881e94e8a9a45354470ec05/Hauptdokument/ews30/ews30setup.tex#ews30setup.tex-12
<ArneBab_>daviid: usage example: https://bitbucket.org/ArneBab/1w6/src/26274437f361ccde5881e94e8a9a45354470ec05/Hauptdokument/ews30/ews30setup.tex?at=default&fileviewer=file-view-default#ews30setup.tex-12
<daviid>ArneBab_: cool! let me look at it... tx
<daviid>ArneBab_: i think you did paste twice the same link
<daviid>ArneBab_: I use tabularx, and my L def is
<daviid>\\newcolumntype{L}{>{\\raggedright \\arraybackslash}X}, but that won't center vertically, as you know...
<daviid>ArneBab_: just tried this
<daviid>\\newcolumntype{L}[1]{>{\\raggedright\\let\\newline\\\\\\arraybackslash\\hspace{0pt}}m{#1}}
<daviid>which does not work either. there is a bug im the m operator, when all other colun neighbors are images, it fails to proper calculate the height of the cell where 'we ask' to vertically center the text, and always pushes the txt tothe bottom
<daviid>ArneBab_: my best attempt so fr is to have the text slighty below the top, using a 'multirow trick', and a false (writng in white) 2 rows for one image cell, here: https://paste.debian.net/1002037 {in this example, replace img-1 with one image on your computer of course...)
<daviid>this uses tabluar (not tabluarx), to make the #latex folks hapy to try to debug this with me...
<ArneBab_>daviid: ah, yes, you need to switch to m - I thought that should work
<ArneBab_>daviid: did you delete the paste?
<ArneBab_>daviid: does it work if you manually set the height of the image?
<ArneBab_>daviid: ang yes, it was the same link, unintentionally :( the correct one is https://bitbucket.org/ArneBab/1w6/src/26274437f361ccde5881e94e8a9a45354470ec05/Hauptdokument/ews30/ews.org#ews.org-710
<ArneBab_>(usage example)
<ArneBab_>this is where I found the trick: https://tex.stackexchange.com/questions/12703/how-to-create-fixed-width-table-columns-with-text-raggedright-centered-raggedlef/12712#12712
<daviid>ArneBab_: here is new paste (last 24h) https://paste.debian.net/1002182/
<daviid>ArneBab_: I can't set manually the vertical size of the image anyway, all this is generated code, based on the width of images...
<daviid>I did switch to m in your example, as I reported, it does not work