IRC channel logs

2017-12-21.log

back to list of logs

<amz3>héllo
<amz3>I am reading the documentation of elastisearch
<amz3>so far, it's seems like a mess of exceptions without the guarantees of SQL like ACID
<amz3>I don't understand how this can be put in productio without headache
<amz3>that said it has a broad set of features
<amz3>that's part of my 'mess of exceptions' description above
<amz3>AFAIU so far, it's basically a some kind of store with multiple kinds of indices
<amz3>that can scale horizontally
<amz3>ie. the data can be stored on multiple machines
<amz3>Here is an extract of the the documentation explaning that a write can fail https://paste.freshbakedyams.com/paste/18L146PG
<amz3>an example of feature creep: you don't need to create the "table" that will store your document and instead directly ask to index a given document under an index name, field types will be automatically guessed based on the first document
<amz3>I understand how it's useful, but at the end of the day, it's a little extra effort to declare the index upfront and IMO will make the documentation easier to read
<amz3>similarly you can pass parameters as HTTP JSON body or query string
<amz3>ACTION lazy dev
<amz3>ACTION lazy dev™
***webshinra_ is now known as webshinra
<amz3>(also elasticsearch invented a scripting language called ``painless'')
<daviid>hello guilers!
<daviid>mwette: yu might be intereste to read about this: https://jvns.ca/blog/2017/12/21/bindgen-is-awesome/ (if you haven't yet ...)
<jralls>Is scm_divide(scm_from_int(num), scm_from_int(den)) the best way to construct a Scheme rational from C int numerator and denominator?
<mwette>daviid: Thanks for the pointer. It looks similar to the helper I am working on. [One think I like about our helper as is that it can parse comments from the C headers and pretty-print c code; the original C code is generated as a comment along with the Scheme bindings.
<mwette>jralls: this is low level but I might work : scm_double_cell(scm_tc16_fraction, num, den, 0)
<jralls>mwette: Will that work with int64_t num & den?
<mwette>jralls: not sure. the arguments are scm_t_bits which seems to be uintptr_t. That should be 64 bits if you are running on a 64bit machine.
<jralls>Hmm. I need 64 bits regardless of machine architecture, so scm_divide is probably safer.
<mwette>i agree
<daviid>mwette: yes, I know you are working on ffi-helper, hence the link ... I thought you might be interested to read their approach, maybe snarf some ideas, maybe ...