IRC channel logs

2017-11-24.log

back to list of logs

<amz3>héllo
<artyom-poptsov1>Hello, amz3!
<manumanumanu>Morning guilers!
<str1ngs>god these autoconf macro's are driving me bonkers
<str1ngs>GUILE_PROGS gets all confused if I use GUILE_PKG
<str1ngs>actually GUILE_PROGS get confused . if I have /bin/guile and /bin/guile2.2 it will find guile 2.2 headers but then complain that /bin/guile is not version 2.2
<str1ngs>actually GUILE_PROGS seems potentially broken. since the documentation state is should check for preffix -X.Y first anyways.
<str1ngs>atleast that's how I'm reading https://www.gnu.org/software/guile/manual/html_node/Autoconf-Macros.html
<str1ngs>or... aclocal is using the wrong guile.m4
<str1ngs>well manually adding guile2.2.m4 seems to fix it
<str1ngs>so I think the issue is I don't understand autotools enough :(
<mistnim>Hi, is the guile-gnome library used? The documentation doesn't look very welcoming
<str1ngs>mistnim: the git repo looks like it's still active
<mistnim>what would you use to make a gui?
<str1ngs>I'm in the middle of writing a guile guile program but I opted for GTK. but in C
<str1ngs>err guile gui program*
<str1ngs>but the reason I used C is I'm using webkit and some other widgets
<str1ngs>I think guile gnome is worth checking out if you don't need anything fancy under the hood.
<amz3>mistnim: what do you want to do?
<amz3>mistnim: don't be shy :)
<amz3>str1ngs: sorry, I can't help with autotools, I am more than newbie in this regard
<amz3>I finished re-coding the indexing part of my search engine
<amz3>which is almost fully tested now
<amz3>Now I need to adapt the querying part
<amz3>also I started to scrape wikipedia and it's verrrrrrry long
<mistnim>amz3, I was thinking of a an app to track the diet. The other open source alternatives don't look that good to me
<amz3>mistnim: why not create a web app then?
<amz3>mistnim: also I have plenty of free time, I could help with your project
<mistnim>amz3, there are many options already, the idea is to make an app for people who don't want to send their data to the cloud
<amz3>mistnim: it's not a problem you can create a web app that runs locally
<mistnim>amz3, that nice of you
<mistnim>amz3, I understand what you mean, that's an option
<amz3>nowdays everything is done as a web app
<amz3>that said, I don't think about a thing like electron
<mistnim>yes, you mean just a server you need to start and then connection to localhost
<mistnim>with the browser, right?
<amz3>which does embed a browser in the app, it's more like the user start an app which will both spawn a browser at the correct url and server on localhost
<amz3>yes
<amz3>mistnim: that said is an example of guile gnome powered app https://www.gnu.org/software/foliot/screenshots.html
<amz3>the proof is there is an example gtk application
<amz3>but there is no GNU project that use guile as web app
<mistnim>I was also intrigued by the idea of a tool for making the docs from docstrings
<amz3>that said I made several, just they are not GNU
<amz3>mistnim: you are the person asking for project ideas on the ML?
<mistnim>amz3, yes
<amz3>ok
<mistnim>I haven't decided yet :/
<amz3>because I was going to send another batch of ideas
<amz3>mistnim: do you know lucene/solr/elasticsearch java software?
<mistnim>amz3, nope
<amz3>oh
<amz3>those are libraries/http server that embedded a search engine
<amz3>basically it's a stack lucene is the library and elastic search is the http server which use lucene-solr to implement a search engine
<amz3>sneek: what is culturia?
<sneek>I could be wrong, but culturia is a re-search project
<amz3>sneek: what is culturia?
<sneek>From what I understand, culturia is a re-search project
<amz3>well
<mistnim>amz3, a search engine for what?
<mistnim>something like google and ddg?
<amz3>mistnim: well, my end far fetched goal is to implement a concept search engine
<amz3>sneek: a concept search engine is a search engine that takes into account concepts https://en.wikipedia.org/wiki/Concept_search
<sneek>Okay.
<amz3>mistnim: somewhat yes
<amz3>I want to make it a GNU project, but it much too early
<str1ngs>I'm writing a web browser in guile
<mistnim>amz3, have you already started?
<amz3>I used to have a demo but it's down because I changed my server and I am too lazy to setup back the app...
<mistnim>str1ngs, from scratch?
<str1ngs>yes
<amz3>str1ngs: fun!
<mistnim>str1ngs, with a gui or console?
<str1ngs>gui
<mistnim>woah
<amz3>(you never implement something from scratch nowdays...)
<str1ngs>has a repl and everthing
<str1ngs>well the html rendering is done by webkit
<amz3>str1ngs: do you implement layout algorithm like grid layout or flexbox? do you handle line continuation for text in justify text-align?
<amz3>str1ngs: oh
<amz3>ok
<amz3>str1ngs: so it's a browser with an repl
<amz3>str1ngs: that will be fun
<amz3>str1ngs: you know what I miss from browsers, is deep integration with platforms
<amz3>web platforms that is
<amz3>like GNU Social, mastodon, QA platforms like Quora or StackOverflow
<amz3>you basically can't decide how true is some profil on those platforms without diving into hundreds of messages and their bio is short phrasing that wanna be catchy
<amz3>my plain was to create some summarizers for web pages
<amz3>text summarizer
<amz3>did you know that AI assistant can't summarize a text for you?
<amz3>it's a missing feature from AI.
<str1ngs>here's a screenshot of the browser https://imgur.com/a/Zsazr
<mistnim>there are reddit bots that summarize pages
<amz3>mistnim: oh really? let me know what username it is
<mistnim>amz3, I have no idea, I just see its posts from time to time, the get very upvoted
<amz3>never saw them
<str1ngs>amz3: with this extensible browser you could do alot of intergration
<amz3>str1ngs: can you interact with the page like change css on mouse over an element?
<str1ngs>eventually yes, just not quite yet
<amz3>or capture the text that is selected?
<amz3>display the title also
<str1ngs>right now I'm focused on C to scheme API
<mistnim>amz3, what do you think of an app like readlang.com?
<str1ngs>amz3 yes all that is possible
<mistnim>there is no open source alternative as far as I know
<amz3>mistnim: I trying it
<amz3>mistnim: I did not know about that app
<mistnim>in short to learn a language without bothering to go to a dictionary, you just click on the word and the translation appears above it
<amz3>that's like http://genius.com annotation but as bookmarklet or extension for browsers
<amz3>you can do that in guile and with mistnim browser i guess at some point
<amz3>mistnim: you are right there is no opensource alternative
<amz3>I will think about it, but it could be added as separate route in my web app
<amz3>that said, it will require a javascript bookmarklet
<amz3>it's possible to do
<amz3>it's kind of separate from what I am doing now
<amz3>patch welcome ;)
<mistnim>well, it's not strictly necessary, the user could just copy/paste the the text to the app and than study it there
<amz3>search://guile+dictionary+github points to a project of mine
<amz3>mistnim: true
<amz3>mistnim: there is a library in guile that does retrieve grammatical information about words, I don't find it right now
<amz3>mistnim: give me a word
<amz3>let's imagine you highlight 'search'
<amz3>you get http://conceptnet.io/c/en/search
<amz3>this program will load the database from the above website
<amz3>and store in a database that you can access in guile
<amz3> https://framagit.org/a-guile-mind/culturia/blob/wsh-inverted-index/src/conceptnet.scm
<amz3>then you can query the data using minikanren (see http://minikanren.org/)
<amz3>I don't have a web app that reproduce the web ui of conceptnet.io
<amz3>patch welcome !
<amz3>neither can i reproduce the dataset...
<amz3>I started something somewhere but it's very difficult to parse wikitionary
<amz3>I can't even tell an adjective from a noun in most cases
<mistnim>that is cool
<amz3>I have a program somewhere that links every word of a sentence to it's conceptnet link and there you can get the wikipedia or wikidata node
<amz3>then display the article...
<amz3>not yet
<amz3>actually
<amz3>but it could be possible
<amz3>the only issue is that it's BIG DATA, you have vast amount of data :/
<amz3>loading the data of conceptnet takes 20 min on my machine, wikidata takes around 1 day
<amz3>but you do that only once
<amz3>in a while ;)
<amz3>I have a screenshot of the app
<amz3>somewhere
<amz3>ACTION firing GNOME
<amz3>also there is the opencog project that is looking for brillant computer scientists
<amz3>see https://wiki.opencog.org/w/Early_2017_Ideas_Page
<amz3>I love this website https://amirouche.github.io/link-grammar-website/
<amz3>disclaimer: it's mine ;)
<amz3>but for a opencog project, it's not official yet, and likely will never be
<amz3>I should mention it somewhere
<amz3>Oh; I found this: https://imgur.com/gallery/W7PGZ7Q/comment/1124380759
<amz3>OrangeShark: what does the comment mean in the above image, my english is laking
<str1ngs>far out is slang for. it's cool
<amz3>I think they think I am lost in space
<amz3>oh
<str1ngs>far out man!
<amz3>tx!
<amz3>so I don't find the correct screenshot
<amz3>anyway, it's exactly the same thing as the left pane of https://i.imgur.com/W7PGZ7Q.png
<amz3>I wondering again about whether culturia is a good name
<str1ngs>well my autotool woes have improved... for now
<mistnim>so many ideas amz3, the thing is, since there isn't much time to graduation date, and I've already just started learning scheme/functional programming, I probably shouldn't do something that would require me to study a new domain. Like AI, which I know very little about. The risk is that I will overshoot the graduation date
<amz3>mistnim: they are subjects that are not about doing AI, myself I am learning the way of AI, I don't do much of AI actually
<amz3>I know scheme for 3 years of free time only...
<amz3>that to be taken into consideration
<str1ngs>I barely know scheme. I came to scheme only due to elisp. but now I'm hooked
<amz3>mistnim: I will reply again with you mail with hopefully more details
<mistnim>yes, I should focus on those subjects, the professors said the will already praise my efforts to learn functional programming, which is not taught at my uni. And doing a relatively simple project would suffice.
<amz3>mistnim: ask daviid about guile gnome when he comes
<amz3>mistnim: if you want to go the gtk route, there is GNU Foliot as example working app
<amz3>or ask dustyweb about anything else!
<mistnim>ok
<mistnim>it's crazy that I have to access the gnu website with a proxy because it doesn't load on my connection
<dustyweb>hi
<amz3>mistnim: maybe your school blocks gnu.org?
<amz3>I am not sure why they would do that tho
<OrangeShark>hello everyone
<amz3>hi both of you
<amz3>guile-wiredtiger was accepted in guix, now you can guix package -i guile-wiredtiger apprently
<amz3>did not try
<amz3>because I embed the source of it in my project but that should not mater
<amz3>for you
<mistnim>is there a library with the for/X constructs like in racket?
<amz3>manumanumanu: ^
<mistnim>ok, I found something similar, SRFI 42
<manumanumanu>mistnim: I hae one
<manumanumanu>that is faster than the included srfi-42
<manumanumanu>it generates very pretty code
<manumanumanu>2 sec
<manumanumanu>the only limitation so far is that you can't add your own sequence types yet
<manumanumanu> https://bitbucket.org/bjoli/guile-for-loops
<manumanumanu>but I have the most common ones (in-list, in-vector, in-string, in-hash, in-hash-pairs, in-port, in-lines, in-range, in-naturals
<manumanumanu>oh, and the body-or-break clause doesn't work. in racket you can write (for ([a 2]) #:break (= a 1) (display a)) but I don't support that
<manumanumanu>The upside compared to srfi-42 is that I use no mutation (apart from a destructive reverse! in for/list) which makes everything (apart from for/list) continuation safe. There is a safe for/list for those who want continuation safety.
<manumanumanu>it is also quite a bit faster
<manumanumanu>the downside is that there is no safety-checks. Racket can rely on it's jit to make efficient code that removes redundant safety checks. guile cannot.
<mistnim>nice manumanumanu
<manumanumanu>mistnim: docs are here: https://koketteriet.se/software/guile-for-loops/docs.html
<manumanumanu>it is all in decently portable scheme. I use guile/racket-style keywords, but it should be easy to port to any other scheme that supports syntax-case and keywords
<manumanumanu>oh, and another upside: the macros expand faster than srfi-42 :)
<manumanumanu>at least on my computer
<manumanumanu>I'm pretty proud :D
<manumanumanu>there are some other small things that I had to change to make efficient code in the absence of a JIT, but it is documented in the docs.
<manumanumanu>stis: God kväll! How are things going?
<stis>manumanumanu: I'm following the aftermath of an event in Stockholm today.
<stis>It's about an invention of a very controversial figure Andrea Rossi which many is skeptical, others belive and they spend eons of electrons debating. Fun!
<stis>I'm skeptical, but if it will freeze down there I would like to see it from the beginning.
<stis>err see it -> follow it
<manumanumanu>stis: I remember that guy from a couple of years ago.
<stis>yeah he still tries to get attention. We'll see but from the peanut gallery frontline there is not much of proofs to show off, don't hold your breath for it getting below zero down there :-)
<manumanumanu>Well then, that is enough scheme for today. Have a good night!
<stis>night!
<ArneBab_>manumanumanu: did you already consider making a SRFI from your for-loops?
<pokes_>i'm trying to wrap my mind around delimited continuations and there's a point where my understanding breaks down: if i do
<pokes_>(set! dcont (% (begin (display (abort)) (newline)) list))
<pokes_>((car dcont) "hello world")
<pokes_>everything's dandy; but if i do:
<pokes_>(set! dcont (% (begin (display (abort)) (newline) (display (abort)) (newline)) list))
<pokes_>i naively expect the continuation i get back to display what i pass to it, and then give me back a second continuation at the second abort
<catonano>pokes_: the seasoned schemer has a nice discussion of delimited conts for multithreading
<pokes_>catonano: i'll check it out. i'd vaguely heard of it but i would have assumed due to its age it wouldn't have much on delimited continuations
<catonano>pokes_: it might be that it discusse vanilla continuations, not delimited. I read the chapter and it seemed well written