IRC channel logs

2017-11-13.log

back to list of logs

<happy_gnu[m]>Hello \\o/
<happy_gnu[m]>Where can I read more about this type of AI
<happy_gnu[m]>I have no idea how to design it
<davexunit>does anyone happen to know how to specialize how a goops accessor sets a value?
<davexunit>I want (set! (bar foo) 'frob) to do more than just (slot-set! foo 'bar 'frob)
<daviid>davexunit: there is an option for that
<daviid>in the slot definiti0n itself
<daviid>let me find an example for you
<daviid>#:slot-set! (lambda (self value) <your code here>)
<daviid>davexunit: another way is to define a setter or an accessor and writ a method for it
<daviid>that might be cleaner, becuse at some point you want to actually call (slot-set1 name value) ... the above example I use only for virtual allocation ...
<daviid>*slot-set!
<daviid>hth
<daviid>davexunit: not sure I was clear but you would would specify an accessor n the slot def, then write a setter method, within which you call slot-set! ...
<daviid>here is an example http://git.savannah.nongnu.org/cgit/grip.git/tree/grip/clutter/bouncer.scm - when a user sets the colour of a bouncer, more has to be done then 'just' slot-set! ... - (line 68: (define-method ((setter !colour) (self <clus-bouncer>) rgba) ...
<davexunit>daviid: the #:slot-set! slot option seems to only work for virtual slots
<davexunit>daviid: a-ha! (define-method ((setter ...) ...) ...)
<davexunit>that sheds some light on things
<davexunit>thanks!
<daviid>davexunit: yw!
<davexunit>that's some brilliant stuff
<daviid>thank you!
<laertus>i'm trying to compile guile-wm, and configure tells me: "error: required guile module not found: (xcb xml)"
<laertus>how do i install those modules?
<OrangeShark>laertus: install guile-xcb
<OrangeShark> https://github.com/mwitmer/guile-xcb
<laertus>guile doesn't have a package manager i could use
<laertus>?
<OrangeShark>laertus: a lot of people are using GNU Guix as their package manager, but you can install the module yourself
<laertus>ah, guix, yeah... that's way too heavyweight for me, unfortunately
<OrangeShark>laertus: xcb doesn't have any dependency
<laertus>yeah, i'll do it manually
<OrangeShark>so you can install from a release
<amz3>héllo all :)
<OrangeShark>hello amz3
<kristofer>hello!
<OrangeShark>hello kristofer
<kristofer>I've been coding up a web app with artanis.. it's doable but particularly frustrating that the art work command doesn't spawn a repl server for geiser to connect to. I have attempted to spawn one from the ENTRY file with (spawn-server ..) -- if I connect geiser to the socket, artanis crashes.
<kristofer>excitingly, using the guile server instead of ragnarok does the trick.
<happy_gnu[m]>kristofer: hi!! I can't help because I am too noob but can you share your code with me and an artanis link :)
<happy_gnu[m]>I want to learn !
<kristofer>happy_gnu[m]: there is a pretty simple tutorial at http://web-artanis.com/ and the documentation is detailed
<amz3`>hélllo #guile :)
<amz3`>monday, a new beginning...
<amz3`>about the gentleman that added autotools to my project, he is working on graph stuff
<amz3`>something about mowing stuff a getting the shortest path to do it
<amz3`>but it's still no ready for production (tm)
<amz3`>incoming a guide about writing web apps in racket https://gumroad.com/l/serverracket#
***apteryx is now known as Guest6762