IRC channel logs

2017-11-12.log

back to list of logs

<adfeno>What is a good tutorial for starting to program in Scheme, for non-programmers?
<mwette> http://download.plt-scheme.org/doc/205/pdf/t-y-scheme.pdf
<adfeno>Oh... thanks mwette :)
<happy_gnu[m]>adfeno: The Little Schemer!
<adfeno>:)
<happy_gnu[m]>adfeno: https://7chan.org/pr/src/The_Little_Schemer_4th_2.pdf
<happy_gnu[m]>Also How to Design Programs and SICP of MIT
<adfeno>SICP is a good one :)
<adfeno>... also it is at-least-shareable :)
<happy_gnu[m]>How to Design programs is CC BY-NC-ND
<adfeno>+1 :)
<mwette>ACTION is out for the night
<noxdafox>greetings, do you know if there's any support for pathname matching in guile similar as for the fnmatch function?
<mwette>noxdafox: you could write it pretty quick using ffi interface, I think
<noxdafox>that's what I am doing, weird it's missing tho as it's pretty basic
<noxdafox>I found some e-mail on guile-devel dated back to 2001 but not much more
<mwette>noxdafox: http://paste.debian.net/995335/
<noxdafox>mwette: thanks! I was half way through :D
<noxdafox>had some issue with dynamic-link which got me stuck
<noxdafox>so calling dynamic-link with no arguments leads to libc being linked?
<noxdafox>nice! it was not documented and didn't dare to try
<mwette>noxdafox: it depends. On my mac if I use dynamic-link a library I can later refer to routines using (dynamic-link). That does not work on Centos.
<mwette>but yea. If bound into guile I think yo ucan use just (dynamic-link)
<noxdafox>debian works as well
<ArneBab>OrangeShark: would you allow me to include your article in with-guise-and-guile? It would be a great match: http://www.draketo.de/proj/with-guise-and-guile/index.html
<ArneBab>OrangeShark: with-guise-and-guile is a project which I want to develop into something like an unregularly published collection of articles focussed on elegant and efficient Scheme. I’m working with org-mode because I want to be able to easily turn it into editions (i.e. yearly collection) as PDF, epub, …
<ArneBab>currently the design just provides the bare basics, but that can easily be changed by editing the theme :) (so I can do it while also working on the content)
<OrangeShark>ArneBab: sure, you can do it :)
<ArneBab>thank you!
<OrangeShark>that seems like an interesting project idea.
<daviid>who says python is beautiful? and who wants non-programmers to read and edit your code? :) (teasing time...)
<ArneBab>OrangeShark: let’s get the licensing done right away. Is cc by-sa ok?
<ArneBab>(cc by would make it even easier, but I’m not sure whether it wouldn’t have bigger drawbacks)
<ArneBab>daviid: obviously I do ☺
<OrangeShark>ArneBab: that is what it is currently licensed as
<ArneBab>ah, great!
<ArneBab>(dang, I missed the footer. Sorry)
<OrangeShark>ArneBab: that is okay
<OrangeShark>I've been wondering if we should really all get together and try to reorganize all the projects and documentation together
<ArneBab>I think that’s a pretty large task
<OrangeShark>yeah, but I think it is something we need.
<ArneBab>OrangeShark: is it something you’d like to do?
<OrangeShark>ArneBab: yeah, I keep thinking about it. There is a bunch of things I want to do to try and help Guile.
<ArneBab>do you think you could finish it?
<ArneBab>(that’s the really hard part about this)
<ArneBab>OrangeShark: I added your article: http://www.draketo.de/proj/with-guise-and-guile/guile-projects-with-autotools.html
<OrangeShark>ArneBab: awesome :)
<ArneBab>and the articles now all have license footers
<OrangeShark>ArneBab: not sure, how would you ever know if you have finished?
<ArneBab>that’s the first question to ask before starting the task :)
<ArneBab>for with guise and guile: One task is done when one issue is released
<OrangeShark>it really seems like something that needs to be continually maintained as Guile evolves
<ArneBab>OrangeShark: then it should live in the texinfo files
<ArneBab>to help to keep it matching the source
<OrangeShark>books and articles should also play an important part
<ArneBab>yes, but fragmentation and stale projects have a cost
<OrangeShark>I was reading online what negative point that guile has is the libraries. When you compare it to something like racket, they are all use the same documentation format
<ArneBab>(especieally when stuff is highly coupled)
<ArneBab>ah, so you mean, going through libraries and making them more canonical?
<ArneBab>that sounds like something which would have a purely positive impact — but also like hard work
<OrangeShark>yeah, it a lot of work
<ArneBab>but then, it can easily be split up into tasks you can finish
<ArneBab>each library is one
<OrangeShark>yup
<OrangeShark>would be great if it was more consistent, so same build tools and documentation.