IRC channel logs

2017-10-24.log

back to list of logs

<kevinfish>getting a bunch of these kind of errors while compiling the latest guile. Any ideas?
<kevinfish>ake[2]: Entering directory '/home/kevin/0work/guile-2.2.0/bootstrap'
<kevinfish> BOOTSTRAP GUILEC language/cps/effects-analysis.go
<kevinfish>;;; WARNING: loading compiled file /home/kevin/0work/guile-2.2.0/bootstrap/language/cps/dce.go failed:
<kevinfish>;;; ERROR: In procedure load-thunk-from-file: Invalid argument
<kevinfish>I did crash during the middle of it. Make I should make clean and start again?
<dsmith-work>kevinfish: Make sure you don't have another guile somewhere.
<kevinfish>oh god, I gotta lot of guile :)
<dustyweb>does anyone have an example of match-let I can look at?
<dustyweb>oh nm
<happy_gnu[m]>dustyweb: that's interesting please share what you found with me
***vicenteH` is now known as vicenteH
<manumanumanu>Ahoy ahoy!
<manumanumanu>What a wonderful morning!
<manumanumanu>I have been thinking about srfi-127. It is called light-weight laziness, but the most useful generator is the coroutine one, which I guess most schemes will implement using call/cc (apart from guile and scheme48). That it not light-weight at all
<manumanumanu>For it to be, a scheme would have to implement an efficient generator
<dsmith-work>{appropriate time} Greetings, Guilers
<sirgazil>Let's say you copy some code with unconventional indentation from the Web and paste it in your Emacs. What do you use to reindent code?
<sirgazil>How do you reindent a region or the whole file?
<daviid>sirgazil: place the cursor at the beginning of the sexp and hit M q
<sirgazil>daviid: Nice. I'll try it...
<daviid>sorry. it is M C q, not M q
<sirgazil>daviid: M q did some reindentation, though. Let me see the difference...
<rekado>C-M is always for s-expressions. C-a is beginning of line, C-M-a is beginning of sexpr; same for -e, -b, -f, etc.
<dustyweb>wingo: I'm trying to figure out how to model the following in fibers:
<dustyweb>I need to wait on read from a websocket *or* after a certain amount of inactive time, send a ping
<cmaloney>Wouldn't that be a UNIX alarm?
<cmaloney>or are you looking for something cross-platform?
<dustyweb>wingo: it doesn't seem we have a good way to compose read/write suspension with the rest of the fibers CPS choice-operations
<dustyweb>cmaloney: I know how to suspend for sleeping but
<dustyweb>I don't have a good way to interrupt waiting on reading
<dustyweb>I guess
<dustyweb>the right way to do it would be to spawn the reading thing into its own fiber, maybe, as well as the timer
<dustyweb>and have both of them send to a shared sink
<cmaloney>Can't the fiber itself set a SIGALRM?
<cmaloney>and whenever it gets data it resets the SIGALRM?
<dustyweb>cmaloney: there's already a sleep mechanism
<dustyweb>cmaloney: the issue is that the read/write/system event mechanisms we have don't compose with the CSP choice operations
<cmaloney>Perhaps I'm solving the wrong problem then
<dustyweb>wait I think I already know the answer
<dustyweb>I'm a moron
<cmaloney>I don't think that. :)
<daviid>ACTION thinks dustyweb is a top notch hacker
<dustyweb>well I'm certainly not at my optimal thinking ability right now
<dustyweb>thanks cmaloney, daviid
<dustyweb>I was up until 3am trying to get this thing working
<dustyweb>well
<dustyweb>the test suite working
<dustyweb>and I did
<dustyweb>but then it turned out deploying it was another matter X_X
<dustyweb>so I'm working on one of my other TODO list items while I compile a new version of guile and a new guix system build
<dustyweb>so many yaks deep
<cmaloney>feel the skin of the freshly shaven yak