IRC channel logs

2017-09-27.log

back to list of logs

***darthlukan_ is now known as darthlukan
<galex-713>Damn the python ecosystem impress me
<galex-713>Is there any way of calling python from guile?
<galex-713>People just dropped lot of flyers about some centralized proprietary local social network in my college, and I just found the reverse enginering of its api on github
<galex-713>plus a more recent node.js webapp version which has the newest update keys
<galex-713>oh I found pyguile on github
<galex-713>is it somewhat known around guile community?
<galex-713>Because it seems a lot useful
<galex-713>damn it’s from 2008 and based on guile 1.6 :/
<galex-713>any way of importing python objects into guile otherwise?
<galex-713>Just heard you could use FFI for that…
<amz3`>héllo all
<amz3`>dustyweb: did you have a look at argon2i, the recommend algorithm to hash passwords?
<amz3`> https://github.com/P-H-C/phc-winner-argon2/
<amz3`>how do you generate cryptographically secure random bytes?
<amz3`>seems like Python's argon2i bindings is using /dev/urandom
<amz3`>got it
<amz3`>I made some bindings for argon2i http://paste.lisp.org/display/356996
<amz3`>(using /dev/urandom for generating the salt)
<amz3`>I need to deal with secure cookies now
<galex-713>amz3`, oh hi, what are you doing currently?
<dustyweb>amz3`: secure cookies are supported in guile-webutils
<dustyweb>I have signed cookie based sessions support
<dustyweb>look at pubstrate to see how it's used
<dustyweb>ACTION really needs to make a guile-webutils release!
<dustyweb>I haven't looked at argon2
<dustyweb>I forget even what I used in pubstrate; it was whatever I was able to use from gcrypt
<dsmith-work>{appropriate time} Greetings, Guilers
<manumanumanu>Good afternoon! What are you all up to today?
<amz3`>manumanumanu: I am coding a blog engine
<manumanumanu>amz3`: nice! I myself is trying to re-implement guile's reader in scheme so that I can do all sorts of funny things :)
<manumanumanu>It's about time we had reader macros :D
<manumanumanu>or at least some sort of not so low level parsing utility. As it is right now, even using hash-readers is a pita if you want to delimit them with anything else than ( or [
<manumanumanu>say #{(a b) (+ a b)} -> (lambda (a b) (+ a b))
<manumanumanu>but unless you also turn on curly infix, } is not a recognized token, and will be read as a part of a symbol by read, so you will have to more or less scrap together your own reader
<davexunit>we do have reader macros. guix uses them.
<manumanumanu>oh, but that is using a third party library that won't compile for be
<manumanumanu>(my own fault, my system is in a very sad state)
<manumanumanu>guile-reader is exactly what I want.
<manumanumanu>it looks fantastic
<davexunit>I just double-checked and guix doesn't depend on guile-reader
<manumanumanu>what am I missing then?
<davexunit>dunno
<davexunit> http://git.savannah.gnu.org/cgit/guix.git/tree/guix/gexp.scm#n1179
<davexunit>here is where guix defines a reader macro
<manumanumanu>is it using read-hash-extend?
<OrangeShark>manumanumanu: yeah, looks like it
<davexunit>yes
<manumanumanu>what I am trying to do is to write a general thing to work with tokens
<manumanumanu>anyway. work in progress
<davexunit>in general I think it's a bad idea to write reader macros
<davexunit>but there are very rare cases where it is useful
<davexunit>people talk about hash tables a lot but they really shouldn't have a read syntax
<davexunit>reader macros don't compose
<amz3`>manumanumanu: I tried to code my own 'read' procedure, the task seemed daunting especially if you want to make the reader configurable
<amz3`>manumanumanu: also, reporting errors was not perfect
<dsmith-work>manumanumanu: Day job: embedded python on Linux talking to AWS with MQTT and devices using ANT.
<dsmith-work>*really* grooving on magit!
<dsmith-work>Finnaly found out how to split a commit when rebasing.
<dsmith-work>Magit is *fun* !
<dsmith-work>manumanumanu: No guile unfortunately
<amz3`>galex-713_: I am working on a blog engine
<amz3`>galex-713_: what are you up to?
<davexunit>fyi, for static blogs, there is already something available: https://haunt.dthompson.us/
<amz3`>Yes, I know, tx. I need something that can handle comments and stats
<amz3`>it's mostly an excuse to code something that is too complicated
<amz3`>I mean somewhat complex but not too much
<galex-713_>amz3`, restarting studies
<amz3`>galex-713_: computer science?
<galex-713_>amz3`, yup
<amz3`>galex-713_: cool
<galex-713_>beh
<galex-713_>they’re saying students to do Visual Basic .NET on Windows 10 with Visual Studio by designing gui with a gui…
<amz3`>ouch!
<amz3`>ahem
<amz3`>we need everything to do a world ;)
<OrangeShark>galex-713_: that sounds fun :)
<galex-713_>OrangeShark, sarcasm?
<OrangeShark>yes
<galex-713_>ah, lol then x)
<OrangeShark>I guess that is one of the intro classes?
<galex-713_>it is the intro class
<galex-713_>first semester java, then C
<galex-713_>err vbnet
<galex-713_>first semester vbnet here
<galex-713_>then C
<galex-713_>then java
<galex-713_>and some ocaml
<OrangeShark>I wish I went to a school where the intro class was scheme :)
<galex-713_>I thought the same thing x)
<OrangeShark>I think some schools still use scheme in their graduate programs
<galex-713_>especially that racket/pltscheme/drscheme was made for that purpose in that context
<galex-713_>it’s sad guile hasn’t all the nice features of racket
<OrangeShark>well guile is growing so we can always keep trying to improve
<galex-713_>still growing? I’m not following that much
<OrangeShark>well guix has helped attracted more people and there is some pretty cool stuff planned on the roadmap for Guile 3.0 or whatever next major version
<galex-713_>native compilation?
<OrangeShark>yeah that is one
<galex-713_>I don’t understand how guix can attract that much people
<OrangeShark>one of the google summer of code projects had compile to JS
<galex-713_>r7rs and guile emacs would be cool
<OrangeShark>well guix uses guile, so when people want to enhance or extend, they are going to get involved in guile.
<galex-713_>ah no I don’t mean that
<galex-713_>I mean, how guix can attract that much people to itself
<galex-713_>I mean it’s natural to attract people to the lisp dialect you’re coded in
<galex-713_>like emacs did
<OrangeShark>I am not sure, but guix has a lot of activity.
<galex-713_>yeah I noticed that
<OrangeShark>I would like to see r7rs support and guile emacs as well
<amz3`>galex-713_: a lot of people are attracted to guix, I remember the only foss contributor I new at school was in the distribution space
<amz3`>s/new/knew/
<amz3`>sorry
<amz3`>they think it's easy
<amz3`>idk actually why some much people are attracted by working on distros
<galex-713_>especially that I heard it has poor dependency working
<amz3`>dependency? in guix?
<galex-713_>yeah
<galex-713_>it seems to be less good than debian from the outside
<amz3`>I would not say poor, but opiniated
<galex-713_>(well from what I heard from the inside)
<galex-713_>yeah both :P
<galex-713_>debian has rich dependency working
<galex-713_>ie “bloated” if you don’t like/use debian
<amz3`>what I miss in guix, is to be able to fine tune my build to make it very fast like gentoo
<galex-713_>I’d like to see some compatibilities/gateways between guix and debian
<janneke>amz3`: i'm contributing to guix because it's not `a distro' to me
<galex-713_>yeah it’s like gentoo or LFS
<galex-713_>more a metadistro
<galex-713_>yet it doesn’t explain why it attract more people than gentoo or LFS
<amz3`>janneke: what do you do in guix? cuirass?
<janneke>amz3`: i'm mainly working on removing the need for bootstrap binaries
<amz3`>ok
<janneke>i'm adding the occasional package, and do some cuirass work
<amz3`>oh
<janneke>i've moved all my machines to guixsd and am moving my primary client's ecosystem from ubuntu to guix
<amz3`>ah
<amz3`>I had again trouble installing guix 0.13 on debian inside an lxc
<amz3`>I am not moving right now
<amz3`>I feel stupid, but it's a real story
<janneke>yeah, it's not too friendly yet, many rough edges
<amz3`>tx
<amz3`>for saying it
<amz3`>I am not against the cli/scheme based installation process
<janneke>i'm just totally taken by the idea to declaratively describe your whole os using guile...amazing
<amz3`>it's just that 'guix pull && guix package -u' fails
<amz3`>janneke: me too
<galex-713_>yeah me too
<janneke>yup, installing it might be very easy, or terribly difficult depending on circumstances
<janneke>esp. the bit-for-bit reproducibility feature that guix adopted i think is amazing
<janneke>just don't feel bad if it doesn't work for you yet
<stis>heay wingo:
<stis>I got a few questions.